Jump to content

Haswell ML on Gigabyte GA-H87M-D3H + GTX 770 + Intel® Core� i5-4430 PCI configuration begin

4 posts in this topic

Recommended Posts

Hi guys. I tried following advice from here http://www.insanelymac.com/forum/topic/290434-how-to-install-mountain-lion-on-a-haswell-machine-without-1085/ and add custom mach_kernel to install drive, and unfortunately I am stuck "PCI configuration begin"

So here is what I did:


  1. Downloaded latest ML on my Macbook Pro
  2. Using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] I created a bootable drive
  3. I downloaded mach_sse4_exts
  4. Renamed it to mach_kernel
  5. Overwrote the original one on the drive using console
  6. In BIOS I did:
    1. Set SATA mode to AHCI
    2. Set my USB as first priority boot drive
    3. Enabled EHCI and xHCI
    4. Disabled VT-d
    5. Disabled onboard graphics


I didn't even try to use standard installer and started with: -v GraphicsEnabler=No

And I hit "PCI configuration begin"
Later I tried a lot of different flags(with and without GraphicsEnabler=No):

  1. npci=0x2000
  2. npci=0x3000
  3. -x
  4. -f
  5. PCIRootUID=1
  6. PCIRootUID=0
  7. cpus=1

I used those in different combinations( I confess - I didn't write every of those down and don't remember by heart anymore, but I can go through once more),

but the only thing that allowed me to proceed to the next step was: pci=off.
Problem with that was that it was stuck on a next step which was something like "console 1024 x 768 @ ...." (there was a number in hex where I have put dots, not sure if it's relevant)
Any help is very appreciated, after this one is successfully installed I will put together a full guide for community benefit.


Link to comment
Share on other sites

Hi MoP,


I have a Gigabyte z87x-ud4h + GTX 760 running Mavericks Dev Preview with the same exact issue.  Can boot fine in safe mode (-x) but booting normally I'm stuck at PCI configuration begin.  Tried what you've tried and no luck.


Hope you find a solution.  If I find a fix I'll post back and hopefully it will help you as well :D

Link to comment
Share on other sites

This is embarrassing :blush:, figured out my problem while installing HWMonitor (app that shows system temps, fan rpm, etc).  I was missing FakeSMC.kext in S/L/E.


Installed that along with HWMonitor and can boot normally... added bonus GTX 760 appears to work out of box with acceleration in 10.9!  Now going to check on the small stuff like audio and bluetooth.

Link to comment
Share on other sites


  • Create New...