Jump to content

iAtkos ML2 / boots only safe mod / ASUS P5Q Turbo / IDE Drive

6 posts in this topic

Recommended Posts

System specs:


ASUS P5Q Turbo 

Intel Core 2 Quad Core XEON

500 Gb IDE drive (triple boot with Windows 7 / iAtkos L2 (working - no specific video driver) / iAtkos ML2 (only safe mode)

nVidia GeForce 610M




Last year, I successfully installed iAtkos L2 on my system. I had an old graphic card which was not working with OSX lion anyway. Just had to delete the drive ATIRadeon(xxx).kext and things where working fine. I had to replace this kext from this link:


AppleVIAATA.kext .

This all went well.
This year I decide to go with iAtkos ML2. Burned at DVD DL... Try to install but kept getting waiting for device.
Finally figured that it was not seeing my IDE drive.
So I modified my iAtkosML2.dmg (by using the hdiutil convert tool). Then added the the AppleVIAATA.kext to it. Then burnted another DVD DL. This time it worked but it is extremely slow at some steps. 
So installed it all with specs coming from another forum:
Then I used my OSX Lion partition to boot and copied into the ML drive /System/Library/Extensions the AppleVIAATA.kext file.
Rebooted with ML in safe mode and things are good.
Tried various scenarios to get it to boot in normal mode but hangs near the end of the boot.
The boot log is very similar at the end whether it is in safe mode or normal mode.... Just wondering if anyone has similar problems. 
BTW I just changed my graphic card for a newer one hoping that it would solved the problem but no...
Any ideas ?
Link to comment
Share on other sites

Hopefully you're using a SATA hard drive. Connect it to the ICH10R (set to AHCI mode in the BIOS) instead of the off-chipset controller.


Look up which ports belong to which controller in your motherboard manual.

No, as I stated, I have IDE drive. My BIOS settings are fine since it works on Lion... but thx anyhow

Link to comment
Share on other sites

Sorry, I missed that part.


Maybe you should be using a JMicron driver instead of the AppleVIAATA.kext.

Any links for that ?



I actually tried to remove all video kext as stated in this link:




That worked !


Anyhow... would be better if I could get a native driver... but for the meantime that's a good start. 


Let me know where I can get the jMicron driver ... Thx !

Link to comment
Share on other sites

I've never hackintoshed anything with a jmicron controller, sorry. I know there are several, use google or the forum search to find out which one is best for you, there are several threads on the P5Q series motherboards here and many other motherboards use the same jmicron controller as well.


But if removing your video drivers solved your problem then just stick with your VIAATA driver no?


I like how you picked your own post as best answer. kind of like liking your own post on Facebook.

Link to comment
Share on other sites


  • Create New...