Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
pantag77

GTX 670m or i7-3630QM hd4000.

5 posts in this topic

Recommended Posts

I tried use hd4000 with deleting other (nvidia) Kext. but It does not work. 

my laptop is Optimus system  (Toshiba Qosmio x875 q7390) 

When I use GE=Yes  GeForce GTX 670M 3072 MB

When I use GE=No Display 7mb ( but there was 'nvidia display' at System Report even I deleted all nvidia kext)

 

I not sure I can QE/CI with my GTX 670m.

If it is impossible. I like to use HD4000. I think I need Right DSDT for my laptop.

please help me.  

 

I attached my DSDT and IORE

dsdt.zip

Chad’s MacBook Air.zip

Share this post


Link to post
Share on other sites

Optimus technology does not work with OS X so that is the major issue. I believe the most used solution is to edit the DSDT to remove the nVidia card information in order to use only the iGPU. It should also be possible to use the dedicated graphics card (you should already be aware of this), but that uses more battery life. 

Share this post


Link to post
Share on other sites

Thank for your reply. 

 

You mean that even I use DSDT.aml to change from GTX 670M to GTX 650M,

(http://www.insanelymac.com/forum/topic/281835-no-acceleration-on-nvidia-gt650m-on-mountain-lion-108/) which was your issue.

 

I never work QE/CI by my Nvidia card Right?.

 

Then do have any DSDT.aml to remove the nVidia card information ?

CUZ I have been tried but It is possible I used wrong files or wrong ways.

Share this post


Link to post
Share on other sites

Did you try the solution posted in that link. It seems to be the case that if you have the option to disable the Intel HD 4000, then you can get the nVidia card to work correctly by using the right SMBIOS. Otherwise, you'll have to use DSDT edits to use the Intel HD 4000 only. You also seem to be using a Macbook Air SMBIOS. You should try a Retina Macbook Pro SMBIOS with the nVidia card enabled. 

Share this post


Link to post
Share on other sites

I tried to open hidden bios option to disable the Intel HD 4000. (Insyde) http://www.jakobheinemann.de/j-bios.html

I do not know why, It does not work.

I gave up to use nVidia card.

 

So I tried to DSDT. Change  AAPL,ig-platform-id. When I try to make my DSDT.aml

 

 "AAPL,ig-platform-id",\n
            Buffer (0x04)\n
            {\n
                0x03, 0x00, 0x66, 0x01\n
            }\n
        }, Local0  by DSDTEDITER,

 

compile get errors. I couldnot get it.

 

most that I can not understant is why I can not stop to get Osx on my laqtop..........

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×