Jump to content

[Solved] Asus X52F impossible to start with ML 10.8

10 posts in this topic

Recommended Posts

Hi all and please excuse my english.


I tried to install ML 10.8 on laptop in my signature, but I failed with both pandora's box and Iatkos ML2. I tried with niresh 10.8.2 and I did it, but the first restart fail, I can't creat an account. I tried with many flags, (one by one and together) -X, -V, GraphicsEnabler=No, npci=0x2000/0x3000, -F, cpus=1, and, recently, also PCIRootUID=1 and dart=0, as suggested me in the italian forum:




but i failed.


I have another partition with windows 7 and the Paragon HFS+ installed, so I can read and write the partition with ML from windows. I also extract the DSDT with DSDT editor for windows and I copied it in the partition ML, but it does'nt start anyway.

I attach the screenshots with -V and -X -V


Thank you all.



Link to comment
Share on other sites

Hi there...

The problem is the graphics kext (during -x -v).

-Boot up in -s (Single user mode)

-type in:

#  /sbin/mount -rw /
#  cd System/Library/Extensions
#  mkdir Temp
#  mv AppleIntelHD* AppleIntelSNB* Temp
#  exit
#  reboot

now booting in with  -v should help

Link to comment
Share on other sites

  • 2 weeks later...

Thank you Aju Deeju,


I made what you wrote and it started, I have finished the installation and created my account. Now it start.


I searched the kext for my hardware and installed them with kext wizard, and now this is the situation:

- reboot works but not the shutdown, I have to restart with Windows 7 and shutdown

- keyboard works but not touchpad, I need a USB mouse

- audio does'nt work. I tried with both AppleHDA patched for my audio (downloaded from here


and voodooHDA, but there are no devices founded.

- wifi and LAN should work, even if I have not yet connected (it shows wifi connections and LAN device)

- IGPU must be set, but now it's not a priority.


I don't knok if there is a correlation with something that does'nt works, but I don't installed the bootloader, I start Mountain Lion from usb with the last Chamaleon (2.2 r2254)


Thank you!

Link to comment
Share on other sites

  • 1 month later...

I was able to install the ML 10.8.4 with Pandora's box, so I pray the administrators to close or cancel this topic.


Thank you all for your help.


Big time congrats for your well done install :excl: Now you have a :happymac::excl: You are in this way in heaven :star_smile: :angel: :star_smile: :angel: :star_smile:without any help of the :pope:  or have you sent some prayers to computer universe? :wink_anim:


It is  fair  and  just a little thanks for your gotten support,  as also the  the goal of this community, to share your by yourself made experiences with others.

Therefore please be so nice to tell others the general setting and options, you have chosen, in Pandoras Box.  ;)


Why should this topic  then be closed or  even cancelled??? :whistle: :whistle: :whistle:


Have fun!

Link to comment
Share on other sites

Hi styrian,

I thought to close or delete the topic cause it was opened for the Niresh and to open another one for the problems I have now.

Anyway, I was able to install thank to the last pandora's box, the previous one was unsuccessed.


I selected the option 3, (that doesn't enable the graphics kext during installation), smbios Macbook pro 5.1, but the installation failed. I resolved deleting the folder with backup kext (I don'remember exact name) from Pandora installer and the installation went right without any flag! I'm a little bit newbie, so in the pandora's installation options I selected "Laptop support" and no one else. It's strange because the installation does'nt created the Extra folder in /, and for this reason chamaleon does'nt boot, I have to boot from pen drive. Even copying the Extra folder from Pandora to "/" the pc does'nt boot, and chameleon wizard tells me that can't fint the chameleon.boot.plist, even if I copy it. I extracted and optimized DSDT from windows with DSDT extractor, but if I put it in ACPI folder and/or in Exra folder the boot fails immediatly. About the audio I installed a voodooHDA.kext that sounds good, but the main problem is that I don't have the full graphic acceleration, I think for the same reason, the missing of Extra folder (following the guide http://www.insanelymac.com/forum/topic/286092-guide-1st-generation-intel-hd-graphics-qeci/). Whath else? My pc reboot fastly but does'nt shutdown, cause it miss Modules folder in Extra, and the keyboard works but not the touchpad, the webcam works fine but it's upside-down (but it's a problem of my laptop, in windows is the same).

Bye and I hope I've been useful to anybody

Link to comment
Share on other sites

Open Pandora Postinstall and select enough bootloader. Just do a standardinstall by selecting your installed partion. After remove your stick and reboot. At bootpromt set flag -f -v and look whats happening. I think you should be able to reach the desktop. For not working gfx you should add flag -x.

I have downloaded Pandora and clicked though the options. If  the standard install daes not work it seems to me, that it is a little bit hard for a newbie.


Have fun!

Link to comment
Share on other sites


  • Create New...