Jump to content
InsanelyMac Forum
simconti

DV6-6xxx DV7-6xxx OS X Mavericks 10.9.3

Recommended Posts

(DV7-6180sl) DV6-6xxx DV7-6xxx OS X Mavericks 10.9.3
 

La guida è perfetta quella di carbo178 (Grazie): http://www.insanelymac.com/forum/topic/289753-guida-installazione-os-x-109-mavericks-dp1/


 

 

Installazione eseguita con:

 

• Enoch-rev.2247

 

• fakeSMC + NullCpuPowerManagement + keyboard e ps2 kext

 

• Cartella Extra con: DSDT (grazie Micky1979), SSDT, org.chameleon.boot.plist e smbios.plist (trovate tutto in allegato).

 

• Intel HD 3000 funzionante (eliminazione artefatti con la configurazione EDID + Demone Fan Control 1.2).

 

• Radeon 6770m non funzionante. Disattivata scheda video con bios mod insydeH2O F1.A (L'ho ritenuto necessario per aumentare la durata della batteria e diminuire il surriscaldamento del           notebook).

 

• Sostituita scheda WiFi con Atheros 9285 installato bios mod senza whitelist: insydeH2O F1.A - Funzionante.
 

• Intel audio funzionante con AppleHDA.kext (grazie Micky1979)

 

• Batteria funzionante VoodooBattery.kext

 

• Trackpad - Keyboard funzionante con ApplePS2Controller.kext and ApplePS2Controller.kext

 

• USB 2.0 e webcam funzionante nativamente. 

 

• USB 3.0 kext disponibile: www.insanelymac.com/forum/topic/286860-genericusbxhci-usb-30-driver-for-os-x-with-source/ , more information available

 

 
post-702252-0-24853400-1371418983_thumb.png

 

• Aggiornamento 10.9.1/10.9.2/10.9.3 dopo aggiornamento è necessario ripristinare  AppleHDA.kext patchato.

 

 

• Allego nuovo AppleIntelCPUPowerManagement per ultime versioni.

NUOVO AppleIntelCPUPowerManagement.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

Ciao Sim, arriva Pandora con supporto a Mavericks.....a breve...brevissimo!

Ti allego un AICPMpatch modificato che ho aggiunto in Pandora, per evitare di installare xcode e patchare l'AppleIntelCPUPowerMangement.kext

Complimenti, ...ma quei download li hai fatti già tutti stamattina?? :)

 

Micky

AICPMPatch.zip

Share this post


Link to post
Share on other sites

Grazie Micky, come sai bene sono in attesa del tuo Pandora oramai... da tempo, per vedere il fantastico lavoro svolto...

 

I download :hysterical: sai che non ho fatto in tempo a aprire il topic che già hanno scaricato tutte queste volte.... :hysterical: 

incredibile gli utenti di Insanelymac!!! :hysterical:

Share this post


Link to post
Share on other sites

Ciao Claudio,

io ho usato AppleHDA che trovi sopra nella cartella DV7.

Cmq fai una cosa, te hai sul tuo laptop l'audio IDT 7605 se non ricordo male... Usa il kext di Micky che trovi in Pandora.

Se non funziona prova a cancellare AppleHPET.kext

Share this post


Link to post
Share on other sites

Ciao Claudio,

io ho usato AppleHDA che trovi sopra nella cartella DV7.

Cmq fai una cosa, te hai sul tuo laptop l'audio IDT 7605 se non ricordo male... Usa il kext di Micky che trovi in Pandora.

Se non funziona prova a cancellare AppleHPET.kext

ci provo! perchè con quello tuo non ne sono riuscito a venire a capo. Dovrebbero farti una statua sei gentilissimo davvero!

 

 

EDIT: ho provato con quello sia pandora che uno modificato da un tizio su osx86 ma nulla da fare. Non si attiva, premetto che come dsdt ho sempre quello postato da te per la guida di ML!

 

EDIT2: Ho fatto una clean install eliminando anche ML, ora l'audio va usando il kext di pandora, ho aggiornato alla DP2 e bisogna solo rimettere il kext AUDIO. Purtroppo il problema webcam permane. Non riesco a capire da cosa possa dipendere!

Share this post


Link to post
Share on other sites

Mi intrometto,il mio pc lo supporta? come potete leggere in firma ho un hp dv6500

 

Grazie mille

Se non erro è un modello del 2008, per cui non puoi installare nè Mavericks (ne ML se hai la GMA3100), consigliato 10.7.5 in 32 bit..

 

Micky

Share this post


Link to post
Share on other sites

Ciao a tutti. Ciao Micky.

Ho aggiornato alla DP7, stesso sistema di aggiornamento: occorre ripristinare soltanto AppleHDA che viene sovrascritto dall'upgrade.

Ho notato che le porte USB 3.0 vengono riconosciute da Mavericks ma non funzionano.... prima di mettere il GenericUSBXHCI.kext patchato attendo la versione definitiva.

Share this post


Link to post
Share on other sites

Ciao Sim

come funziona cn mavericks visto che apple scrive upgrade.....FREE!! :rolleyes:  :D 

 

Smigol

Share this post


Link to post
Share on other sites

Ciao, potresti aggiornare il pacchetto e i kext per Mavericks GM?

 

Thanks ;)

Ero in attesa della versione definitiva.... presto metterò tutto l'occorrente. 

Ciao

Ciao Sim

come funziona cn mavericks visto che apple scrive upgrade.....FREE!! :rolleyes:  :D 

 

Smigol

Penso che non ci saranno particolari problemi...

Se vuoi provare fatti un backup prima. 

O magari cerca nel forum se qualcuno l'ha già fatto!!! 

Share this post


Link to post
Share on other sites

Ero in attesa della versione definitiva.... presto metterò tutto l'occorrente. 

Ciao

Penso che non ci saranno particolari problemi...

Se vuoi provare fatti un backup prima. 

O magari cerca nel forum se qualcuno l'ha già fatto!!! 

O magari ci provo ioooo :hysterical: 

:blowup:

Share this post


Link to post
Share on other sites

ciao ragazzi, io dopo l'aggiornamento a 10.8.5 ho avuto parecchi problemi... premetto che usavo il bios non modificato e che con 10.8.2 ero piuttosto stabile.

vorrei provare mavericks ripartendo da zero (su nuovo hard disk per evitare di pasticciare il vecchio su cui ho anche Ubuntu) per cui:

 

1) installerò il bios modificato F1.A

2) proverò a installare mavericks

3) verrò di sicuro a chiedervi aiuto

 

vi chiederei gentilmente già se i DSDT/SSDT presenti negli attachment al primo post vanno bene per il mio modello (in firma), perché ad esempio con ML non mi hai

funzionato VoodooBattery, e se vi funziona l'ingresso audio (line in)

attendo voste intanto mi procuro l'occorrente per procedere...

Share this post


Link to post
Share on other sites

ciao ragazzi, io dopo l'aggiornamento a 10.8.5 ho avuto parecchi problemi... premetto che usavo il bios non modificato e che con 10.8.2 ero piuttosto stabile.

vorrei provare mavericks ripartendo da zero (su nuovo hard disk per evitare di pasticciare il vecchio su cui ho anche Ubuntu) per cui:

 

1) installerò il bios modificato F1.A

2) proverò a installare mavericks

3) verrò di sicuro a chiedervi aiuto

 

vi chiederei gentilmente già se i DSDT/SSDT presenti negli attachment al primo post vanno bene per il mio modello (in firma), perché ad esempio con ML non mi hai

funzionato VoodooBattery, e se vi funziona l'ingresso audio (line in)

attendo voste intanto mi procuro l'occorrente per procedere...

Ciao Gio,

abbiamo lo stesso modello di notebook... il DSDT va benissimo! Strano che non ti è mai funzionato il VoodooBattery, funziona a tutti...

L'audio non è stato ancora modificato...

Prova a sentire Smith nell'altro topic forse lui ha una soluzione o sa come configurare il line-in

Il bios mod ti serve sopratutto per sostituire la wifi o disattivare la scheda video Ati, per ridurre consumo della batteria e per non far scaldare troppo il notebook.... 

Share this post


Link to post
Share on other sites

Ok, per l'audio poi sentirò in caso Smith. Scaricato nottetempo Mavericks, sto per procedere: nella guida di carbo178 non c'è scritto se il disco di destinazione deve avere mappa partizioni GUID o MBR...

In ogni caso installando su nuovo hd da zero penso che faro GUID con una sola partizione e terrò eventualmente gli altri OS su altro hd.

Altra domanda sim: quando installi Enoch/Chameleon per il nostro laptop cosa serve? Solo bootloader o moduli particolari? Kernel patcher? 

Intanto provo solo bootloader + la tua cartella Extra in toto.

 

Vi aggiornerò con i risultati...

Share this post


Link to post
Share on other sites

Missione compiuta. Vi scrivo da Mavericks! Sim, è saltato fuori che VoodooBattery mi funziona SOLO ed esclusivamente con la tua versione di AppleACPIPlatform.kext, non ho ben capito perché...
Per il resto, reinstallato bios mod, disattivato la Radeon, Installato su disco partizionato GUID, e sembra funzionare tutto a dovere, anche se devo ancora verificare il line in della scheda audio. Unica cosa che specificherei ulteriormente nel tuo primo post, io ho dovuto usare il modulo di kernel patching da Enoch (che NON c'era nella tua cartella Extra) altrimenti mi dava panic all'avvio.

Adesso mi manca solo un cavo per installare l'HD vecchio come secondo nel laptop  B) e di reinstallarmi tutto ciò che uso di solito.

Share this post


Link to post
Share on other sites

Missione compiuta. Vi scrivo da Mavericks! Sim, è saltato fuori che VoodooBattery mi funziona SOLO ed esclusivamente con la tua versione di AppleACPIPlatform.kext, non ho ben capito perché...

Per il resto, reinstallato bios mod, disattivato la Radeon, Installato su disco partizionato GUID, e sembra funzionare tutto a dovere, anche se devo ancora verificare il line in della scheda audio. Unica cosa che specificherei ulteriormente nel tuo primo post, io ho dovuto usare il modulo di kernel patching da Enoch (che NON c'era nella tua cartella Extra) altrimenti mi dava panic all'avvio.

Adesso mi manca solo un cavo per installare l'HD vecchio come secondo nel laptop  B) e di reinstallarmi tutto ciò che uso di solito.

Benissimo!!!

Certo che c'è bisogno dell'AppleACPIPlatform patchato, senza di quello non può funzionare VoodooBattery....

Si, la cartella Extra è antecedente a Enoch, quindi manca...

Il kernel patch non l'ho specificato pensando e dando per scontato che non ce ne sarebbe stato bisogno.... :hysterical:  tanto siete esperti....   :hysterical:  :hysterical:  :wink_anim:

Share this post


Link to post
Share on other sites

Benissimo!!!

Certo che c'è bisogno dell'AppleACPIPlatform patchato, senza di quello non può funzionare VoodooBattery....

Si, la cartella Extra è antecedente a Enoch, quindi manca...

Il kernel patch non l'ho specificato pensando e dando per scontato che non ce ne sarebbe stato bisogno.... :hysterical:  tanto siete esperti....   :hysterical:  :hysterical:  :wink_anim:

 

 

Benissimo!!!

Certo che c'è bisogno dell'AppleACPIPlatform patchato, senza di quello non può funzionare VoodooBattery....

Si, la cartella Extra è antecedente a Enoch, quindi manca...

Il kernel patch non l'ho specificato pensando e dando per scontato che non ce ne sarebbe stato bisogno.... :hysterical:  tanto siete esperti....   :hysterical:  :hysterical:  :wink_anim:

ehm... come si fa?  :(  :(  :(

Share this post


Link to post
Share on other sites

Ho seguito il procedimento della guida linkata all'inizio del topic e poi messo i file della cartella DV6 esattamente come indicati nel readme (ho modificato org.chameleon.Boot.plist aggiungendo la Kernel Flag -v) ma non parte nemmeno l'installer mostrando la scritta "Still waiting for root device"

post-354775-13832154775808_thumb.jpg

 

Dove posso aver sbagliato?

 

Ps: premetto che ho utilizzato la release finale di maverick e non la golden master dunque il mach_kernel l'ho estratto personalmente dal pacchetto pensando che potessero essere differenti

Share this post


Link to post
Share on other sites

Ho seguito il procedimento della guida linkata all'inizio del topic e poi messo i file della cartella DV6 esattamente come indicati nel readme (ho modificato org.chameleon.Boot.plist aggiungendo la Kernel Flag -v) ma non parte nemmeno l'installer mostrando la scritta "Still waiting for root device"

attachicon.gifImageUploadedByTapatalk1383215476.129526.jpg

 

Dove posso aver sbagliato?

 

Ps: premetto che ho utilizzato la release finale di maverick e non la golden master dunque il mach_kernel l'ho estratto personalmente dal pacchetto pensando che potessero essere differenti

Ciao Guido,

il problema dovrebbe essere legato al tipo di hdd che hai... è collegato internamente al controller sata?

prova a avviare con -f

Dovresti caricare da Pandora il AHCIPortinjector...

Share this post


Link to post
Share on other sites

Ciao Guido,

il problema dovrebbe essere legato al tipo di hdd che hai... è collegato internamente al controller sata?

prova a avviare con -f

Dovresti caricare da Pandora il AHCIPortinjector...

Ho cambiato l'hdd con un ssd ma il connettore è rimasto lo stesso, è possibile che ci sia qualche configurazione sbagliata nel bios?

Nel frattempo ho creato un'altra chiavetta usb con Pandora e a fine processo sostituito i file della cartella extra e di S/L/E e dopo con kext utility ho fatto Rebuild Cache sulla chiavetta ed è uscita questa schermata al boot

post-354775-13833059407252_thumb.jpg

---EDIT---

l'installer di Windows invece quando devo selezionare il disco su cui installare non mi vede l'ssd. Quindi probabilmente è un problema di config del bios giusto?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×