Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Hackintosh Builds for Every Budget!

1 post in this topic

Recommended Posts

Do you know exactly which parts to get for your machine? Working on a budget? How do you know if your parts will work with OS X with minimal fuss? This thread is dedicated to helping you with your purchasing requirements! Here's how it works. RampageDev has kindly put together a pricing guide from NewEgg for four rigs at four approximate price points: Baseline, Deluxe, Ultra, and Killer.


Baseline gets you a powerful rig, suitable for nearly everything you'll ever need to do on your hackintosh for day-to-day useage. Deluxe gets you more performance, and Ultra gets you into the maxed out, the top-of-the-line, and nearly all the bells-and-whistles territory. And last, but certainly not least, Killer gets you an X79 rig!


These rigs are nearly hassle free, or at least as close as you can get with OSX on PC components!


This list is available HERE in the Buying Thoughts, Reviews and Recommendations Forum.

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By noisegate
      Hi all,
      I use this setup (X79 Deluxe - 4930K - HD6870) as an audio rig. It all works fine, I'm only experiencing stability issues with everything USB (audio sound card, MIDI controllers). Logic Pro X keeps randomly losing sync with them.
      I installed GenericUSBXHCI (v1.2.11) from the rampagedev X79 dmg. Has anyone successfully used other USB kexts? I mostly use USB 2 ports.
    • By Peerke
      (Mistakenly posted in 'Installation Guides' at first)
      A couple of weeks back I took the plunge and upgraded my system from Yosemite (10.10.5) to Sierra 10.12.6. Reason for doing that was that I wanted to upgrade my graphics card from a GTX 960 to a GTX 1060. I followed Rampagedev's procedure and used his DMG to upgrade. I also installed the nvidia web driver 378.05.05, and I installed an Intel 750 PCIe NVME SSD, using Pikeralpha's NVME patch and included the NVME drivers from a Gigabyte Z97 board on the GA-X79-UD3, as the X79 board originally does not support NVME. 
      So, I can boot from the Intel SSD, but it takes about 3 or random 4 kernel panics and reboots before I get to a login prompt. Once logged in everything works fine and the system is stable. I saw the same behaviour when everything was still on a SATA SSD, so I do not suspect the NVME drivers and patches to be the culprit. The KPs can happen at different stages during boot, sometimes even when I am logging in. But once logged in, everything is ok.
      Another thing that bothers me is USB3. I installed USBXHCI_FL1009.kext, also from the Rampagedev DMG, but the results are flaky. A USB3 USB-stick is recognised, as is my card reader, but an external (bus-powered) USB3 drive from Seagate is completely ignored when inserted. I did turn off USB3 during the upgrade, but it is switched back on now.
      The original install was with Mavericks, and I upgraded that too to Yosemite. I never tried a clean install as that would take a lot of work to migrate and relicense all my apps. 
      So, in terms of system goodies:
      Mobo: Gigabyte GA-X79-UD3
      CPU: Intel 4930k
      OS: Sierra 10.12.6
      Nvidia web driver: 378.05.05
      GPU: MSI GTX1060 3GB
      Boot drive: Intel 750 NVME PCIe SSD
      Clover: 4220
      Anyone that can help to solve the kernel panics and the USB3 issue?
      Enclosed my complete EFI folder, IOreg, ACPI tables and kextstat.txt.
      Any help is appreciated. Thanks.
        Toms MacPro.ioreg.zip
      Send me Toms MacPro.zip
    • By cheneyveron
      Hi guys,

      My computer hardware is i signature.
      Currently, 10.12.6 is perfect and my EFI is here.

      Problem Description:
      When I tried to boot 10.13 DP5, I encountered AppleACPIPlatform problem:

      Typical Causes and Solutions:
      After searching google for couple of days and with the help of @PMheart I found Alext James (@TheRacerMaster)'s article : http://alextjam.es/debugging-appleacpiplatform/

      Because signed char become negative when bigger than 0x7f, Apple rewrote isprint method but seems to forget to cast char to unsigned. Thus, if OemId, Signature、OemId、OemTableId or AslCompilerId in any ACPI table contains a char greater than 0x7f, it will cause a memory overflow.

      Most people can solve by:
      dropping MATS/BGRT table( or other table ) add FixHeaders_20000000 in clover ACPI patch Modify MATS/BGRT/other table and change that char to lower than 0x80 But sadly none worked for me
      I dropped all of my ACPI tables except DSDT and APIC, cuz I cannot boot without these two I searched for APIC and DSDT, none of their OemId, Signature、OemId、OemTableId or AslCompilerId contains char greater than 0x7f Untypical Situation:
      I took a video of my boot process using -verbose, debug=0x100, keepsyms=1 :
      see online : https://www.dropbox.com/s/p4eztglltdtqxyb/boot.mp4?dl=0
      In the trace, the boot process stuck at isspace other than isprint.
      Out to curiosity, I decompiled AppleACPIPlatform and saw isspace looks like this:
      _isspace: 000000000001f5cf push rbp ; CODE XREF=_AcpiUtStrtoul64+71, _AcpiUtStrtoul64+89 000000000001f5d0 mov rbp, rsp 000000000001f5d3 lea rax, qword [__ctype] 000000000001f5da mov al, byte [rdi+rax] 000000000001f5dd and al, 0x20 000000000001f5df shr al, 0x5 000000000001f5e2 pop rbp 000000000001f5e3 ret And in C language it looks like this:
      int _isspace(int arg0) { rax = (int)__ctype[arg0]; return (rax & 0x20) >> 5; }  It uses __ctype as an array and rdi, which acts as argument in assembly language, as a pointer to find some char and put it into al. 
      I checked the length of __ctype is 256, thus any normal byte, which is 16 bits, won't caus overflow.
      However, Apple didn't cast arg0 to unsigned char. Thus, any char that's greater than 0x7f will also cause an overflow.
      Follw the trace, I found _AcpiUtStrtoul64 the source code is here. Looks like it just uses a loop to judge whether it's a space. No other useful information were found during further dig.
      New Discovery and Dilemma
      Occasionally, i decompiled two programs written to test signed and unsigned char, and were surprised to find,
      the only difference between 'cast to unsigned' and 'stay signed' in assembly language is that when delivering argument, unsigned used 'movzx' and singed used 'movsx'.
      In assembly language, arguments are delivered by register rdi. So, I think, if I change 'movsx' to 'movzx' then this problem can be solved. Here's where isspace is called inside _AcpiUtStrtoul64:
      0000000000001153 mov qword [r14], 0x0 000000000000115a movsx edi, byte [r15] 000000000000115e test edi, edi 0000000000001160 je loc_12b5 0000000000001166 mov dword [rbp+var_2C], esi 0000000000001169 xor eax, eax 000000000000116b call _isspace 0000000000001170 lea rbx, qword [r15+1] 0000000000001174 test eax, eax 0000000000001176 je loc_118d loc_1178: 0000000000001178 movsx edi, byte [rbx] ; argument #1 for method _isspace, CODE XREF=_AcpiUtStrtoul64+99 000000000000117b xor eax, eax 000000000000117d call _isspace 0000000000001182 inc rbx 0000000000001185 test eax, eax  Note that edi is the lower 32 bit of rdi .
      However, after patching in Clover, it stucks that line 0000000000001178 . And checking the register printed, register edi is empty. That means something's wrong when executing movzx .
      If I do not change movsx to movzx, at the panic scene we can see in the above video that register rdi is 0x00000000 ffffffa4 , thus edi is 0xffff ffa4 .
      Obviously, the char that caused the problem should be A4. However, I searched APIC but didn't find A4. There is a A4 in DSDT but I have no idea how to modify.
      BIOS rom, all of my ACPI tables and modified dsdt/ssdt can be found in attachment.
      Need Someone's Help
      So, here I'm at a very embarrassed stage don't know where's wrong even what to do next... Maybe something's wrong with one of my ACPI tables? Or with AppleACPIPlatform? Or with AppleSMCRTC?
      I'm pretty sure I'm not alone with this question, someone willing to dig into it please check my raw ACPI tables, BIOS ROM, modified DSDT/SSDT and my current EFI folder. Thanks very much.
      BIOS ROM:
      Modified DSDT/SSDT, perfect on 10.10 - 10.12.6:
      Original ACPI Tables:
    • By JD Apolo
      Hey guys! Took me about a whole day to figure this out but I finally got macOS Sierra (latest GM release) working for my board. Here are the specs of my Hackintosh.
      Mobo: Gigabye X79-UP4
      Proc: i7-3930K
      Mem: 4x8GB 1866Mhz Corsair
      Video: NVIDIA GTX 680
      SSD: Mac
      Here's my EFI (change them to just EFI and put at your EFI partition):
      X79-UP4 Files.zip
      For Audio:
      1. Burn macOS Sierra your usual way. Put this EFI folder to your EFI installer partition. Upon installation bootup, change the nv_drv=1 to nv_disable=1 until installation completes etc.
      2. When you first get to your desktop (still with nv_disable=1), run the AGDPFix program to get full resolution for your NVIDIA card. (If after booting, the screen is black, hard restart then make sure to change the nv_drv=1 to nv_disable=1)
      3. To enable audio, mount your EFI partition then drag the audio_clover file to Terminal. Reboot and everything should work now. Congratulations!
      Everything works (USB3, SATA, Audio, Video, etc) (Sleep I'm not really sure as I seldom leave my Hack on when not in use)
      I hope this could help some people to save you guys time and energy from figuring it out. Cheers!
    • By pduke
      Hi to all!
      I have been reading your forum for months and I must thank you for all the help so far. And…. this is my first post.
      The past 6-7 months my interest about hackintosh rekindled. I managed fairly easy (thanx to forum support!) to setup OSX on a q9550 coe2quad on an MSI p45 platinum with 8gb ram. First I put on a mavericks zone since I had no mac to access the app store. Downloaded el Capitan and I went straight to a vanilla install which worked like a dream. 1st try all working. Then sierra went out, upgraded it, liked it and fresh installed it on a SSD. Since then the system is working like a charm!
      But …. This is not my main machine.

      I have a:
      CPU: e5 2670 v1
      Motherboard: x79 taken from a Lenovo Eraser X700 (ridiculous I know!!!)
      RAM: 16GB gskill
      GPU: XFX 280X
      ……-probably one of the worst combination of components I could choose for hackintosh -…..

      But it is steady and super fast with my Win10 installation.
      I also occasionally replace the XFX with a 9600GT for testing purposes when hackintoshing…
      16 core on Sierra is the main goal.
      So I am struggling for months.(ok when i manage to find some free time to experiment)

      3 major problems
      1. The system when it boots with clover kills all USB ports and goes to “waiting for boot device”.no keyboard, no mouse and no USB boot disk.
      With chameleon cpus=1 fixes the problem but not in clover.
      Also npci=0x2000 is needed when booting with 280X but not with 9600GT
      I have read many many articles about such problems but nothing seems to work. I think I need a tailored solution but I still do not have the skills.
      2. The well known XFX ROM problem. But I found some posts where load VBios is working. still, clover do not recognize my ASUS roms….what am i doing wrong?
      3. It never recognized any HDD as a boot disk. None! Chameleon , clover,GUI, MBR nothing. I am able to boot ONLY from USB sticks. this i think can be left for later but i am writing it down in case it points somewhere

      I am not going to list all the testing I have done, just where I am now.
      (before all below, I tried hundreds of Yosemite  and el Capitan installations)
      - I managed to install Yosemite zone with chameleon and the 9600GT on. Works great although a bit heavy. But I need the latest OSX and my xfx on if possible
      - I installed clover (along with chameleon) and managed to boot with it on legacy -not UEFI.
      - I downloaded sierra from appstore and started the upgrade process so now I have a partition “macOS installer”
      - I created a sierra  USB boot disk
      - and returned to using my XFX280X cause with 9600GT I can ‘t boot with UEFI and off course this is the card I want to use… obviously.

      Booting UEFI from SIERRA USB I can :
      a. Select the sierra installation partition on my Yosemite HDD.
      with cpus=1 + npci=0x2000 it loads to SIERRA installation screen in full 1920x1200 res, but my USBs are DEAD and I have no mouse or keyboard to click CONTINUE!!!
      I tried all ports and 2 USB extensions I have . Nothing, all dead. Unfortunately, my cheap chinese PCie USB 3 card is dead. Could this be a solution I don’t know. I also have tried all clover possible settings. I am really sorry I don’t post one by one, but this has been done through various weeks and I am lost into million of retries and configurations.
      If can get pass this problem I think I will manage to put the correct DDST and have a working system. But I am out of ideas.
      b. Select Sierra installation USB with cpus=1 and npci=0x2000  which results in …dead USB ports…. Back to zero
      On both situations I have tried PCIRootUID 1/0 UseKernelCache, USBBusFIX but nothing changes.
      I pasted FakeSMC.kext to /Clover/Kexts/10.11 and 10.10 
      Tried Fakecpuid as well but I get a panic
      i also tried to load Vbios, put some ASUS 280X roms ,  renaming them to 1002-6798.rom in /EFI/CLOVER/ROM but clover doesn’t seem to read them since I can’t see any details on Graphics settings screen.

      Ok i understand this is kind of chaotic but I really feel I need some help here. So If anybody has any ideas or suggestions on how to proceed(or start fresh with a certain target in mind(!!)) with this thing , I would be really  grateful.

      thanx in advance and sorry for my English