Jump to content
InsanelyMac Forum
JahStories

High Cpu Temperatures

Recommended Posts

Hi there folks :)

I was finally able to get qe&ci work on my laptop an asus n53jl (just for the intel hd) so i'm using 10.8.3 as main os... but i'm noticing that the temperatures of the cpu cores are too high around 70° idle and grows to 100° just watching flash videos online, i think it's crazy...

i've used nullcpu before in the extra folder, but i thought it was better to use a patched version of the appleintelcpu in S/L/E but the cpu temps are the same, these are my system info...

 

Chameleon v2.2 r2189

Kernel flags: -f

Patched AppleIntel*FB

Natit

VoodooHDA

SleepEnabler (sleep do not work anyway)

FakeSmc (latest rev.)

Compiled Dsdt (just errors fixing no patches)

 

Hope someone can help :) THX :)

 

here a screenshot...

qswrxs.png

Share this post


Link to post
Share on other sites
Advertisement

You need to patch your DSDT and generate c and p-states to enable speedstep using Apple's stock CPUPM.

Share this post


Link to post
Share on other sites

Patches depend on the system specs.

Please upload your DSDT and tell me the specs of your system.

Share this post


Link to post
Share on other sites

tried... temperatures are still high 83° right now, the only benefit seems to be that now it goes to sleep... can't wake anyway, i think it's the dual video card optimus stuff that activate the nvidia gpu when waking, i'm still stressed by the temperatures, i would like to have even sleep, but i don't really care... any idea?

Share this post


Link to post
Share on other sites

Could you please extract other ACPI tables in Linux (live CD would do) and upload those? Thanks!

 

BTW you have a nice desktop, could you share the link? :)

Share this post


Link to post
Share on other sites

About the temperatures i was thinking that it could be the optimus setup, i've read somewhere that's is possible to tweak the dsdt to disable the nvidia card, Dr. Hurt can u please add that patch to the dsdt you posted before?

Share this post


Link to post
Share on other sites

thanks Dr. Hurt, i'm building you a pyramid... by the way temperatures still high 88° right now and when wakes from sleep there is no backlit, it look like nothing changed :( any other useful trick? it's weird using an hackintosh where you cook eggs on...

Share this post


Link to post
Share on other sites

OK, is the Optimus disabled now (check graphics section in system info app). It should no longer be listed there.

 

What are you using to monitor your temps?

 

Please install the HWSensors attached below, and tell me if speed step is working. You should see multiplier and clock speed changing.

HWSensors.pkg.zip

Share this post


Link to post
Share on other sites

Installed and checked and yes it does change, the multiplier sometimes is at 9x and sometimes is at 20x and the clock speed bumps from 1.26 to 1.80, just this nothing random... it seems that its not working as it should

Share this post


Link to post
Share on other sites

The screenshot is attached ;) by the way i hope the live cd is the last chance there isn't anything more osx or windows friendly or maybe some specific tweak ?

The tables can be extracted in Windows too. Tables extracted in OS X, may not reflect the actual situation (DSDT at least). Not that it is only Linux feature, it's just my preferred weapon of choice :)

 

BTW thanks for the pic,

Share this post


Link to post
Share on other sites

No, I meant click the apple -> more info -> system report -> graphics/displays :)

Share this post


Link to post
Share on other sites

Why are you using the natit kext? Do you have GraphicsEnabler=Yes in chameleon's plist?

 

Good point.

Share this post


Link to post
Share on other sites

@Maniac10 Graphics enabler is set to NO... (i don't need the nvidia card) and without natit i get a boot loop (no KP and dsmos arrives)

@iFire i've dumped the acpi tables with that app... is attached

@3.14r2 i've dumped the acpi tables even with the app you told me, attached too

P.s.

i can't stop giving thanks to everyone guys :D

3.14r2.zip

iFire.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×