Jump to content
InsanelyMac Forum
brunosky

Kernel panic connecting USB devices after sleeping/awakening on a real Mac

Recommended Posts

Hello,

I have a Mac Pro 1,1 (now 2,1) and I'm a very satisfied user of Chameleon.

Everything is working great, apart from a problem that happens only after putting my Mac to sleep and awakening it: if I connect an external USB device (audio, pen drive, iPhone, etc.), I experience a kernel panic.

No problem if I don't put the Mac to sleep.

I've recently updated to 10.8.3, the Sleep function works well, but the problem I had before, with 10.8.2, persists: after connecting any USB device, my Mac freezes.

The only difference is that now I don't see anymore the grey screen of death, but the frozen desktop.

 

Anyone can help?

 

Mac Pro 1,1, with 2 Intel X5355, 16 GB of RAM, upgraded EFI and SMC firmware (so now 2,1 and 1.15f3), booting in 64 bit mode using Chameleon bootloader, and following the Jabbawok's method.

 

Thanks for your attention! :)

Share this post


Link to post
Share on other sites
Advertisement

I can only see this message from Chameleon:

 

message of kernel panic from Chameleon: can someone understand it?

 

I'm getting crazy with my Mac Pro 1,1 (now 3,1) for a problem that in certain moments seems solved, and then inexplicably returns.

After putting the Mac to sleep and then awakening it, when it comes the moment to connect a USB device it freezes.

Below you can find the message I receive from Chameleon booting in verbose mode, and I hope that someone can help me to understand the reason.

Thanks a lot

 

panic(cpu 0 caller 0xffffff8000b7e95): Kernel trap at 0xffffff80005f0221, type 13=general protection, registers:

CR0: 0x000000008001003B, CR2: 0x000000010b5e1000, CR3: 0x0000000002904000, CR4: 0x0000000000000660

RAX: 0xffffff8023166e00, RBX: 0x0000000000000000, RCX: 0x0000000000000000, RDX: 0x0000000000000100

RSP: 0xffffff81d1003e50, RBP: 0xffffff81d1003e70, RSI: 0xffffff8020475100, RDI: 0x8ed88ec88ce88b66

R8: 0x0000000000000016, R9: 0x0000000000000000, R10: 0xffffff802033ce80, R11: 0x0000000000000202

R12: 0x0000000000000000, R13: 0xffffff8020574600, R14: 0xffffff80008e0a80, R15: 0xffffff8025e50100

RFL: 0x0000000000010246, RIP: 0xffffff80005f0221, CS: 0x0000000000000008, SS: 0x0000000000000010

Fault CR2: 0x000000010b5e1000, Error code: 0x0000000000000000, Fault CPU: 0x0

 

Debugger called: <panic>

Backtrace (CPU 0), Frame : Return Address

0xffffff81d1003af0 : 0xffffff800021d626

0xffffff81d1003b60 : 0xffffff80002b7e95

0xffffff81d100ed30 : 0xffffff80002cd4dd

0xffffff81d1003d50 : 0xffffff80005f0221

0xffffff81d1003e70 : 0xffffff80005f0439

0xffffff81d1003ea0 : 0xffffff800062ff05

0xffffff81d1003f30 : 0xffffff800062c390

0xffffff81d1003f70 : 0xffffff8000630f59

0xffffff81d1003fb0 : 0xffffff80002b2977

 

BSD process name corresponding to current thread: kernel_task

Boot args: boot-uuid=2E6875C1-3C7C-3F0C-AD42-B5C379D46957 rd=*uuid -v

 

Mac OS version:

12D78

 

Kernel version:

Darwin Kernel Version 12.3.0: Sun Jan 6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64

Kernel UUID: 3EB7D8A7-C2D3-32EC-80F4-AB37D61492C6

System model name: MacPro3,1 (Mac-F4208DC8)

 

System uptime in nanoseconds: 112313820347

Share this post


Link to post
Share on other sites
Finally I solved the problem with a clean installation of the system!   :D
Now, after 3 weeks, I can cry Victory without the fear that it's too soon.
Anyway it's important that I boot Chameleon with the boot flag -f and using Kernel cache:

   <key>Kernel Flags</key>
   <string>-f</string>
   <key>UseKernelCache</key>
   <string>Yes</string>

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×