Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Help with UEFI bios :S

6 posts in this topic

Recommended Posts

Greetings to all, I have a pc with UEFI BIOS system, and let me know that I do to install the snow leopard, since most requested tutorials using bootloaders but none recognizes me UEFI boot: S, thanks in advance !

Share this post

Link to post
Share on other sites

Chameleon is designed to emulate EFI. Since UEFI is a development of EFI, either you should use a legacy BIOS mode (non UEFI boot; Chameleon should then work fine), or use a different bootloader that supports UEFI. Clover for instance.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cvad
      Boot Disk Utility
      v2.1.2018 rev. 023b
      © cVad 2012-2018
      Latest update is always here.
      You can
      Make bootable USB Flash Disk for macOS with Latest Clover bootloader revision
      Download(with resuming) Latest! Apple Recovery HD package,
      Extract HFS-Image and Restore it with BDU.
      Automatically Check/Download the Latest Clover Rev.
      and Use existing Zip and LZMA Clover archives from Local Repository,
      Download files from User Download List
      and BDU Additional Download List,
      build FreeDos bootable drive
      with Volkov Commander.
      Feel free to click "like"

      - Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows 7 and later.
      Not supported  WinPE and Wine. -
      Special utility from cvad & russian MAC community for new hackintosh users.


      BootDisk Utility is intended to make a external bootable USB Flash Disk by installing to it special Data set (MBR, PBR sectors and Data files) of EFI-based Clover bootloader (and may be Chameleon bootloader).
      BDU was created for new hackintosh users to simplify the installation
      of a EFI bootloader Clover to the flash drive.
      More information can be found in the appropriate forum topic:
      - Clover General discussion -
      Feel free to click "like"

    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.
    • By swordsx48
      Hi, so this is an issue I have put off for a while by just selecting the windows drive to boot.
      My Clover bootloader, UEFI, cannot load my Windows installations. Those are set to boot legacy, so I can understand that. But I cannot get legacy Clover working! When I install it to my drive and set that to boot, it just goes straight to the Windows installation. I think it has to do with the boot1 / 6 type error where it's just redirecting it to Windows, because that's all that happens.
      In Summation-
      UEFI Clover-can't boot Windows
      Legacy Clover-forwarded to another boot drive
      Something something active partition?
      Happy new year and thank you for your time, I appreciate any help!
    • By uglyJoe
      Hello everybody,

      I’m using Ozmosis with a Gigabyte H81M-HD3 but unfortunately this board hasn’t enough space in it’s ROM to store the apfs.efi, too.
      Than I have a second machine, my ZBox-Nano that not even has the space for the really necessary stuff.
      Sure, Clover is able to solve all this problems but I want to go with Ozmosis

      Here comes rEFInd into the game: http://www.rodsbooks.com/refind/
      This boot loader could be installed into the ESP.
      rEFInd is not only able to detect apfs formatted partitions but also to load uefi drivers!
      And after some weeks of testing, I claim that rEFInd is doing his job very well.

      rEFInd is open source so I take a look into it and found a good starting point to learn a little more about the UEFI. The result is a rEFInd version with some additions, that should make life easier and more colorful ….

      I’m using this „enhanced“ version in two different setup’s.

      First the H81M, that comes with ozmosis, hfsplus, fakesmc and a patched dsdt inside the ROM.
      Here rEFInd is only loading apfs.efi and scanning for macOS. The Oz directory on the ESP is not in use.

      Second the ZBox. I only replaced the FileSystem driver with EnhancedFat and patched the ROM to unlock the MSR.
      rEFInd is loading hfsplus, apfs and ozmosis and is scanning for macOS.
      Ozmosis is loading dsdt, ssdt, kext and defaults from the Oz directory on the ESP.

      If you like to test it: Installation is easy but do it at your own risk!
      Unzip the download and open the directory in Finder.
      It comes with rEFInd, ozmosis.efi, apfs.efi, hfsplus.efi and a Oz directory with mac mini defaults and fakesmc.kext.
      Goto Efi/Oz and adapt it, to suit your needs.
      Goto Efi/Boot/drivers_x64, if you have ozmosis or hfsplus installed into your ROM, delete it from the drivers directory because you don’t need to load it again.

      If you are ready to go, mount your ESP and copy shellX64.efi and the Efi directory into the ESP root.
      Btw.: This is a EDKII shell, that comes with some functions, which are needed by the nsh scripts I used for changing rEFInd’s configuration from the boot menu.

      This is a round up of the changes I made, but after some more testing I will create a fork on GitHub.
      Until then I can provide a patch against the current refind source, if someone is interested.

      rEFInd 0.11.2-enhanced

      Changes / Additions

      A. Configuration

      rEFInd is showing a message while scanning for devices.
      To disable this message use:
      hide_scan_msg 1

      Boot Splash is an extra banner used only with timeout -1
      This banner is splashing centered at the boot screen.
      boot_splash banners/banner-black.png

      Color Mode can be any combination from the following
      1=icon_auto, 2=icon_value
      4=font_auto, 8=font_value
      16=menu_auto, 32=menu_value

      color_mode 0 <- function is disabled (default)
      color_mode 21 <- icons, text and selections are tinted automatic
      background color from the banner
      color_mode 85 <- icons, text and selections are tinted automatic
      background color from value (for transparent banner)
      color_mode 101 <- icons, text are tinted automatic
      menu / selection color from value
      background color from value (for transparent banner)

      *_auto generates the color from the current background color
      *_value enables the corresponding rgb(a)_color
      rgba colors are in hex RED, GREEN, BLUE, ALPHA
      rgb colors are in hex RED, GREEN, BLUE

      rgba_color_icon f3,f3,f3,5e
      rgba_color_menu d3,d3,d3,5e
      rgba_color_font d3,d3,d3,5e
      rgb_color_back 0c,6f,b8
      Space between icons in pixel
      # big-icons(0-256) small-icons(0-64) y-spacing(0-64) icon_spacing 64 32 24  B. Behaviour

      The unmodified rEFInd is scanning all devices at start.
      Then it loads the drivers if any detected and scans the devices again.
      This is good for Mac's but we want to load the drivers for sure, so I change this a little.
      Now rEFInd only scans for the ESP to know it's location.
      Then it reads the config, load the drivers and start scanning devices.

      Also this version is able to detect the 'macOS Install Data'.
      This is necessary for installing and updating macOS on partitions formatted with apfs.

      New embed banner, arrows and selections.
      New embed font (Ubunutu-Mono 18pt and 28pt).
      New os_icons from https://github.com/munlik/refind-theme-regular
      New tool and function icons.
      Visual changes for creating the boot entries.
      Changed icon spacing
      And some more ...
      Update (14.12.07):
      - adaptable icon spacing
      - apfs.efi from macOS 10.13.2
      Have Fun!
    • By innokentiy.dailymsg
      My original Software/Hardware:
          "Dock station: Windows 8" + "Unplugged Tablet|LCD: Android";
          "LCD 10.1 FHD"/i5-4200U/HD4400/4 GB;
          Intel Dual Band Wireless-N 7260HMWAN Mini PCI-E half-card;
          HDD Toshiba;
          BIOS v.213;
      My current Software/Hardware:
          "Dock station: Windows 10 + OS X Siera 10.12.6 + Ubuntu" + "Unplugged Tablet|LCD: Android";
          "LCD 10.1 FHD"/i5-4200U/HD4400/4 GB;
          SSD Crucial;
          PCI-E Wi-Fi BCM94352HMB;
          BIOS v.216;
      USB3.0 x2, microHDMI x1,miniDP x1, comboJackMicrophone x1, comboport for Tablet|LCD (LCD, Touchscreen, Web camera) x1.
      HARDWARE (What works and doesn’t work):
          Intel Core i5-4200U – SpeedStep Works [sSDT] (but there're some issues,see below);
          Integrated Intel 4400 HD Graphics HDMI/DisplayPort(DP) – Works full QE/CI [FakePCIID.kext & FakePCIID_Intel_HD_Graphics.kext, DSDT/SSDT pathes, Clover Config.plist patches];
          DisplayPort (DP) - Works;
          HDMI - Works;
      (but there're some issues,see below).
          Touchscreen Atmel maXTouch Digitizer USB - Works [OOB] detected as ink;
          LCD resolution (1280x720, 1600x900, 1920x1080)- Works [after Graphics setting];
              Keyboard Fn brightness keys - Works [after Graphics and Keyboard settings];
              SysPref brightness slider - Not Works (see issues below);
          Unplug built-on LCD from dock and plug it to dock-station again - Works (but there're some issues, see below).
          Sound: Context CX20751/2 - Works [AppleALC.kext, DSDT];
          Keyboard Fn volume keys (F10, F11, F12) - Works [after Graphics and Keyboard settings];
          HDMI Sound - Works [AppleALC.kext, Clover Config.plist patches and SSDT patches];
          Built-in microphone - Works [after Sound settings] ;
          Headphone's line-in microphone - Not Works (see issues below).
          ASUS Wireless Input Receiver USB(Keyboard/Elan Touchpad) – Works [Elan AppleSmartTouchPad.kext];
          Touchpad – Works [Elan SmartTouchPad.kext] (but there isn't TouchPad Panel in SysPref, see issues);
      Wifi/Bluetooth: Intel Dual Band Wireless-N 7260HMWAN Mini PCI-E half-card - not supported can be replaced with a supported card. I replaced with Broadcom BCM943225HMB card:
          Wifi 2.4GHz/5GHz, Bluetooth BCM20702A0 - Works [bT kexts, Clover Config.plist patches];
      SSD: Crucial SSD – Works [Trim support Clover Config.plist patches];
      USB 3.0: Works [OOB] (incorrect works after sleep, see issues);
      Webcam: ASUS UVC 2.0 - Front cam Works [OOB with LED];
      Battery: Battery management, battery status – Works [ACPIBatteryManager.kext, DSDT patch];
          Sleep mode - Works [after DSDT patches];
          Sleep on clamshell close – Not Works (I don't need it);
      Hardware installation (to change the wi-fi cards or HDD) - To remove the back aluminum plate of the dock-station, use a plastic spudger(there are 2 hidden screws under the rubber foots. The rubber foots is necessary to remove);
      A) FOR INSTALL (this is my experience of installation OSX, you may install OSX other ways as you like):
          A.1) Update Bios version to v.216;
              CSM = disable (with enable option OS X boots and works too but see issues);
              Security Boot = Disable;
          A.2) Create Clover USB OS X installer (I used BDU app from Windwos - BootDiskUtility.exe, see links);
              Kexts - Place these kexts in Flash/EFI/CLOVER/kexts/Other:
                  FakeSMC [system];
                  FakePCIID.kext [Graphics]
                  FakePCIID_Intel_HD_Graphics.kext [Graphics]
                  ApplePS2SmartTouchpad.kext [Keyboard + Touchpad]
              Clover Config.plist - attached below (without SMBIOS), replace the one in EFI/CLOVER/
                  Boot options: -v kext-dev-mode=1 rootless=0;
                  KernelPM = true;
                  Also I use pre-configured SMBIOS for MacBookPro 11,1 (I don't know whether the pre-configured SMBIOS somehow affects to the installation of Sierra, it just copied from my El Captain last installation);
          A.4) Extract original DSDT/SSDT's (push Clover F4 key);
          A.3) Prepare HDD/SSD partitions for OS and Install OS X and Windows (I used MultiBooting UEFI Guide, see links).
          Need to download beforehand:
              Clover app last version;
              Clover Configurator app (I use it only for mount EFI partition and configure SMBIOS);
              Kext Utillity app;
              IORegistery 2.1 app;
              DPCIDevice app;
              iasl dissembler;
              MaciASL app;
              Piker-Alpha ssdtPRGen scripts;
              RehabMan Laptop DSDT/SSDT Patches;
              All needed kexts;
          B.1) Install latest Clover(I use Clover ver4268) with options:
              install Clover only for UEFI;
              install Clover on EFI partition;
          B.2) DSDT/SSDT patching (for details see links):
              Create new folder, copy extracted DSDT/SSDT's(non-x) from usb-flash and downloaded iasl in folder, open console, cd to folder, type

      ./iasl -da -dl DSDT.aml SSDT*.aml         Edit DSDT/SSDT via MaciASL app(use ACPI 6.1) (and DON'T use 'DSDT Editor' app, use MaciASL app!!!):            You need DSDT.dsl, "Cpu0Ist" SSDT(my SSDT-0.dsl), "SaSsdt" SSDT(my SSDT-7.dsl);
                  DSDT apply the following patches in the following order(!!!):
                      [syn] Fix ADBG Error;
                      [bat] ASUS G75VW;
                      [audio] Audio Layout 12 (I use 28, change 12 to 28);
                      [igpu] Rename GFX0 to IGPU;
                      [sys] Add MCHC;
                      [sys] Add IMEI;
                      [sys] Haswell LPC;
                      [sys] SMBUS Fix;
                      [sys] RTC Fix;
                      [sys] IRQ Fix;
                      [sys] OS Check Fix (Windows 8);
                      [usb] USB3_PRW(0x6D);
                  Save as DSDT.aml file.
                  Generate SSDT.aml usingssdtPRGen.sh;
                  Save as SSDT.aml file.
                  SSDT-0 "Cpu0Ist" Patches:
                      [syn] Remove _PSS Placeholders
                  Save as SSDT-0.aml file
                  SSDT-7 "SaSsdt" should contain GFX0 apply the following patches in the following order(!!!):
                      [igpu] Rename GFX0 to IGPU
                      [igpu] Rename B0D3 to HDAU
                      [igpu] Haswell HD4600 Yosemite - change 4600 to 4400;
                      [igpu] change in HDAU layout to 28
                  Save as SSDT-7.aml file
                  Place only the DSDT.aml, SSDT.aml, SSDT-0.aml, SSDT-7.aml in /EFI/Clover/ACPI/Patched;
          B.3) Clover kexts and settings:
              boot options:
              -v dart=0 kext-dev-mode=1 rootless=0
              kexts (Place these in EFI/CLOVER/kexts/Other):
                  FakeSMC [system];
                  CPUSensors.kext [HWMonitor app];
                  LPCSensors.kext [HWMonitor app];
                  ACPISensors.kext [HWMonitor app];
                  FakePCIID.kext [Graphics];
                  FakePCIID_Intel_HD_Graphics.kext [Graphics];
                  ApplePS2SmartTouchpad.kext [Keyboard + Touchpad];
                  ACPIBatteryManager.kext [battery];
                  BrcmFirmwareRepo.kext [bluetooth]
                  BrcmPatchRAM2.kext [bluetooth]
                  BTFirmwareUploader.kext [bluetooth after sleep] (The author BTFirmwareUploader specifies to use it in /S/L/E/ , but at me It works in E/C/k/O/);
                  AppleALC.kext [Audio]
                  I don't Use VoodooPS2Controller.kext (see issues);
              Config.plist patches and options (You may use my config.plist, but it without SMBIOS info):
                     [HD4400 and reduce some video glitches]

      <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>Enable 1536MB for Azul framebuffer 0A260000</string> <key>Disabled</key> <false/> <key>Find</key> <data> AADwAAAAAEDZCgAA </data> <key>Name</key> <string>AppleIntelFramebufferAzul</string> <key>Replace</key> <data> AADwAAAAAGDZCgAA </data> </dict> <dict> <key>Comment</key> <string>Enable 9MB cursor bytes, 0x0a260006</string> <key>Disabled</key> <false/> <key>Find</key> <data> BgAmCgEDAwMAAAACAAAwAQAAYAA= </data> <key>Name</key> <string>com.apple.driver.AppleIntelFramebufferAzul</string> <key>Replace</key> <data> BgAmCgEDAwMAAAACAAAwAQAAkAA= </data> </dict> </array>                        [HDMI Audio]
      <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>HDMI-Audio Port_0x6 DP2HDMI, 0A260000</string> <key>Find</key> <data>AgQJAAAEAACHAAAA</data> <key>Name</key> <string>AppleIntelFramebufferAzul</string> <key>Replace</key> <data>AgQJAAAIAACCAAAA</data> </dict> </array>                      [sSD Trim]
      <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>Trim Enabler for SSD</string> <key>Disabled</key> <false/> <key>Find</key> <data> QVBQTEUgU1NE </data> <key>Name</key> <string>IOAHCIBlockStorage</string> <key>Replace</key> <data> AAAAAAAAAAAA </data> </dict> </array>                       [Wifi, Bluetooth]
      <key>Fixes</key> <dict> <key>AddDTGP_0001</key> <true/> <key>FixAirport_4000</key> <true/> </dict> <key>FakeID</key> <dict> <key>WIFI</key> <string>0x43a014E4</string> </dict> <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>10.12-BCM94352-fvco-darkvoid</string> <key>Disabled</key> <false/> <key>Find</key> <data> gflSqgAAdSk= </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> gflSqgAAZpA= </data> </dict> <dict> <key>Comment</key> <string>10.11+-BCM94352-5GHz-US-FCC-darkvoid</string> <key>Disabled</key> <false/> <key>Find</key> <data> QYP8/3QsSA== </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> ZscGVVPrKw== </data> </dict> <dict> <key>Comment</key> <string>10.11+-BCM94352-Airport-Extreme-skvo</string> <key>Disabled</key> <false/> <key>Find</key> <data> axAAAHUN </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> axAAAJCQ </data> </dict> <dict> <key>Comment</key> <string>10.12-BCM94352-0x43b114e4-Info.plist-bpresles</string> <key>Disabled</key> <false/> <key>Find</key> <data> PHN0cmluZz5wY2kxNGU0LDQzYmE8L3N0cmluZz4= </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> PHN0cmluZz5wY2kxNGU0LDQzYjE8L3N0cmluZz4= </data> </dict> <dict> <key>Comment</key> <string>10.11-BCM94352-CC=#a-Ramalama</string> <key>Disabled</key> <false/> <key>Find</key> <data> QYP8/3QsSA== </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> ZscGI2HrKw== </data> </dict> <dict> <key>Comment</key> <string>10.11+-BCM94352-Whitelest-0x4331-iMac14,3-skvo</string> <key>Disabled</key> <false/> <key>Find</key> <data> TWFjLUM2RUZBNjM5NjJGQzZFQTA= </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> TWFjLTI3QURCQjdCNENFRThFNjE= </data> </dict> <dict> <key>Comment</key> <string>10.11+-BCM94352-Whitelest-0x4353-MacBoolAir5,2-skvo</string> <key>Disabled</key> <false/> <key>Find</key> <data> TWFjLUM2RUZBNjM5NjJGQzZFQTA= </data> <key>Name</key> <string>AirPortBrcm4360</string> <key>Replace</key> <data> TWFjLTI3QURCQjdCNENFRThFNjE= </data> </dict> <dict> <key>Comment</key> <string>10.11+-BT4LE-Handoff-Hotspot-lisai9093</string> <key>Disabled</key> <false/> <key>Find</key> <data> SIX/dEdIiwc= </data> <key>Name</key> <string>IOBluetoothFamily</string> <key>Replace</key> <data> Qb4PAAAA60Q= </data> </dict> </array>         SMBIOS Serial# is not configured in the attached Config.plist file (you may generate it via Clover Configurator. I use Makbook Pro 11,1 2013 late info. 
      ISSUES :
      1) Different Mac OS behaviour at boot time and work time with the BIOS option CSM=enabled/CSM=disabled:
      For example,
        -  when CSM=disabled Mac OS boots normally with Built-on LCD + DP/HDMI plugged monitor (both monitors work well during boot and after boot), but I can't unplug built-on LCD and plug it again, glitches appears on built-on LCD, helps only reboot;
        -  when CSM=enabled Mac OS boots only with one plugged monitor(only built-on LCD or only DP/HDMI monitor), the second monitor can be plugged after OS fully loaded and both monitors work well. And I can plug and unplug built-on LCD at any time, it works well without glitches.
      2) CPU turboboost only to 2,3Ghz although it should be up to 2.6Ghz;
      3) USB ports work incorrect after sleep mode (usb-flashs shout be replugged);
      4) The built-in notebook microphone stops working when I insert the headphones with a built-in microphone (Both microphones don't work. OS X recognizes headphone's microphone as line-in).
      5) I can't get to work AppleBlackLight.kext (There isn't brightness slider in SysPref -> monitor panel);
      6) There isn't "Touchpad panel" in SysPref when I use ApplePS2SmartTouchpad.kext (I can't use VoodooPS2Controller.kext as touchpad has mad cursor motion with it), but SysPref -> Touchpad panel appears with it.
      - Use AsusNBFnKeys.kext (It makes all Fn keys working - enable/disable touchpad, enable/disable bluetooth, switch to Android tablet and other) carefully because some issues appear with brightness control. For the present moment I don't use the AsusNBFnKeys.kext.
      Clover doesn’t see any ext4 Volumes in Hard drive (Done, copy VBoxExt4-64.efi in /CLOVER/drivers64UEFI/).
      Bios 216 - https://www.asus.com/ru/support/Download/3/587/0/1/afd86D69CMWsUhle/32/;
      Create Clover USB OS X installer with BootDiskUtility.exe - https://applelife.ru/threads/mac-osx-i-clover-iz-windows-izgotovlenie-zagruzochnoj-flehshki.37189/;
      Clover install options - https://ddr5.ru/ustanovka-i-nastroyka-zagruzchika-clover-na/;
      Guide: MultiBooting UEFI. Install OS X, Windows 10 and Linux - https://www.tonymacx86.com/threads/guide-multibooting-uefi.197352/;
      [Guide] Patching LAPTOP DSDT/SSDTs - https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573;
      Generate SSDT.aml using ssdtPRGen.sh - https://github.com/Piker-Alpha/ssdtPRGen.sh , http://osxpc.ru/zavod/cpu-zavod/speedstep/;
      HWMonitor.app, CPUSensors.kext, LPCSensors.kext, ACPISensors.kext, FakeSMC.kext (I use 20171017) - https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/;
      FakePCIID.kext, FakePCIID_Intel_HD_Graphics.kext (I use 20170527) - https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/;
      ApplePS2SmartTouchpad.kext (I use 4.6.5)- http://forum.osxlatitude.com/index.php?/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/;
      Clover patches Wifi and Bluetooth - https://github.com/toleda/wireless_half-mini;
      BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext (I use 20160705)  - https://bitbucket.org/RehabMan/os-x-brcmpatchram/downloads/;
      BTFirmwareUploader.kext (I use 3.1.5_10.11) - http://forum.osxlatitude.com/index.php?/topic/2925-bluetooth-firmware-uploader/;
      AppleALC.kext - https://github.com/vit9696/AppleALC;
      Piker-Alpha ssdtPRGen scripts - https://github.com/Piker-Alpha/ssdtPRGen.sh;
      RehabMan Laptop DSDT/SSDT Patches - https://github.com/RehabMan/Laptop-DSDT-Patch;
      Many Thanks for:
      Maromi for the guide T300LA (http://www.tonymacx86.com/yosemite-laptop-guides/156756-guide-asus-transformer-book-t300la-using-clover-uefi.html),
      thespanky for the guide T300LA (http://www.tonymacx86.com/yosemite-laptop-guides/166461-guide-asus-t300la-using-clover.html),
      Going Bald for MultiBooting,
      RehabMan, toleda, Mirone for kexts and helps,
      and others