Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Hello, Alienware M17x R3 Graphic Cards are unable to Work!

5 posts in this topic

Recommended Posts

I got a major issue here which has been bugging me for like a month. it's killing me.

Pls check out my attached System Info.


The problem is, no matter what kind of solutions i used via Google, it just won't work, neither of my Graphic cards is working, the resolution stuck at 1024 x 768 forever. i tried intel HD 3000 graphics drivers, manually change Dev ID within the info.plist and all, totally in vain.


Would sb pls enlighten me here ? Many thanks.

My laptop is Alienware M17x R3, it's under my signature here, u could check it out~


Share this post

Link to post
Share on other sites



and welcome on InsanelyMac :)


at first , pls read forum rule and posting guidelines



Your topic does not deserve any more attention than others seeking help

hence topic titles must reflect their content, and topic titles containing things like: 'please help' 'look here' 'cash reward' 'urgent' or other inaccurate descriptions will be removed. This includes all-caps titles.


Please remember that you are in a public forum, a

bit of courtesy is always welcome

. It's always nice to start by saying "Hi" or "Hello" before asking a question or seeking help.



Good luck! ;)

Share this post

Link to post
Share on other sites

The reason the Dedicated GPU will not work is because of the switching method of our machines. The only way to use the Dedicated GPU is by disabling the Intel 3000, but it would not allow you to use the internal screen.


Basically the dedicated GPU works by routing through the intel 3000, OSX does not recognise this switching method, and as such graphics switching will not work at all.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      This app can be used to edit or create custom versions of the voodoo tsc sync kext, i have created it because i have seen many times peoples having troubles in finding the right version of voodoo tsc sync for their cpu, so i created a mac app that lets to edit or create a voodoo tsc kext and configure it for your system, i have included 3 ways to edit the kext:
      1) configure using one of the existing templates (just chose one of the cpu models listed)
      2) specifying the number of logical cores (threads)
      3) manually editing the info.plist of the kext using the editor (still experimental, needs some improvements)
      This app uses a copy of the VoodooTSCSync in his Resourches folder, or you can open an existing version of VoodooTSC and edit it, there are some other useful features to discover, and new ideas are also welcome to improve this program, i know that with a plist editor you can do what this app does, but this is designed to be more user friendly than editing a plist file manually and just for accomplish the task of configuring this kext for your machines without looking on the web for that specific pre-configured version you need, just download this program and follow a few steps.
      Reference topic: VoodooTSCSync Configurator, create a custom version of voodoo tsc sync
    • By kosakgroove
      Is there a way to run Tiger with an Intel Core Quad Q6600?? If so can it work with Clover??? And what would be the best SMBIOS? Because i think MacPro 3,1 is the right one for that processor, which am currently building a Hackintosh with, but in my knowledge, MacPro 1,1 is the only one that could run Tiger....
      Also, my hardware is more than fit for Mac OS Sierra, but the ability to run all versions from Tiger to Sierra is what i would really love to know..
      Thanks for the answers
    • By johnny5k
      I made a spreadsheet comparing all the available Haswell & Skylake Intel Core i3, i5 and i7 CPUs. My goal was to find the best low-power processor for use in a low-profile HTPC. I thought I'd post it in case anyone else finds it useful. Let me know if you do!
    • By AbsoZed
      Trying to boot to Niresh Mavericks Via USB, have tried GraphicsEnabler=No, however, after it runs through the verbose boot, I get a screen that looks like the following. I am running a First-Gen Core i5, with GMA900 Graphics (I think.) Here's is the screen.

    • By ssccrab
      I've just recently installed 10.6.8 on an ASUS P6T Deluxe, with an Intel i7-930, 12GB of ram, and everything boots and runs as it should. However, for some reason or another, I can't get OSX to recognize all cores. I've downloaded a custom DSDT specifically for the 930 on Snow Leopard, used the MacPro 4,1 definition, repaired permissions, set the BIOS to using all cores and all that good stuff, but System Profiler still shows Number Of Processors: 1, Total Number Of Cores: 2, Processor Interconnect Speed: 4.8 GT/s. 

      I'm not sure if it's normal there, but the big issue is that this computer was converted from Windows to Mac in a professional recording studio, and upon opening ProTools 9, It's only recognizing 2 processors, when it's supposed to be recognizing 8. I'm about ready to just pull my hair out of my head on this, lol. Is there something I need to key in through smbios or boot.plist to enable showing all cores/processors, or is there a file somewhere someone could point me to? Thanks in advance!