Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

No Wake After Sleep on Notebook with Intel GMA 950 video on 10.6.8 AND 10.7.5

6 posts in this topic

Recommended Posts

Aloha all,


I'm hoping someone can shed some light on a frustrating issue that I have encountered. I have 2 very nice, nearly 100% functional HackBooks that both exhibit the exact same deficiency. They will NOT wake from sleep. I'm fairly sure that they KP on wake. Usually they just stay black screen but every once in a while, I'll get a stack trace screen. Only once was there actually a kext in the stack trace and that was IOSurface.kext.


Both notebooks are ICH7 models with the Intel GMA 950 video chip. One is a Toshiba A105, Core Duo T2500, 1GB RAM, etc. and the other is a Dell Inspiron E1505, Core 2 Duo T5600, 2GB RAM, etc. Again, both have the Intel GMA 950.


I have Snow Leo 10.6.8 w/ Chameleon 2-RC5-r752 on the Toshiba and Lion 10.7.5 w/ Chameleon 2.1-r1650 on the Dell.


Both systems are entirely vanilla except for the usual AppleACPIPS2Nub/ApplePS2Contoller/FakeSMC in /E/E and an AppleACPIPlatform rollback to Snow Leo + VoodooTSCSync for the Dell running Lion. There are also the usual "legacy" mods to IOPlatformPluginFamily on both to get native SpeedStep as well but other than a few added kexts for audio and LAN, that's about it.


Everything else works: QE, ResMan, LAN, WiFi, Audio ins and outs, SpeedStep, Sleep from the menu button and power button menu pop up and clamshell/lid but NO WAKE !


There is one other VERY KEY kext that must be changed, AppleIntelIntegratedFrameBuffer.


I have found that only a couple of "patched" versions will get me a display and both seem to be all the way back from Tiger based on the version number -> 1.4.20 !


I have also found one other from Dr. Hurt versioned 1.6.6 that seems more modern but all three still end with the same result, no wake from sleep.


If I try the proper Intel FrameBuffer for the exact release of OS X that I'm running, I get a black screen with cursor. I have tried most, if not all, the FrameBuffers from 10.5.8 all the way through 10.7.5.


I have tried a couple prescribed DSDT fixes, injecting GMA 950 values from the GFX0 device and removing CRT/DVI/TV devices but this makes no difference.


At this point, I'm guessing that this problem is caused by the old FrameBuffer.


So these are the details of my testing.


Has anyone else out there gotten wake from sleep working on their notebook with GMA 950 under either 10.6.8 or 10.7.5 ?


If so, please share.

Share this post

Link to post
Share on other sites

sleep:Proper combination for sleep is:

1) patched HPET, TIMR, RTC, PIC sections

2) patched EHCI/UHCI sections

3) patched AppleLPC kext to match chipset id

4) removed NullCPUPowerManagement,

5) patched AppleRTC kext to solve CMOS reset after sleep

Share this post

Link to post
Share on other sites

Yep, all those were done. My problem is not getting to sleep. This seems to work, OK.


My problem is WAKING from sleep.


Didn't even need the trick to make AppleLPC load as both of these systems do it on their own with no DSDT mod.


Thanks for the reply but generic answers are of limited use at this point.


I need something from someone who has the GMA 950 waking from sleep under 10.6.8 or 10.7.5 on a portable.


Thanks though and keep 'em coming !

Share this post

Link to post
Share on other sites

Yes, I cracked it thanks to you and the folks over at OSXLatitude.


As they first and you later pointed out, the BIOS needs to have a system password set or it never wakes from sleep. You were kind enough to provide a copy of your D430 DSDT which was very similar to the one in their EDP database. In fact, there were only a couple minor differences between the 2. I liked a couple of your device injections better, I think.


The D430 DSDT had much in common with the D620 DSDT, also in their EDP database. However, the Dell Inspiron 6400/E1505 generates a fairly different DSDT from both of these, missing some critical code which can't simply be added back in. In fact, OSXLatitude includes a DSDT in the EDP package for both the D430 and D620 while their install package for this E1505 has no DSDT and includes NullCPUPowerManagement instead. There is also an Inspiron 6400 DSDT available on osx86.com with almost no mods which is useless for anything beyond the basic HPET & RTC fixes. So, apparently, it's not quite as easy ;)


In the end, I got my wake working about 90% but it sometimes still doesn't come back and may KP in IONetworking on wake from time to time as well.


I think the version of the boot manager and the o.c.B.plist flags may be contributing to the success as much as the DSDT mods.


I'm working out a few last kinks and then plan to post it to osx86.com.


Thanks for responding :)

Share this post

Link to post
Share on other sites

Hi bisk,


Its true that EDP contains alot of data for the different models.. more being added everyday .. think we are approaching around 50 models - with plans for around 50 more soon.


I suggest that if you find any improvements that we can commit to EDP, then let me know.


About sleep, then check out this: http://www.osxlatitude.com/getting-sleep-to-work-on-your-dell/


Slice, is that old girl still running ? .. amazing :-) .. replaced mine with a Samsung 900x3c ..




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.