Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[HowTo] Asus z8na + Mio card sound+ 2*E5520 + XFX 5870

1 post in this topic

Recommended Posts

Hello all !

I'm a french newbie on hackintosh steps and I want to share my first experience.




First time follow this tutorial : http://www.insanelym...-for-beginners/


--> For the SMBios I have selected MacPro 4.1


Once you have your hack installed with your dsdt extracted and the

NullCPUPowerManagement.kext deleted ...


You need Network works first : Install my legacy --> Intel82574LZ8naD6.kext with kext utility

(it add the 0x10D38086 String to IOPCIMatch)


Now you need sound for the Asus MIO card : Install AppleHDA.kext with kext utility


If you have a bug with your ATI like a GHOST screen (two display but you have just 1 monitor connected) ... : Install ATI5000Controller.kext with kext utility

(if doesn't work ... do yourself :

http://www.tonymacx8...html#post512322 ).


The IOAHCIBlockStorageInjector.kext is in order to have the good HD icon .. not like an external disk.


Here is my org.chameleon.Boot.plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Graphics Mode</key>


PS : No modification on my DSDT extracted ...


Personnal tips :

On updates your kexts maybe erased like AppleHDA etc ...

My simple things is to do that on terminal :

(tild) $ sudo crontab -e

in this window put that :

#m h dom mon dow command
0 2 * * * cp -rf /patched-z8na/AppleHDA.kext /System/Library/Extensions/AppleHDA.kext
1 2 * * * chown -R root:wheel /System/Library/Extensions/AppleHDA.kext
0 3 * * * cp -rf /patched-z8na/ATI5000Controller.kext /System/Library/Extensions/ATI5000Controller.kext
1 3 * * * chown -R root:wheel /System/Library/Extensions/ATI5000Controller.kext


You need a folder on root named : /patched-z8na

and both kext AppleHDA.kext and ATI5000Controller.kext inside...


What this lines do ? This is a simple task daily :

at 2:00 copy AppleHDA

at 2:01 change the owner of AppleHDA

at 3:00 copy ATI5000Controller

at 3:01 change the owner of ATI5000Controller


Have fun.

Thanks to real3x ;) poney poney++


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By onlyJRevenge
      Buonasera ragazzi,
      grazie all'aiuto di questo forum, sono riuscito qualche mese fa a configurare il mio portatile e ne sono pienamente soddisfatto. Ora mi è sorto un dubbio, per poter utilizzare la porta HDMI esterna per collegare il portatile ad un monitor cosa dovrei fare? Ho letto che c'è la possibilità che questo non possa essere possibile, per via del fatto che ho disabilitato la GTX950M e di conseguenza essa portava il segnale "all'esterno". A voi cosa risulta? Riuscireste a darmi una mano?
      Grazie anticipatamente.
    • By Lilith
      i have a little old mobo with socket 1156 no Sata 3 - biostar tpower i55 and i Was wondering if i had some chance to install a new nvme memory like Intel 760p.
      Due lack of support by my mobo i found a Pci Express card lycom dt-120 to expand my connectivity.
      After some researches i understood that i need a ‘bios support for the boot from nvme disk’. I want some of these nvme memory to install high Sierra and get a killer desktop.
      I think that i haven’t obviously a native bios support cause my mobo is pretty old, so i can’t get an nvme disk and install properly high Sierra hoping that boot?
      Or should i catch anyway? I Guess that same problem is for w10? 
      Thanks, Gabriele.
    • By LuCyr04
      Hi guys, I have a weird problem using an Xeon E5450(775 modded) with nvidia card(8600gt & Quadro 580 FX same problem).
      First I want to say that in windows I don't have any problem, so it's not something about compatibility.
      When I try to boot in macOS with this cpu and nvidia video card I get only a glitch displayed(see attachments), the computer isn't froze, I can access it with ssh or file sharing, only no image.
      If I boot with nv_disable=1 flag I get image(no acceleration of course) and everything's fine.
      I tried the cpu on 2 different boards and 2 different nvidia cards and the problem is the same.
      With amd video card I don't have this problem.
      What I tried and failed:
      Deleting injection from dsdt and injecting or not injecting with clover.
      Using nvidia web drivers.
      Changing CPU settings from bios, like virtualisation, speedstep etc.
      Different macos versions(10.11, 10.12, 10.13)
      The hack I want to use with this CPU is the Desktop from signature, I can provide dsdt or entire efi if it's needed but I don't think it matters since I have the same problem with 2 different boards and 2 different nvidia cards.

    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
    • By sect0r5
      Hello guys I need help for tuning my system for better working possibilities.
      What works:
      Sleep/Wake Audio Ethernet App Store  
      CS:GO not working (other Steam games are OK) Bad GPU performance 40 fps on OSX Cinebench vs 85 fps on Windows Cinebench Big audio latency when using line input      //edit : problem is gone  Slow start of Viber Desktop, OBS and some web pages  //edit : OBS is slow on native MacBook too Sometime random mouse freezings            Huge lags on latest NVidiaWeb drivers(158, 159) Sometimes can't awake and stuck on black screen after restart   //edit : now is alright. magic! Sometimes sound start crackling when watching online video     //edit  : magically gone edit : she come again  
      It's happens on a both Kernel's :
      Shanee 13.3.3
      Clover 4392
      What info i can provide for better results?
      With best regards, Stan.
      Send me stanMacs-Pro.zip