Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
spuker1

Need help with my Dell laptop

6 posts in this topic

Recommended Posts

Hi there,

 

I have successfully installed OSX86 on my desktop PC before. It didn't seem easy at first because it was made with ATi/AMD components and back in the day it was quite hard to get drivers for it. But I finally came across an xXx 10.5.6 distribution which started up nicely from DVD and had everything I needed to get my PC going. I have managed to get it all working perfectly pretty much after trying twice I think (had a small problem with recognising my HDDs and booting properly, but I have moved my main HDD into one of those USB boxes and used my secondary one as a main drive as it came up straight away). Anyways, I know 10.5.6 is a bit dated now but I was running it regardless as it was really trouble free and very very stable. Didn't have a single problem with it. EVER.

 

So,

 

I have managed to buy an old(ish), discarded laptop from my wife's work. It's a Dell Vostro 1520, obviously I want to get OSX running on it. I have tried my old distribution but it's list is missing most of drivers I need. It all starts up nicely if I just push it trough without selecting anything, but It runs without built-in keyboard (although volume and other multimedia buttons work ok :S), sound, network, not sure about USB, uses native resolution and when I check up on hardware lists most of it states 'uknown' (including processor).

 

I was hoping if you guys could point me in some direction of drivers and patches that I would need and how to install them. Or maybe some other distro that is known for working in such a simple way as my old xXx distro.

 

Anyways, here's the spec list of it:

 

CPU: Intel Core 2 Duo P8700 @ 2,53GHz

 

 

CHIPSET: Mobile Intel GM45 Express

 

GPU: GeForce 9300M GS - got that going no poblem

 

Audio: High Definition Audio - That's one of my main problems, it's some sort of unknown generic soundcards. Or maybe I haven't looked hard enough.

 

Network: Yet again some sort of generic Dell made system. No idea. I had problem with getting that working straight after I got rid of pre-installed Vista. Tried Ubuntu 10.12 last night and it didn't have idea what's going on. As you can imagine - No WiFi. Haven't tried cable though, but I have to get it working.

 

for more in depth details the full spec list of it is here:

 

http://www.lapspecs....ell vostro 1520

 

So yea, I need any sort of helpm becuase there's not much about running OSX86 on those. I would love to get it working as no-nonsense as possible as I want to give it to my parents when I'm done with it :)

 

Thank you for all your help up front.

 

Cheers,

 

Tom

 

PS. Sorry for a bloody essay :D

Share this post


Link to post
Share on other sites

Update: I have managed to get almost everything going. Keyboard, Mousepad, GPU, CPU shows up properly now, all USB ports are working 100% fine.

 

I still have problems with getting my audio going. I have installed AppleAzaliaAudio kext with soundflower and it seams to work fine, volume buttons are now on and it all shows up correctly in my system info, except i can't get any sound in or out of it.

 

I still can't get my WiFi working. Cable connection works fine but I need my WiFi.

 

Please help.

Share this post


Link to post
Share on other sites

Run this http://www.insanelym...and-kexts-info/ application or boot to a Linux Live CD (Ubuntu should do) and run LSPCI command like:

sudo lspci -vnn > ~/Desktop/Dell_LSPCI.txt

This should give you a .txt document on desktop named Dell_LSPCI.txt. In the document you should be able to find the info on sound and WiFi cards (and other system devices as well).

Share this post


Link to post
Share on other sites

That system info thing says that my Java isn't up to date enough to run it. Anyway looking at screenshots of that program I have noticed that my OSX86 distribution has got something like that built in to it's utilities when you actually run an install process. But most of things just say that they are Intel/unknown. It also says that my Ethernet card is a Realtek R8111 which is all nice and dandy but I have no idea how to make my WiFi work anyway. But also I

 

 

Same applies to my sound card. It says it's Intel HDA (High definition audio card) and this is it's exact name. I have tried couple of HDA drivers for it that have been added to my distribution but none of them actually make my hacintosh make or pick up any sound at all.

 

Any clues?

 

Also could someone give me a link or very simply explain to me how to manage my kexts because every time I want to do something with them I have to re-install my OSX. I have tried to add something on my own later on but it just ended up in big crash and no booting.

 

Cheers.

Share this post


Link to post
Share on other sites

The main idea behind the LSPCI data is to have device and vendor IDs of the on board components. When you have dev/ven IDs, you can check what devices you have via this site:

http://www.pcidatabase.com/

 

If you run the above command in Linux, it should give you all the system devices with names dev/ven IDs and other info. Once you know your hardware, google for drivers or ways to enable the hardware.

Like in this image:

http://www.dedoimedo.com/images/computers_years/2012_1/hardware-troubleshoot-lspci.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×