Jump to content
InsanelyMac Forum
ramonbd

Ultrabook Samsung Series 5 + Intel HD 3000 + Mountain Lion= Tela Preta

Recommended Posts

Boa Noite Galera

 

Tenho um Ultrabook da Samsung Series 5. Instalei o Mountain Lion usando o comando "-x -v -f GraphicsEnabler=No PCIRootUID=0 npci=0x3000" pois sem ele não aparece a tela de escolher idioma, fazer as partições etc.

 

Logo após a instalação, quando reinicia o Ultrabook tenho que entrar no modo Single User e fazer o seguinte procedimento:

 

 

fsck -fy

mount -uw /

mkdir /intelhd_backup

cd /System/Library/Extensions

mv AppleIntelHD* AppleIntelSNB* /intelhd_backup

reboot

 

Senão ele trava em uma tela Preta e não aparece a tela de login e nem nada mais.

 

Feito isso. Atualizei para o ML 10.8.2. Note reinicia e entra no sistema normal.

 

Dito isso segue os problemas:

  • O M u l t i B e a t s dá erro na hora que aplicar as alterações.
  • Não consigo de jeito nenhum ativar a HD 3000. Sempre dá tela preta. Daí eu tenho que ir e fazer os passos citados anteriormente.

Alguma ajuda?

Share this post


Link to post
Share on other sites
Advertisement

Acho que eu que estou dando manota então. Depois que a gente manda compilar, que dá isso. O que eu devo fazer? Eu achava que a compilação era o último passo. Nunca usei o DSDT.

Share this post


Link to post
Share on other sites

olá

 

convém começares a ler alguma coisa como isto

 

http://olarila.com/forum/viewtopic.php?f=7&t=646

 

depois isto

 

http://www.insanelymac.com/forum/topic/284026-pos-instalacao/

 

e muito + k se encontra aki no forum

 

mac os x é desenvolvido para macs

 

hacmac os x é 99% de leitura, googling (google é teu amigo), persistência e 1% de sorte k teu hardware seja compatível

 

bom hack

Share this post


Link to post
Share on other sites

Fiz tudo certo, instalei as dsdt na pasta extra

 

Só que mesmo assim nada do vídeo.

 

Aí eu percebi, parece que o problema é nas kext :

 

AppleIntelSNBGraphicsFB.kext

AppleIntelSNBVA.bundle

 

Pois apaguei só essas e entrou. Não com o vídeo acelerado, mas pelo menos saiu da tela preta.

Share this post


Link to post
Share on other sites

olá

 

convém atualizares no teu perfil > assinatura, as tuas especificações de hardware, qualquer coisa como tenho no final da minha resposta.

 

bom hack

 

cpu

gráfica

som

lan/wireless

 

bom hack

Share this post


Link to post
Share on other sites

Hello Forum,

 

I hope somebody here can give me some short instructions, hints...

 

I'm using (bought few weeks ago) samsung ser.5 ultrabook np530u4c - c02

 

for my further work (of ocurse I've got a Mac but only installed with ML) I need a Snow Leopard

 

Installation on a 2nd Partition the other should be reserved for Win7 ultimate

 

my 1st and working osx86 machine is a 10.5.8 Leopard on an Acer TM6292

 

thanks for help and solutions

 

regards

Share this post


Link to post
Share on other sites

Mesmo ultrabook mesmo problema.. ainda nao consegui resolver...

Ja usei o Dual link no dsdt mas tela preta ainda...

Consegui uma tela preta porem com backlight usando uma kexts para CCE 745B aqui no forum..

Share this post


Link to post
Share on other sites

So consigo video com aceleracao pela saida hdmi, ja tentei editar os conectores AppleIntelSNBGraphicFB, porem sem sucesso...

Alguem pode ajudar?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×