Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

AB1988B SupremeFX 2 not seeing green rear port

14 posts in this topic

Recommended Posts

Hi all, i've been trying to get this to codec to work but i seem to be having an issue. I installed the ab1988b codec from old napalm and a few other codecs from osx86 . net and I can't get the green port to appear in system preferences. It worked once but then i tried to update to 10.8.2 and it broke everything, so I formatted and installed it again just how i did before and i've never been able to get it back. I'm thinking it may have something to do with the hdmi port from my video card but I'm pretty lost as to what to try next. I'm running an Asus Striker 2 Extreme nforce 790i with the supplied Supreme FX 2. Any help is appreciated, thanks!



Share this post

Link to post
Share on other sites

It may have to do with the number of outputs supported by AppleHDA. I'm not sure if this has changed since 10.6 but I asked about this when I was working on my ALC883 and was told that AppleHDA has a limit of 4 outputs. So if you want all 4 analog outputs you have to disable S/PDIF out.

Share this post

Link to post
Share on other sites

I have Asus P5E Deluxe with ad1988b, and I use this:


VoodooHDA AD1988B 7.1 - Downloads - OSx86.net


No 5.1 etc, but 2 channel working. Starting application and preferences are from voodoo 2.7.4


VoodooHDA 2.7.4 pkg installer - Downloads - OSx86.net




T -.-



tle88, unfortunately i've tried that one before and gives me the same problem ;(





It may have to do with the number of outputs supported by AppleHDA. I'm not sure if this has changed since 10.6 but I asked about this when I was working on my ALC883 and was told that AppleHDA has a limit of 4 outputs. So if you want all 4 analog outputs you have to disable S/PDIF out.



Riley, do you know how I would go about disabling the S/PDIF out? I definitely won't be using that one and would gladly get rid of it.

Share this post

Link to post
Share on other sites

If you're using VoodooHDA it might not apply. But I can't be sure as I've no experience with it. If you are then have a look at VoodooHDA documentation or guides.


For AppleHDA you'll need to edit it out of the layout and platform xml files. You might also have to remove it's pinconfigs too. Then add the necessary data for the green port. Have a look at this topic for details on editing AppleHDA. The codec is different, but the process is the same. If you can find a pre-edited AB1988B kext then you might only have to make some adjustments.

Share this post

Link to post
Share on other sites

@ manny


See http://www.insanelym...o/#entry1842852..........I use a modified version of oldnapalm's original version VooddoHDA.kext for AD1988B, that has a default association of 0x02214050 for node 17 in the VoodooHDA.kext Info.plist file rather than the original of 0x0221401f and have:


Sound Output:


- Headphones (Green Front) - Working via manual selection in sound prefs

- Line-out (Black Rear) - not tested

- Line-out (Green Rear) - working via manual selection in sound prefs

- Line-out (Grey Rear) - not tested

- Line-out (Orange Rear) - not tested

- SPDIF-out (rear) - not tested


Sound Input:


- Line-in (Blue Rear) - not tested

- Microphone (Pink Front) - working via manual selection in sound prefs

- Microphone (Pink Rear) - not tested fully as not convenient to use


working with OS X 10.8.2....... :)

Share this post

Link to post
Share on other sites

Verdant, i've tried using that one and unfortunately am still getting the same ports available as listed in the OP :( . I think it might have something to do with the hdmi port on my video card. I've been reading on needing to modfiy some info.plist to skip looking for that particular controller... do you have any idea what that might be?

Share this post

Link to post
Share on other sites

@ manny


Have you checked to see if this topic offers any help..........http://www.insanelymac.com/forum/topic/220707-solved-acl889-and-hdmi-video-card/........?

Share this post

Link to post
Share on other sites

Verdant, that link helped out a bunch. I edited the 7.1 AD1988B kext to skip looking for the hdmi port in my video card and like magic all my ports including front and rear microphone are working!


Thanks alot dude!

Share this post

Link to post
Share on other sites

Well, I spoke too soon. It looks like my computer froze just a bit ago and when i was finally able to boot into osx (after a few KP's) my sound preferences once again looked like the picture in the OP ;x

Share this post

Link to post
Share on other sites

@ manny


Sorry the fix does not appear to be sufficient..........it will be helpful to post your kext changes here for readers to check and compare with what is working/not working for them........ ;)


What kexts did the KPs point to? All the same kext, or different.......?


I wonder if there is another kext is also looking for and activating the HDMI port?


If a permanent solution is identified, I will include it in my OS X 10.8.2 nForce guide.

Share this post

Link to post
Share on other sites

The modifications to the audio kext were adding these in:







Hrm.. do you have any guesses as to which kext might be activating the port?



Also, the KPs point to like four different kexts each time. One of them being IOPCIFamily I think. When i work up the courage and boot into OSX i'll find out which ones and then i'll post them more in detail


Do you think it might be necessary to try and add similar lines of code to AppleHDA as well? I've tried with and without AppleHDA and still get the same results so i'm not sure it matters..

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By spectra
      Hi people, can someone help to put my HDMI sound working? I already tried different methods and I can't figure a way to fix this problem.   And another question, someone knows why the HDMI port just work if i use macbook pro 14,2 on smbios? Because my hardware is much more similar to 14,3.    
      thanks guys
      My system dump
      DarwinDumper_3.0.4_01.02_12.24.51_MacBookPro14,2_AMI_X64_4392_High Sierra_17D47.zip
    • By bigben1
      hi there!!!
         my system specs are
      ga z170x ud5,
      i7 6700, cpu
      gtx 1060 6g,
      16gb ram,
      sierra 10.12.6.,
      everything working except can't enable hdmi for 4k lg monitor.i have sound through back panel and front panel using alc1150.kext and all 100/200 series kext.
      any help is much appreciated.

    • By unexpectedsense
      Estimados desde ya muchas gracias por cualquier aporte que puedan hacerme para intentar solucionar en este caso el AUDIO HDMI y si fuera posible las frontales de micrófono y auriculares.
      Tengo corriendo Mac OS Sierra 10.12 en una ZOTAC NANO ID61 y va muy bien en el desempeño general y los gráficos aunque el video algo ralentizado.
      La instalación inicialmente arrancó (siempre en SAFE MODE y hasta ahora mismo, de otra forma queda en la manzana eterna) sin red (el bluetooth funciona perfecto) y sin audio.
      Em el caso de la red pude hacer funcionar la ethernet con la kext RealtekRTL8111.kext pero no directamente sino a través del paquete HoRNDIS-rel8.pkg.
      Para el caso del wifi el DPCIManager me muestra Centrino Wireless-N 130 integrada que no he podido hacer funcionar pero no es prioridad ahora mismo puesto que tengo red.

      Los datos de manual y algo mas son:

      ZOTAC ZBOX nano ID61

      • American Megatrends - Core Versión - UEFI 2,1
      • Intel HM65
      Onboard CPU
      • Intel ® Celeron ® CPU 867 @1,30GHz
      Onboard graphics
      • Intel HD Graphics Family
      • HDMI & DP output
      • 8 GB SO-DIMMs DDR3-1333
      • SATA 320 Gb
      • Gigabit (10/100/1000Mbps) LAN
      • IEEE 802.3 compatible
      WiFi/Bluetooth support
      • Compliant with IEEE802.11b/g/n standard
      • High speed wireless connection up to 150 Mbps • Fully qualited Bluetooth v3.0
      • 2-channel high-definition audio • Jack-sensing compatible
      • Optical SPDIF
      Operating System support
      • 32-bit and 64-bit support
      IR receiver
      • Support carrier frequencies 36k Hz

      NOTA: En la Bios / Chipset /OnBoard Device Configuration, hay un item AZALIA con un sub item AZALIA INTERNAL HDMI CODEC que probé habilitado y desabilitado. Si lo desabilito desaparece en el DPCIManager. Habilitado aparece pero no el Codec ID.
      * Por otro lado hay un item de la Bios /Advanced que es Sandybridge PPM Configuration que por default esta todo habilitado.

      La guía que use en el intento de hacerlo funcionar:


      Al ejecutar audio_cloverALC-120.command
      La terminal muestra:

      Last login: Wed Aug 16 04:05:36 on ttys000
      Mac-mini-de-umac:~ umac$ /Users/umac/Downloads/audio_cloverHDMI-120_v1.0d.command ; exit;
      The audio_cloverHDMI script is for personal use only. Do not distribute
      the patch, any or all of the files for any reason without permission.
      The audio_cloverHDMI script is provided as is and without any warranty.
      File: audio_cloverHDMI-120.command_v1.0d
      Release Mode
      EFI partition is mounted

      No audio codec detected
      No system files were changed
      To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
      Saving session...
      ...copying shared history...
      ...saving history...truncating history files...

      [Proceso completado]

      Con MACIAsl agregue algunos repositorios de Toleda (audio hdmi hd 3000, zotac), pero no pude en ningun caso aplicar patches.
      No se si he sido extenso en la descripción o me falta algun dato importante, disculpas por ello.
      Reporte DarwinDumper
      DPCIManager (pantalla)
      IORegistryExplorer (pantalla)
      Informe de Sistema (algunas pantallas)

      Saludos y gracias desde ya.
    • By imjohnjo
      Hola de nuevo a todos!!!
      Como dice mi titulo, tengo un problema con el audio, pero no es que no lo reconoce ni nada por el estilo, sino que al conectar el HDMI, el audio onboard de la motherboard (Z97X Gaming 3) se desactiva y solo puedo controlar el audio del HDMI; que en este caso es solo el volumen de salida. Y este ultimo desde los controles del TV, ya que no uso un monitor.
      Mi problema es que necesito la entrada de microfono que tiene mi placa de audio onboard, pero como tengo conectado por HDMI, solo me deja controlar la SALIDA y las entradas no me figuran por ningún lado. Ni en la pestaña de Efectos de Sonido, ni en la pestaña de Salida. Les dejo una captura de mis Preferencias de Audio:


      Que solución puede tener a mi problema? Desde ya les estoy agradecido por su tiempo
    • By edgaarcervantes
      Les dejo un antecedente de mi problema:
      Hace unos meses instalé Hackintosh en mi pc, a travez de un .dmg de Yosemite-Zone que encontré por ahí en un video de Youtube. Deje el sistema como venía, solo instalé el driver de red wifi a travez de un .kext y así lo estuve utilizando por mucho tiempo.
      Se descompuso mi pc y tarde mucho en mandarla a reparar, después de un tiempo ya la tengo disponible y decidí retomar el proyecto que tenía.
      Fui por ahí instalado los drivers que me faltaban, Ethernet, USB 3.0, Hot Key, Bateria, etc., todos estos a travez de .kext, tuve suerte pues no batalle en lograr instalarlos, había un monto de archivos en la red, si no funcionaba uno intentaba con otro (todos de acuerdo a mi hardware); Pensé que no me faltaba nada hasta que conecté la pc al televisor, me di cuenta que no funcionaba el audio de la TV si no el de los altavoces internos de la computadora.
      Me quise dar a la tarea de solucionarlo, cosa que no pensé fuese tan difícil, puesto que todos los post que he encontrado son en ingles y hablan de un idioma que totalmente desconozco, que si tengo que parchar los dsdt, ssdt o config.plist, un montón de cosas que no logro entender.
      Estuve intentando hacer alguno de los tutoriales que ofrecen pero, siempre me estanco en ciertos puntos. No pude encontrar ningún tutorial en español acerca de mi hardware.
      Quisiera saber si alguien puede orientarme para poder solucionar mi problema
      Les dejo algunas características de mi pc:
      - Tarjeta madre: Asus k43e
      - Procesador: i3 2350m 2da generación
      - Gráficos: Intel HD 3000
      - Audio: Realtek ALC 269
      - Sistema: Yosemite 10.10.5
      No sé si sea necesario alguna otra información o que anexe mis .dsdt o ssdt.
      Anticipadamente, gracias.
  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies