Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Faizan Ahmed

Need Help in Graphics Problem in mountainlion Nvidia 8400gs

6 posts in this topic

Recommended Posts


i am having issues with my graphics since the new 10.6.8 combo update with NVDAHAL50.kext been used i tried many solutions posted on different forums but didn't work for me.

i used patched Nv*.kext with device id with message nvdahal50 has been loaded after it my monitor gives no signal but computer still working also used nvoverride but same result


or when i used NVenabler64 kext my monitor show this black and white patrens and hangs


need help in it i m a bit worried about it as i have to use finalcut pro as my graphics card wont work nor i can do work on fcp


waiting for some usefull reply



Share this post

Link to post
Share on other sites

using vga or dvi ?

Nvidia 8400gs 512mb ddr2 Device id 06e4 should be supported by graphicsenabler of chmeleon 2.1 as its the older video card not 10c3

Share this post

Link to post
Share on other sites

download and install latest Chameleon


Add device ID in /system/library/extensions/NVDANV50Hal.kext/contents/info.plist


Find an NVinject.kext, any one will do, they're basically the same


Graphics Enabler:




Boot with -v

and if you get stuck at [PCI configuration begin]


Boot with -v NPCI=0x2000




Boot with -v NPCI=0x3000


Try this one too:



Share this post

Link to post
Share on other sites

Just to clarify, can you please verify which OSX update you installed, I know your running ML and there is no new 10.6.8 update since it came out a couple years ago so assume you meant 10.8.2 combo update?

Share this post

Link to post
Share on other sites

i've instaled 10.8 no update i used yet . I instaled iatkos 10.6.3 first then i combo update to lion ready. 10.6.8.


tepaks. I tried it with nvenabler64.kext and get that black n white paterns n hang.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By justgeeking
      First thanks for the help from everybody that i PM and those whose responded in my post.
      Seems linking this was a no no to other users posts was just trying to help out removed the links.
      I am gonna try to do this real simple and quick. I tried almost all the methods for the USB stick installer some went well others not so well.
      This is a unaltered restore no add ons to the USB Stick just simple and plain restore.
      1.Get to any real mac or pc mac to do the USB Stick Restore.
      2.Do not use any MBR formats keep it strictly GUID.
      3.Open disk utilities now tab your USB Stick in the left pane then choose RESTORE grab your Dev Prev 1 Dmg don't mount it just drop it in your source and USB Stick to destination and restore erase will be called for with admin pass on lion.
      4.once everything is done take both the HD your gonna install Mt Lion on and your new ESD USB STICK over to any real mac and the ESD will mount choose install and pick the the 10.8 HD your gonna install it this is not for dual Boot HDs and run the installer after you choose the disk it will restart as usual and it will install a nice fresh copy of 10.8 done! restart into the new 10.8 HD fill in your info.
      5.Check all the apps everything should work no crash apps like in the forums. it will work!
      6.Eject the USB Stick your done with it! Take the 10.8 HD to your pc running Snow or Lion Grab yourself Kakewalk 4.1.1from his site Donate if you like buy his app for a Buck! The Guy came through for alot of us. http://www.kakewalk.se/download/
      7.Your 10.8 can be mounted via USB or eSata or internal sata it doesn't matter just get it mounted on your desktop, Pop over to linx2mac and grab his newest kext version .90 http://lnx2mac.blogspot.com/p/realtekrtl81xx-osx-driver.html I used that one if you read his forums it says it wont work but with this version it will i used Pacifist 3.0 leave the, kexthelper app alone dont use it! In Pacifist open the realteck pkg and right click on it and choose your 10.8 HD to install the Kext.
      8.Run the Kakewalk 4.1.1 app choose upgrade option choose your motherboard and the 10.8 HD and let it install ... if the permission weren't fixed, its ok the pop up window will tell you use disk utilities thats what i did.
      9.Install this version of Chameleon_2.1svn_r1820_trunk_10.8 and dont chose anything no smbios nothing... just make sure you change the installation to 10.8 cause i wasnt paying attention while i was lighting up my stogie and it did my LION i fix thank god.
      10.Now after your done fix the 10.8 HD permissions and restart.
      Thasts all i did!!!! gonna uploads screen shots
      for non gigabyte owners there has to be something equivalent to kakewalk4.1.1 for you folks