Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

Cannot force 32-bit on Lion install

3 posts in this topic

Recommended Posts

I've tried editing the chameleon boot file, default apple boot file in /L/P/, using arch=i386, yet it still seems to boot to 64-bit mode (as per verbose mode) and kernel panics once it begins to load my nvidia driver...



Is there some magical way that this flag suddenly takes effect that I'm not aware of? I've been fighting this for a few hours now.


I've tried a few guides including the most recent here http://www.insanelymac.com/forum/topic/267862-tutorial-install-lion-107x-on-dell-xps-m1210/

I dropped that guide after it failed to work after installing everything and decided to go with HackBoot. Setup works great, looks great, has all the nice effects in the right resolution, but once I go to boot up it just panics.

Share this post

Link to post
Share on other sites

You need to use Extra folder inside root dir. and com.apple.Boot.plist or org.chameleon.Boot.plist

Dont touch - default apple boot file in /L/P/

and flags is this:


<string>i386</string> :wink2:

Share this post

Link to post
Share on other sites

Never even crossed my mind to use



instead of

<key>Kernel Flags</key>


Thanks husaber, you're a godsend.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.