Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Shasoosh

chains boot error vs efi_inject_get_devprop_string null trying. Can't load Lion

2 posts in this topic

Recommended Posts

I have a Windows 7 install and a Lion one.

Recently I added a new HFS+ empty partition to my system and since then i can't boot my Lion.

I tried recreating my MBR with easybcd, adding new entries etc' but i always get "Chains boot error".

If i try to use the EFI option in easybcd i see the chameleon screen on boot but after a few secons i see an error msg: efi_inject_get_devprop_string null trying stringdata and my system restarts.

 

My last try was downloading tboot that i found, renaming it to nst_mac.mbr anf that worked! I'm getting a Non-gui camelion screen that let me choose my OS.

 

So basicly i don't really understand what's going on.. why the EasyBCD EFI crash while other works fine?

Also, what ever i tried i couldn't change chameleon settings. I tried changing stuff in Chameleon Preference Pane in Lion but it's like the chameleon version that boots up ignore those settings. Is there a way to change chameleon settings from the chameleon screen itself without actually booting?

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×