Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Rampage Dev

ATI Mobility Radeon 4650 Mountain Lion

18 posts in this topic

Recommended Posts

Post your DSDT and IOreg and I will inject your GPU into your DSDT and give you the AppleHDA I was using. This will give you HDMI audio out.


Also what wifi card are you using in your laptop? The native one will not work and I want to replace it.

Share this post

Link to post
Share on other sites

Ok I have attached my DSDT and ioreg for inject GPU and HDMI.

ioreg n dsdt.zip


Thank you so much for your interest.


As you have the same one - N5010, you know this one comes with bcm4313. I replaced it with Atheros AR9285 from ebay. using this kexts -http://www.osx86.net/downloads.php?do=file&id=2311 .


I have added my HDMI on dsdt, pached AppleHDA works but no output :( . Don't know what's go wrong. So using voodoo HDA.

Please correct HDMI info, if anything wrong and send your AppleHDA.

Share this post

Link to post
Share on other sites

I had replace AppleSmartBatteryManager.kext, its working. So haven't load voodoo battery. Installed AppleHDA, replaced dsdt. Sounds works , but no input :( .



I have attached my codec_dump and ioreg for your consideration.

codec n ioreg.zip


Thank you.

Share this post

Link to post
Share on other sites

Yes I confess. You have edited a few things.

Thanks man...

Here is the kext I am using.power.zip


If you suggest me to load voodoo, please tell me.


Consider audio kext, I think something wrong with device id on DSDT, help me to correct audio.



Share this post

Link to post
Share on other sites

When i setup ATY_INIT.kext for my graphics card driver, it worked. But it just worked on external monitor screen not laptops screen. I just saw black screen on laptop. After boot, the laptop screen still seems black. But the external monitor which i connected by VGA output is worked.


In the following link you can see the pictures which i took for clear understand. Are there any other ways to setup this graphic card ?

Link: pictures and kext files


Note: I tried to setup shrike and peregrine versions of ATY_INIT.kext but it failed. Both of the screens internal and external didn't worked. But when i setup motmot version it worked like which i told above.


Thanks for your helps and sorry for my bad english..

Share this post

Link to post
Share on other sites
Guest minty_lite

Could I request also for AMD Radeon 6320 Graphics Card using ML?


I have

~ Sony Vaio Y - VPCYB4AJA

~ AMD Dual Core E-450 APU @ 1.65GHz

~ 2 GB Ram

Edited by fantomas1
hi minty_lite pls open another topic for your request :) cordially, staff

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.