Jump to content
theconnactic

[Help Needed] My 10.7.4 system cannot see my PATA disk!

9 posts in this topic

Recommended Posts

I used to say that my system is running just fine, but something just came to my mind: i have a tower with four disks, three SATA disks (one of them, exactly the one that contains my Lion OsX, is a 2'5'' from an old netbook, lol) and one 40 GB PATA disk, this one having a Win7 installation.

 

 

My BIOS is set to AHCI. When the AHCI BIOS loads, it shows four devices. My four disks, right? Wrong answer: it shows the three SATA ones plus my optical drive, which is also SATA. Here, no surprises at all. Then, enter the Chameleon. At the Chameleon boot, my PATA disk is listed with the other three, and i can boot Windows without issues, and from Windows i can read and write on the other disks by using MacDrive.

 

 

However, when i boot in OsX, i simply cannot see my PATA Windows disk, even using Disk Utility. I tried to fix it today using a Snow Leopard patched kext, AppleIntelPIIXATA.Kext, but nothing changed (and i did it as pure guessing, since i don't really know if this kext is related to PATA issues). Then i did a lot of googling, but the only thread i found (in fact, here at Insanelymac:

http://www.insanelym...howtopic=166133

) adressing this issue remains unanswered since it was started,

three years ago

!

 

 

Maybe there's no solution, but maybe the answer is so obvious that it didn't worth an answer in the past. Anyway, i'm afraid it is quite un-obvious for me: how could i make my PATA HD a visible prey to my SATA big cat?

 

 

Thanks in advance!

Share this post


Link to post
Share on other sites
Advertisement

First off. It is a Windoze drive, why would you want to?

 

Second. Try AppleATIATA.kext installed with kext wizard or kext utility.

Share this post


Link to post
Share on other sites

Answering the first first: i have tuxera NTFS, i want the possiblity to read and write to my Windows disk from OSX, which i still havn't, because my PATA disk isn't recognized.

 

The second one: thank you very much for the suggestion. I'll try ASAP and report here.

Share this post


Link to post
Share on other sites

Try a copy of OSX86Tools.app.

On the lower panel's top left corner is a button for View PCI Device/VenderID. Click that and install the LSPCI when it asks (if it isn't already installed) and click Run LSPCI.

It will give you a whole list of everything connected to the PCI buses.

 

Mine has one for an ATI IDE controller, which is your PATA drives.

 

Don't try writing to your ntfs drives however. You can read from them. but if you write to them from OSX it messes them up, and you may end up reinstalling Windoze.

If you need something from your Mac drives on the Windoze drives then use MacDrive or simular in Windoze to move it from the Mac drive to the Windoze drive (I alwasy stick something like that into the Downloads folder. Easier for me to find that way)

 

Oh, yeah. And if you would please insert your Hackintosh stuff in your signiture or something, it would make it easier to know if some of the rest of us might have the right answers for you.

 

I am running SL and Lion (not very well yet, 32 bit kernel only at this point) on an AMD based motherboard, and some of the stuff maybe or is different from the Intel based motherboard stuff.

 

 

And if I seem a little testy, I apologize. Waiting for my pain meds to kick in for the night. Recovering from an operation on my right foot. Doc tells me I have about 7 weeks of very limited mobility to go.

Share this post


Link to post
Share on other sites

I have OSX86 tools. It simply didn't come to my mind to use it to solve this issue. Thank you for the tip, very much indeed.

 

I've been using tuxera NTFS for a long time now w/o issues, but will keep in mind the points you raised from now on.

 

As for the kernel, you can get 64-bit support (but not load 64-bit kext) if you have a ssse3-capable CPU (Bulldozer). There are people making experiences with 64-bit patched kernels, without success until now, but however. You can follow this topic: http://osx86.co/f100/10-7-4-amd-kernel-t7687/

 

Thank you!

Share this post


Link to post
Share on other sites

There is also a kext for nvidia ata, but I don't remember the name right off hand. Will search and drop it here if I find it.

 

 

Found it:

AppleNForceATA.kext

I didn't use it because I have the AMD ATI components in my homebuilt.

 

And I am still trying to get 10.7.3 Lion working on mine. AMD processors are becoming the lame little brother as far as the 64bit kernels go and looks like by Mountain Lion I will have to build one with Intel instead of AMD. Too bad. I really like the AMDs!

Share this post


Link to post
Share on other sites

Thanks for the answer.

 

My SATA controler is an AMD Southbridge. So, ATIAta should work. But it didn't. Tried to make an experiment, altering the SATA mode to IDE: that gave me a Kernel Panic which backtrace was "init".

 

So i'm afraid i threw the towel. By now, at least.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×