Jump to content
InsanelyMac Forum
Sign in to follow this  
r b

Sleep / Wake problems on Asus P5e-vm HDMI

Recommended Posts

Hello everyone (skip to the bold text below if you get bored easily or are in no mood for a story),

 

Working on my first osX86 install, and i'm finding it challenging.. which is interesting at least!

I've already tried many different patched .kext(s) , bootflags, and even hardware configs / os configs to resolve some of my outstanding issues... without success. Every time I seem to fix one thing, that fix seems to break another thing that was working before.

 

System is: asus p5e-vm hdmi (w/atherosL1 gigabit NIC AND ALC883 audio), core2quad, gtx260, OCZvertex2, 8gb ram

 

Install flash media created using ###### and the fresh install works fine once I overcame a few issues like the black screen on install (resolved by setting >npci=0x3000 PCIRootUID=0< in the .plist) . Using chameleon 2.1 as bootloader.

 

D-link DWA-556 wireless card worked immediately as did the GTX260.

Initially, I had no sound and no ethernet, but was able to find working .kext(s) for both the atherosl1 and the alc883 audio.

I then struggled to get sleep / wake functionality working..

 

I've had a few different sleep issues:

1. not properly sleeping (only turning off the monitor and then not waking again)

- this was fixed by a patched AppleRTC.kext which, as a side effect, i can no longer restart the system (without using the power button). This also fixed the CMOS reset issue I was getting every time I powered it off after a failed sleep/wake attempt.

 

If I can get sleep working properly.. it won't bother me too much if i can't restart!

 

2. properly sleeping, but then the video not coming back (resolved this by darkwake=0).

 

3. sleeping, and then immediately waking up.

 

**This is where I am now:

If the NIC is enabled (wi-fi card disabled), the computer sleeps perfectly. Upon wake, ethernet no longer works (i have tried setting static ip and dns, setting service ordering, and creating a new "location" ).

I've tried using patched IOPCIFamily, & AppleACPIPlatform .kext(s) as well.

 

... the only thing i haven't tried is reverting back to an older version of mDNSResponder as some people have reported as working. I would love to use the ethernet instead of wi-fi but can't seem to fix ethernet after sleep.

 

If I disable the ethernet and instead use the dlink wifi card, the system immediately wakes up.

Ethernet continues to work after wake at least... :|

 

I think my next step is trying the old version of mDNSResponder.

 

BTW, i used DSDT editor to extract my own, compile and then patch my dsdt.aml with patches specifically for my motherboard that I found on olarila.com .

Here is what I have in my /Extras/Extensions folder in case you might wonder: bold items are for ALC883 audio support.

 

 

AHCI_3rdParty_SATA.kext FakeSMC.kext IOUSBMassStorageClass.kext

AppleACPIPlatform.kext HDEFInject.kext JMicron36xATA.kext

AppleHDA.kext IONetworkingFamily.kext LegacyAppleHDAHardwareConfigDriver.kext

EvOreboot.kext IOUSBFamily.kext LegacyHDAPlatformDriver.kext

 

Do any of you fine folks have suggestions on how to fix the ethernet disconnect after sleep issue?

Sorry for the rambling and thank you!

 

-Ryan

Share this post


Link to post
Share on other sites
Advertisement

I've just read ur topic

I have also same mobo but i'm stucked @ 10.5.8 (everything seems to work fine, except the shutdown) because my cpu/vga/ram was not so fast/powerful.... Anyways the only way to use the lan when the computer wakes, is to unload and load again the lan kext.

In my case it can only sleep/wake twice, because at 3rd wake the lan doesn't work anymore, no matter if the kext is unloaded and loaded again...

I was tryng to update my system to 10.8 or 10.9:

Can u please hook me up with ur dsdt+extra so i can have a try? Thnx a lot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×