Jump to content
InsanelyMac Forum
DislikeYou

[Guide] Intel DZ77GA-70K

Recommended Posts

Intel® Desktop Board DZ77GA-70K

10.8 Mountain Lion Guide

axCRd.png

Note: You will need access to a Mac or OS X in VMware/Virtualbox to download

OS X from App Store and create the USB stick. Min. 6 GB USB stick required.

 

Note: All downloads at end of page.

 

Show hidden files:

Download ShowHiddenFiles and open it. Click Show.

aS20j.png

Open InstallESD:

cQtvm.png

Doble click InstallESD.dmg

H7ABL.png

Right click BaseSystem.dmg. Select Open.

7FDfB.png

Partition USB:

Select USB stick. Click Partition. Click on Current. Select 2 partitions.

J2QkT.png

Select Options. Select MBR.

2KRkI.png

Click on first partition and name it Chameleon. Format: MS-DOS (FAT). Type 1.00 as size and press enter.

oA2eS.png

Select second partition. Format: Mac OS Extended (Journaled). Click Apply.

YjRjQ.png

Restore Base System:

 

Select Mac OS X Base System. Click Restore. Drag Untitled 2 to Destination. Click Restore.

XB9Sz.png

When process finishes, unmount BaseSystem.dmg

dTwAB.png

Packages:

 

Delete Packages link from Base System partition on USB stick.

3kDKJ.png

Copy Packages folder from Mac OS X Install ESD to the Installation folder where you deleted Packages link.

Na50x.png

N5nug.png

Kernel:

Copy mach_kernel from Mac OS X Install ESD to Base System.

GD2Yn.png

L4GAw.png

Hide Hidden files:

 

aS20j.png

Install Chameleon:

Click Continue.

33QSp.png

Continue.

qcCZC.png

Change Install Location.

covcr.png

(Optinal. You can Customize if you want. But i don't recommend using that option).

5ZcGh.png

Select Chameleon partition on USB stick.

Note: To install to HDD, select your OSX Partition on HDD.

SVLUf.png

Close.

wqNYj.png

Copy my Extra folder to Chameleon partition or root of your OSX HDD.

 

W9qrG.png

My Extension folder has kexts for PS/2 keyboard. If you don't use PS/2 remove them so it looks like this.:

l3PeH.png

Reboot. Press F10 at boot. Select USB stick.

Press down arrow on keyboard. Select Mac OS X Base System partition. Have fun installating OSX.

 

Install Sound:

 

Move it to Application and then drag it to dock.

 

 

Extract Interim_Ivy_Bridge_Lion_AppleHDA.

Drag AppleHDA.kext to Kext Utility icon in dock.

 

Reboot.

 

DSDT:

I will upload my DSDT when i patch it.

If you already patched yours then delete HDAEnabler898.kext from Exensions folder.

 

Guide might have errors. I finished writing guide but accidently pressed back button on my mouse. So everthing was lost.

Had to re write and i am tired now. Will check for errors some other time.

ShowAllFiles.zip

Extra.zip

Interim_Ivy_Bridge_Lion_AppleHDA.zip

Chameleon-2.1svn-r2035.zip

Share this post


Link to post
Share on other sites
Advertisement

Great.

 

Thanks DislikeYou, your guide is very clear.

 

I managed to make the hackintos very easily.

 

It seems to work fine, except the wi-fi integrated not recognize me.

 

I await instructions to get it going.

 

Thanks - Maurizio :thumbsup_anim: :thumbsup_anim: :thumbsup_anim: :thumbsup_anim: :thumbsup_anim: :thumbsup_anim: :thumbsup_anim: :thumbsup_anim:

Share this post


Link to post
Share on other sites

dislikeyou, thanks for the guide, just got my dz77 last week and i can get everything to work except for the sound and updates to 10.8.3. cant even update to 10.8.1 to do an incremanent update to .2 then to .3. any help there?

Share this post


Link to post
Share on other sites

ok, got the sound and 8.1 update done. there is supposed to be a driver from ralink i think it was thats supposed to work. looking forward to getting 8.2 or 8.3 installed. also, anyway to change the smbios to mac pro with out causing kp in the bluetooth?

Share this post


Link to post
Share on other sites

did my research, and there is a driver for the wireless by ralink, i downloaded and installed the kext, and guess what... it doesnt work :( i am however happily typing this on my 10.8.1 build complete with dual boot windows 7 on my core i7 3770, geforce 660ti. thank you dislikeyou.

Share this post


Link to post
Share on other sites

Please, can you help me ?

 

I have the same motherboard and

i7-3370-3.40GHz

nVidia GeForce GT630 1GB

8GB memory

 

I followed all steps of your guide but I can only boot the system with -x . The system only boot to install with -x and after.

The only difference is the Chameleon 2.1-r2069 that I have installed.

After install I create a folder "Extra" in the HD and I placed inside your extension folder and your dsdt file.

I tried to boot but no success without -x

With -v the boot stop with this screen below. Do you have change something in the Bios ? I have only changed the SATA Mode to AHCI and nothing else.

 

Please help me

 

Thanks a lot

 

foto.jpg

Share this post


Link to post
Share on other sites

adrianomm make sure you are following the steps to the "T" i got mine to work with in a few tries of messing around with the kext files, and everything i need to work works, but what i want is another thing, am having issues changing the smbios w/o my machine kp'ing. but, back to your issues, follow the directions to the letter, andif you have any questions along the way, stop and ask. i'll be happy to help as much as i can.

 

 

BTW... you shouldnt have to make the extra folder at all. chameleon does it for you. or it does for me. also, make sure you are installing the kexts using a kext installer for ml.

Share this post


Link to post
Share on other sites

This post is a Work In Progress!!!

 

 

I want to inform you that there is a better way to boot OSX on this board, by using Clover EFI bootloader.

 

With Clover you don't need to create a patched DSDT and it boots in native UEFI mode, so you can have CSM/Legacy Boot turned off.

 

Differences between Chameleon and Clover boot:

Chameleon: UEFI Motherboard > Motherboard is emulating traditional BIOS > Chameleon is emulating EFI and boots OSX

Clover: UEFI Motherboard > Clover loads and boots OSX

 

Clover patches the DSDT on the fly and you can create dsdt fix mask and DSDT patches will be added on the fly too.

 

 

Im not gonna write a new whol guide but im gonna explain shortly how to do it.

 

You need a 8GB USB.

 

Format it as GPT,  make 1 Partition Mac OS Extended (Journaled).

 

Extract OSX installer to the USB the same way as described in the first post, but dont format or change partitions. Just extract it to the HFS+ partition on the USB.

 

Download Clover from here: http://sourceforge.net/projects/cloverefiboot/

 

Open Clover installer and click "Change Install Location" select your USB partition, most likely "Mac OS X Base System"

 

Click "Customize", Select "Install for UEFI motherboards", "Install Clover in the ESP",  "Themes"  and Drivers64UEFI > "OsxAptioFixDrv-64".

 

Click "Install".

 

Go to Computer in finder and open the EFI partition that Clover mounted.

 

Drop your kexts in \EFI\CLOVER\kexts\10.8

 

Modify config.plist to your liking. Detailed explanation on config file can be found here: http://clover-wiki.zetam.org/Configuration

 

You can use my config.plist below, but you will have to change some stuff like BoardSerialNumber to add your own 17 digit string, usually you can use Chameleon Wizard to generate a serial and then apply a few random numbers at the end to make it 17 digits.

 

You will also have to set your own CustomUUID. You can generate one here: http://www.uuidgenerator.net/


Turn on GraphicsInjector if needed etc, I have mine turned off because I have UEFI bios on GTX 660 and then enabler/injector needs to be off.

 

To calculate DSDT fix mask, download: http://www.projectosx.com/forum/index.php?showtopic=2562&view=findpost&p=19999

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ACPI</key>
    <dict>
        <key>DropMCFG</key>
        <true/>
        <key>DsdtName</key>
        <string>NO.aml</string>
        <key>FixDsdtMask</key>
        <string>0x8010</string>
        <key>GenerateIvyStates</key>
        <true/>
    </dict>
    <key>CPU</key>
    <dict>
        <key>BusSpeedkHz</key>
        <string>99790</string>
    </dict>
    <key>GUI</key>
    <dict>
        <key>DefaultBootVolume</key>
        <string>Mac OS X Base System</string>
        <key>Theme</key>
        <string>Orange</string>
        <key>Timeout</key>
        <integer>5</integer>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>GraphicsInjector</key>
        <false/>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AsusAICPUPM</key>
        <true/>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>External icons patch</string>
                <key>Find</key>
                <data>
                RXh0ZXJuYWw=
                </data>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Replace</key>
                <data>
                SW50ZXJuYWw=
                </data>
            </dict>
        </array>
    </dict>
    <key>PCI</key>
    <dict>
        <key>InjectClockID</key>
        <true/>
        <key>USBInjection</key>
        <true/>
    </dict>
    <key>RtVariables</key>
    <dict>
        <key>LogEveryBoot</key>
        <string>No</string>
        <key>LogLineCount</key>
        <integer>3000</integer>
        <key>MountEFI</key>
        <false/>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>BoardSerialNumber</key>
        <string>putyourownhere</string>
        <key>ProductName</key>
        <string>Macmini6,2</string>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>CustomUUID</key>
        <string>putyourwnhere</string>
        <key>InjectKexts</key>
        <true/>
        <key>XMPDetection</key>
        <true/>
        <key>boot-args</key>
        <string>-v</string>
        <key>prev-lang:kbd</key>
        <string>en:0</string>
    </dict>
</dict>
</plist>

Thats it. You should be ready to go.

 

Some issues that I noticed:

 

When installing OSX, name the OSX HDD  "System" or something because when i named it OSX86 Clover did not list OSX in the boot menu.

 

Shutdown does not work, makes PC to reboot.

 

I have not tested everything but if I find more bugs I will report here.

Share this post


Link to post
Share on other sites

Hello! I have now tried using clover to boot. I used this guide: http://cloverboot.weebly.com/

But nothing happens when I try to boot from the USB-stick. It just continues to the next bootable device. How did you set your BIOS up to get it to boot? Which version of the BIOS are you using? I have tried several times with different Clover and Chameleon installers, but Clover just doesnt want to work. Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×