Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

what kind of behaviour should I expect from sleepenabler.kext?

4 posts in this topic

Recommended Posts

Hi all,


Managed to upgrade without too much trouble on my rig... but had to add in netkas's iopcifamily.kext to /Extra/Extensions/ on this occasion or I was getting freeze-ups 90% of the time at boot when the loader reaches [ pci configuration begin]. As I installed as an upgrade though I ran into heaps of permissions issues with every partition on my system...urrrgh!


Updated Logitech Mouse software as I am playong Deus EX HUman Revolution and Splinter Cell Conviction as well as my own wineskinned version of Myst IV Revelation (can't get native to run on non-Power PC enabled systems but wineskin works great =) )....however... Logitechs update seemingly added no support for games... can mouse over menus etc but cannot click on them. In game the mouse simply is not there at all. Loaded up my Microsoft notebook mouse and intellipoint 8.1 and games work fine!!! Ouch Logitech!


So to my question....


I have been trying since ho.6.3 to get sleep functionality on my hack with absolutely no success at all. Even had member help here trying to patch the dsdt with further optimisations which did not get the problem solved and ultimately led to a state where I couldn't boot anymore... had to go to a lot of hassle to rescue the system.. and left things the way they were as far as the DSDT goes. Have tried a number of sleep enabler.kexts since from different sources none of them have ever worked and I would have to reboot by the reset or bower button every time.


I just found one that actually seems to half work.... if I click sleep it puts the monitors to sleep but I can at least wake from this now by moving the mouse ....but..... is that it??? shouldn't the hard drive be sleeping also???? or maybe its just taking a while to go into sleep mode,,, What should I expect here?


As it stands it's pretty easy to sleep the monitors... have been doing that since SL using corners in expose...


Hope someone can advise.


PS . would also appreciate hearing from someone with a similar Graphics Card to my own in what I need to do to patch the DSDT to get the machine booting without nvenabler.kext I seem to always get messages relating to that particular kext when booting in verbose mode and occasionaly the voodoo... Still no luck getting DIgital to work with the Audigy 2 so have to work with the realtech and only get 2 channels with the kexts out there, still better than nothing with hear.app =(


mobo: Intel DP43TF

Processor: Intel Q8200 2.33Ghz

Graphics: NVidia GT240 DDR2 1Gb

Audio: On Board Realtec 5:1 (working 2 channels with Voodoo)

Ram 2 x 2Gb DDR2 888mhz Kingston

Rats: Logitech Marble Mouse and Microsopp notebook explorer 3000

OS X 10.6.8, 10.7.4, 10.8 and Winders 7 (the last resort) as well as Ubuntu 11 and Win XPSP3 in VM

Wacom: Intuos 4

Share this post

Link to post
Share on other sites

Hi there- well, instead of a complete shut down and reboot, all the time you get back to the PC, you put the thing to bed and let it sleep. The hardware won't use any power then. Restart back into where you were before, will the windows and programs open the same way. Nowadays, rebooting has an option where all programs open at that time will re-open as well on boot time, but I personally find it more convinient and time saving to let the thing wake up and keep on working. I am rebooting the machine only when software demands same, after new installation. But with a Mac that seldomly happens. For me over here in Europe saving energy means a lot (cost). YOu can try this here --> put the kext into S/L/E and repair permissions, then reboot and see what happens. May need a nullcpupower... kext http://code.google.com/p/xnu-sleep-enabler/



Share this post

Link to post
Share on other sites

Hi Manfred... Thanks for the really quick reply. Just took a shower after posting and there it was... Thought the same thing while taking a shower,,, nullpcpowermanagement... will give it a shot but have never used it before now... no reason to I guess,,,


Basically what I get now (and this is an improvement on nada...... is that the two monitors shut off... The fans were still running and the HDD LED was still blinking away 15 minutes later. This is after setting the energy saving settings to a minute to try and force a natural 'auto-sleep',,,, For my money this is not a sleep state as far as the HDD goes.... will try the null and report the update!

Share this post

Link to post
Share on other sites

Alas - all seems lost and doomed to failure yet again!


Reboot without nullcpu - and I get a kp on AppleCPUpowermanagement EVERY TIME

Install nullcpupowermanagement and once again I cannot wake with the mouse

and am back to hard booting =( Grrrr!


Seems to work - more or less in safe mode with the two (Sleepenabler and NullCPU) though I didn't really wait long enough to find out to my satisfaction as its no good to me in safe mode - but I cannot boot with this combo without further KP....




Managed to get it up and running with both SleepEnabler.kext and nullcpupowermanagement. I had to replace the iopcifamily.kext to S/L/E (seems that netkas's iopcifamily.kext is a patch) OS will not boot without it. With it only, and no patch it maybe boots once in 10 tries (and that without the sleep fix). Not pretty booting with both iopcifamily kexts in verbose mode....but gets the job done! (patch in E/E and original in S/L/E.


Put the rig to sleep when I went to bed 8 hours ago... sometime during the night I had to use the bathroom (some 2 hours or more after retiring and the fans were still blazing) I awoke to find it much quieter. HDD not flashing and only the power units fan humming away - maybe it finally did sleep but someow the fact the fans were still blazing away to me sounds as if the HDD was still working away... still, it may be progress.


Seems SleepEnabler is definitely dependent on a powermanagement kext (applecpu) but I am not so sure nullcpu is the the fix for it unless there is an updated version for 10.8 someplace. I used one from ###### 4.6.1 although I do not use the TonyMac Hack solution as I don't have either a gigabyte or Asus board ... and they seemingly won't even discuss hacks if you don't have one or the other! :( Still can be a useful reource for some things. ###### for Mountain Lion though only supports installation from a MAS download to your applications folder.... Has tony mac abandoned the USB method? Vital imo for maintaining a multiboot hack, particularly if you mess up the boot record.


Much prefer the USB/Chimera or Chameleon method and have had no trouble updating using kexts i used on 10.6.3. Have only had to change about 2 I think since, up until yesterday when I added the netkas patch

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.