Jump to content

[SOLVED]10.8 on an Asus p6t/RAID 0/gtx 260? kp - acpi - need help


3 posts in this topic

Recommended Posts

hey guys, i've got an asus p6t trying to install mountain lion on 2 128G ssd's in RAID 0. i've got an (in technology terms) old nvidia gtx 260 graphics card. i've used the installer shown here : http://www.insanelymac.com/forum/index.php?showtopic=277015


i can install ML to the RAID setup. when i try booting i get:


"Unable to find driver for this platform: \"ACPI\".....IOPlatformExport.cpp:1546"


i've gotten ML to boot into the setup page on a single ssd, but in raid i keep getting this KP.


i've tried everything i can think of. i've replaced the AppleACPIPlatform.kext from Snow Leopard and Lion. I've put the chameleon bootloader files in both diskxs3's. i've deleted all the graphics kexts from ML. i've repaired all permissions. i've formatted, reinstalled about a dozen times already. i've made usb installer drives probably about 20 times now. i've used myHack bootinstallers, i've used the mountain lionize script. i think i'm at the end of my rope.


i'd prob give up and just get a new motherboard and chip, if it weren't for the fact that i can boot into ML on a single drive. there's got to be a way to do raid 0......


Solved: I just used tonymac's USB creator. Plus I had to add the rootuuid to boot loader


Link to comment
Share on other sites

  • 2 weeks later...

Solved: I just used ######## USB creator. Plus I had to add the rootuuid to boot loader


I am running into this same issue. Can you elaborate on what you mean?


I used ###### to create the installer USB, and edited the AppleAHCIPort.kext to have it detect the Intel ICH10 Raid configuration on installation, but am having issues getting the damn thing to boot... same ACPI error.


I installed the latest chameleon2.1 svn package manually to both OS Boot partitions, and tried adding the UUID for the Raid partition to the chameleon.boot.plist in /Extra on each of these, but nothing seems to help. I also had to copy the mach_kernel to the two boot partitions or I was getting a "can't find mach_kernel" error. (which i didn't have to do with Lion).


I'm running out of ideas. Had no issues getting this working under Lion, but Mountain Lion is being a pain. Maybe just let me know the exact steps you took to achieve this if you can, and I'll perform them on my machine to see if that changes anything...


Thanks in advance.


UPDATE: Nevermind, resolved the issue by following the guide found at: ###########l


I think my issue was being caused by using the UUID of the Raid Parition, and NOT the RAID ID. Or it could be due to the fact that I was trying to install Mountain Lion directly to the raid partition from the setup, but I think it was due to using the fact that I wasn't specifying the correct RAID ID, and I was using the Kernel flag of "boot-uuid=[paste RAID identifier]" versus the one specified in that link, "rd=uuid boot-uuid=[paste RAID identifier]"


Either way, managed to finally get it working properly :)


UPDATE #2: Seems that if I try to disable kernel cache (by using the -f flag on boot) then I receive a kernel panic, looking like the system cannot find the /S/L/E folder on the RAID partition, which is odd, since it boots fine when not using this. Need to dig deeper and find out why this is occurring. Just for those who care, I am currently running the latest version of Chameleon 2.1svn rev2043. Will post back if I have an update or solution to this.

Link to comment
Share on other sites


  • Create New...