Jump to content

DWA-556 (Atheros AR9380) Mountain Lion -- No networks detected

Chris B!

11 posts in this topic

Recommended Posts

Hey guys, I recently picked up a DWA-556 Dual Band because I heard it had great compatibility. It detects just fine as native AirPort on my Mountain Lion installation but it doesn't seem to pick up any networks. I assume that because it's detected, I don't need to modify any kexts. So I'm using vanilla Mountain Lion IONetworkingFamily.kext and IO80211Family.kext (does that sound right?).


Here's the system profiler dump:

 Software Versions:
 CoreWLAN: 3.0 (300.9)
 CoreWLANKit: 2.0 (200.10)
 Menu Extra: 8.0 (800.7)
 configd plug-in: 8.0 (800.15)
 System Information: 8.0 (800.1)
 IO80211 Family: 5.0 (500.15)
 WiFi Diagnostics: 1.1 (110.26)
 AirPort Utility: 6.1 (610.31)
 Card Type: AirPort Extreme  (0x168C, 0x3A7E)
 Firmware Version: Atheros 9380:
 MAC Address: ...
 Locale: Unknown
 Country Code:
 Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
 Wake On Wireless: Supported
 AirDrop: Supported
 Status: Not Associated



Techniques I've tried so far:


1. Set AirPort router channels to 11 and 36 (5GHz)

2. Tape pin 20

3. AtherosFix.kext

4. Custom DSDT (change device label to ARPT, add _DSM method)

5. LegacyAtheros (see http://www.insanelym...dpost&p=1823049 )

6. IOProbeScore 600 -> 500 in AirPortAtheros40.kext

7. Remove OSBundleRequired / Network-Root



Kernel logs show:


AirPort: Link Down on en1. Reason 1 (Unspecified).
en1::IO80211Interface::postMessage bssid changed
AtherosNewma40P2PInterface::init name <p2p0> role 1 this 0xffffff8020c75000
AtherosNewma40P2PInterface::init() <p2p> role 1
6.588295: performCountryCodeOperation: Not connected, scan in progress[0]
6.594110: setWOW_PARAMETERS:wowevents = 2(1)
6.599861: ATHR: unknown locale: 3a
6.630221: ATHR: unknown locale: 3a
32.162745: ATHR: unknown locale: 3a
36.743831: ATHR: unknown locale: 3a
40.319916: Tx IQ Cal failed(4171)


I've pretty much run out of ideas at this point--any suggestions?

Link to comment
Share on other sites



To solve this problem, Open the info.plist file which is located in the IO80211Family.kext > AirportAtheros40.kext > Contents

and delete the following 2 lines




try older 10.6.8 or 10.7.2 kexts for network

did u do dsdt irq fix ?

have u tried different slot ?


buy a different card.. the adapter from New Mini PCI-E to PCI-E Wireless Adapter + 3 antenna WiFi



and a reall apple AR5BXB112



is your smbios.plist properly made ? model used ?

Link to comment
Share on other sites

  • 5 weeks later...
  • 3 weeks later...

Hay Chris B,

This may sound obvious, but is there a wireless switch? I saw the same behaviour with the AR9285 card my Dell Vostro 3350 running 10.7.4. The card was detected okay, and would look like it's scanning for networks but the list would always come up empty. Oddly the wifi enabled light on the laptop doesn't always stay in sync with wifi actually being enabled. So after a few days of frustration and many different 802.11 kexts I found the solution was just to press Fn+F2 and wait a few seconds. I really kicked myself when I found this and though may I should go a work with animals or take up gardening rather than continue my interest in computers. I now have WiFi and BlueTooth working.(Although I haven't tested them thoroughly yet.)

I'd be interested hearing if you find a solution to getting the DWA-556 working, I've recently bought a AR5BHB112 to use in a HP 8760w, and it seems to have the same problem... It's the same chip I think..

Link to comment
Share on other sites


That works? Or is it a suggestion?


When you say irqs you meet the _PRT Method on the device or something else?




hpet and ipic and rtc and so.

suggestion as im not sure what else is issue with your install.

Link to comment
Share on other sites


  • Create New...