Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Thinkpad T420 Snow Leopard KP with -x

4 posts in this topic

Recommended Posts

Hi guys! So complete NOOB here. But hoping to change that with this OSX installation. I have a Lenovo Thinkpad T420 4177 with Intel HD 3000 and an i5 processor. (2520m). I have 4 GB of factory installed RAM and a 320 GB hard drive. I was hoping you guys could help me out. I have a retail copy of the Snow Leopard DVD. So what I did was burned iB00t and then used it to boot the retail DVD. It took like two full minutes but then I saw this: thunderbolt-update-kernel-panic.jpg

I tried going into verbose mode but same thing. I changed the mode to ACHI in BIOS and everything. I don't know whats going on. I also tried all the other flags like GraphicsEnabler=No and PCIRootUID=1 but to no avail. Can anyone help me out? Thanks! I think it might be the problem but I actually have all my other partitions still existing during this installation. I have 3 boot options that show up when I put in the ib00t cd. Windows 7, Lenovo Backup, and System Drive. Should I do some formatting or something? Sorry I'm so clueless. Hope someone could help:)


EDIT: Do you guys think this is the problem? I'm using this DVD


Share this post

Link to post
Share on other sites

you cannot use that DVD, it will only work as a restore DVD with the exact mac model it came with. Not to mention it's also 4 years old and your using a newer CPU so no support for it on that version even if it was a full retail installer.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kami11o
      I've got W520 with running High Sierra on it with configuration based on the great guide by @tluck (http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only). I works great with integrated video card, the only thing that I'm unable to get working is Nvidia card (Nvidia Quadro 1000m). 
      By far I tired the following configuration:
      SMBIOS set to MBP 10.1 / 9.1 / 8.1 Nvidia Web Driver 378. Nvidia enabled in the Clover Video card set to discrete in BIOS   
      As a result, after boot, I've got flickering screen with disappearing windows and some artifacts, unfortunately not usable at all.
      Does anyone has managed to get this discrete card working on this notebook?
    • By iHack13
      Hi guys, I have written this up on tomato's forums, so I thought I'd share it here too. Would be a waste if it would get lost there:
        I still own an old T60 Thinkpad. It has a 15" 4:3 fantastic IPS-Screen at a resolution of 1400x1050. Now some of the newer Generations probably won't understand but in fact, this screen ratio is very precious for a lot of productive tasks and nowadays you can't find these anymore in modern laptops, since all manufacturers go 16:9 mainstream, for multimedia consumption. Which sucks... Apple is at least making a compromise and still goes for 16:10 , which is the best you can get. And people already appreciate that. So.. Whatever, lets talk about the Topic.   As you might know this ThinkPad is internally quite outdated. It has a Core 2 Duo with a GMA950 !! I remember getting kexts for GMA950 on my Dell Pentium D Desktop PC (Dual Core Pentium 4 basically) for OSX 10.4 Tiger That was the time when Macbooks were made from Plastic instead of unibody aluminum. Remember those white Macbooks? Yeah, those used Core 2 Duo with GMA950.   Around 2006 that must have been. Infact my Thinkpad has a discrete ATi Mobility X1400, which rather makes things even more complicated.. So.. This whole old stuff doesn't really mean anything, because someone in China who goes by the name of HOPE and has really some love for old Thinkpads, and engineering know-how and connections to manufacturing sites, came along and decided to build a new custom Motherboard calling it the T70.   You can go to 51nb.com and check it out (chinese site). Maybe I will link some threads with pictures later, showing the install process and mods if you cant find it.   Just as a little overview, I tried to get some information off the site (with Google Translate etc). The Specs of the T70 are:   1. adapter models 1) 14 inch 4: 3 positive screen T60 (p), T61 (p) 2) 15 inch 4: 80 GHz) ; 2) i7-6700HQ (4-core 8 threads), i5-6300HQ (4-core 4 threads), i5-7300HQ (4-core 4-thread), i7-7700HQ (4-core 8 threads), i7 -7820HQ (4 core 8 thread) 3) trial production version will confirm the use of the seventh generation: i7-7700HQ 4) production version of the first batch of the seventh generation: i7-7700HQ 5) production version of the second batch of the seventh Generation: i7-7700HQ ES, i5-7300HQ ES, i7-7820HQ ES 6) Production version of the third batch using the seventh generation: i7-7820HQ ES   3. Chipset 1) Engineering board using HM170, you can use the P50 / P70 Bridge chip CM236, reference comparison: HM170 vs. CM236 2) HM175 support 1 NVME M.2 + 2 SATA 3) CM236 support 2 NVME M.2 + 2 SATA, test board and production version of the first, Two, three batches of the use of CM236 chipset 4) built-in TPM encryption chip   4. Cooling & fan & water 1) Early shipments provide motherboards based on the new T500 fan transformation, will be shipped with the motherboard, without self. 2) post-shipment board provided by the dream fly custom water-cooled fan and water-cooled suit (to be paid separately): mass production of the third batch of T70 free upgrade water cooling fan 3) silicone grease to be self   5. memory 1) dual DDR4 memory, The maximum support to 64G (32G * 2, the market is not a single 32G memory, the current maximum support 16G * 2) 2) theoretically support the type of memory: DDR4-1333, DDR4-1600, DDR4-1866, DDR4-2133,   Wireless card 1) using Mini-PCI wireless card, full height, located in the original T60 WWAN card slot location. Half-high card to be self-fixed to full high fixed, 15-inch T60 right antenna to be appropriate to extend their own 2) and X62 the same, not compatible with any original TPU with the FRU card 3) current test compatible NIC: AR5B22, Intel7260ac, Intel6300, BCM94352 10 ( 1) support key combination: Fn + F3 (off screen), F4 (sleep), Home / End (brightness adjustment), PgUp (night light)   11. graphics card 1) set significantly: According to CPU model, 7700HQ is the Intel® HD Graphics 630 2) alone: difficulty is too large, do not support, do not consider   I will try to order things. Since Google Translate messed up the formatting and some other stuff. But the most important stuff should be there.   Also here is a link to the BIOS collection. The BIOS is mentioned to be AMI Award 7 Bios. It should be UEFI as it can be seen at the bottom of this post https://forum.51nb.com/forum.php?mod=viewthread&tid=1740243&highlight=   Also here is a collection of the BIOSes . It gets constantly developed and I think it is nice to have someone that can listen to your input. Call me crazy but it might even happen that with the correct feedback the BIOS could be so good that you would ent up with a perfect native DSDT for OSX.   BIOS: https://forum.51nb.com/forum.php?mod=viewthread&tid=1739986&extra=page=1   The price is set to $580 USD for the latest batch from July, last month I believe. specifications are as follows (Google Trans): i7-7820HQ Processor (ES version, the same specifications and the official version, 4 core 8 threads, 32K +32 K + 256K +8 MB) CM236 chipset, support dual M.2 +2.   I think earlier batches like leftovers from second batch with 7300HQ should be a bit cheaper. $460 USD according to my research.   So this is as far as my research goes. I hope you like my little writeup on this topic. This is a really nice project in my opinion and I think it would make a beautiful hackintosh for people who are willing to mod and get the best classic experience with a beautiful display in terms of aspect ratio and also a very nice keyboard with a horrible trackpad , the size of a stamp and the trackpoint .   Let me know what you think about it. I am especially curious about RehabMans opinion.   Also there are other ThinkPads that are modded like this. So if this isn't your favorite one, or the one that you don't own, maybe it is among these if you are lucky:   X200 / X200s / X201 / X201i / X201s -> X210 X61 / X60 / X61s / X60s -> X62. It was even reviewed by notebookcheck T4x series -> T50
    • By Newbie Mac
      Ciao a tutti,
      sono felicemente riuscito a installare Lion sul mio Optiplex 330.
      Funziona tutto tranne la scheda audio interna ma non importa perché vorrei installare una USB esterna: una Yamaha AG03.
      Dalle istruzioni questa dovrebbe essere installata su Lion senza driver e riconosciuta subito (http://www.yamahaproaudio.com/global/en/products/mixers/ag/manual/mac/index_en.jsp).
      Su un altro hackintosh sempre con Lion viene riconoscita perfettamente.
      Il sistema la vede, nel System Report, correttamente collegata all'USB ma da Audio Midi Setup mi dice "NO DEVICES FOUND".
      Temo che mi manchi qualche parte software per far riconoscere la scheda esterna.
      Ho installato i VoodooHDA ma mi hanno mandato in crash il sistema quindi li ho rimossi.
      Avete consigli?
      Grazie mille
      Retroman Newbie
    • By caspdin
      Hello everyone,
      For the past few days, I have been trying to get the audio working on my ThinkPad T510 with macOS Sierra. I have read all of the guides on the forum, I can link them if anyone needs them, and I still have no audio. As far as I know, the T510 uses the Conexant CX20585. For most people, this seems to work with kexts they have posted. Below are the methods I tried:
      - Using .kext s people have provided under Guides and Downloads on the InsanelyMac forum.       Not Working
      - Modifying AppleHDA through Clover.                                                                                                Not Working
      - Try other verison of Mac OS X (Sierra, El Capitan, Yosemite, Mavericks).                                       Not Working
      This has led me to believe that I am ether completely missing a step in a guide, or I am doing something wrong. Or, that my specific ThinkPad T510 uses a different audio codec.
      Any help I can get, will be appreciated. I hope someone here could help me.
      Thanks In Advance.