Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
lazybon3

Patched AppleHDA / Getting Active Microphone to work on Mic In

5 posts in this topic

Recommended Posts

Hello,

 

I am using a Gigabyte Gigabyte GA-Z77X-UD3H-WB WiFi and i already got my VIA VT2020 working with AppleHDA,

but there are still two Problems left.

 

One of those Problems (and the problem this post is focused on) is that i got Pink Mic In (Front or Rear) only working as Line In.

I have read quite a few posts here, and on some other forums, where this problem was discussed and for some ALCxxx-Chips even solved.

 

No Headset Microphone will work on the Mic In Port(s) but then i connect the Headphones to Mic In i get some signal. Same goes for any other external source.

 

So what i am asking for is a hint, on where to start.

 

Here is a small list of steps that i have already tried without success:

 

- Different Codec Verbs in AppleHDAHardwareConfigDriver.kext

- Different changes in Platforms.xml (for my Layout)

- Different changes in Layout12.xml

- Adding MuteGPIO (i don't know if this is even related to this Problem)

 

Is it even possible to get Mic In to work without any DSP Stuff in the xml files?

 

But, i still got no idea on where to start to get "power" for the Mic In Port working.

 

In the attached file you will find my layout12.xml, Platforms.xml, and all of my current codec dumps.

I would be thankful for any hint that would help me to solve this Problem.

 

 

Note:

 

The Version of AppleHDA Patch i am currently using is based on this:

VIA VT2021 and AppleHDA (as to be alternative)

 

I just modified the Layout and Platforms for my purpose and edited the codec verbs.

All credit goes to VCH888.

VT2021.zip

Share this post


Link to post
Share on other sites

Yeah. That's sweet,

 

and i already got a Speedlink Vigo, that is only about 10$, and this would solve the Problem too,

 

...but...

 

i am not asking for a quick & cheap solution for this problem,

i want to understand how i could solve it myself.

 

But Thanks for the advice, i knew that there were faster solutions, but i really want to learn a little more about the HDA Codec,

and maybe solve this problem for the internal HDA Device.

 

:)

Share this post


Link to post
Share on other sites

Thanks man,

 

but i already know this, and it is basicly the base and source of Information for the patched AppleHDA i am currently using.

Also i got VoodooHDA working with this guide (and some other Guides).

 

I guess all the information i need will be posted in the

 

To be continued...-part of that Guide.

 

But Thanks anyway :)

 

I just need very detailed information just on the Mic In issue, i already know the basics.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×