Jump to content
InsanelyMac Forum
Sign in to follow this  

Desktop animation problem

Recommended Posts

I've built a number of hackintoshes over the years, I'm currently typing from the 10.7.2 I been using for several months.


(GA-G41m, E8400 @3.25, 4G, FX 580, SSD, blah blah. Geekbench/Nova/all scoring like predicted, everyone's happy.)


Familiar with the 775 Gigabyte family of mobos and how to get them working etc etc.


Since upgrading my Windows gaming computer, I was left with a bunch of kit that I figured would be a great hack:



QX9650 & 3.5 (mobo doesn't like voltages much)

8G DDR3 @ 1333

Pal1t GTX 285 1024m (from my media computer)


... and a bunch of drives just to test out installs.


For the past week I been trying many methods of installing Lion up to 10.7.4, I have on USB pen to install - and this all goes swimmingly.


I get everything setup fine. Stick the 285's id in 50hal, Cuda and all that, Geekbench around 8500, Novabench around 1000, XBench around 180, GLView tests pass and look good, and we're all cool except for one thing. (This I've tried as 5,1 3,1 and iMacs) Sound is ok, eth is ok etc etc.


Randomly, it seems, when an app is opened (could be anything), on the desktop it won't open properly and you can see the ghost image of the animation to open it. Reseting Finder can clear this up sometimes. Forcing the app closed (as you can't see the close button properly) and trying again can work sometimes.


Using Safari is hit and miss. Initial opening can go like the above, but response from the slider and clicking links is either delayed or un responsive.


If I open PlistEdit, I can guarantee using Open from the menu will result in a window that is a halfway animation of it fully open.


Now - the biggest thing that points this to animation of the desktop, is, when something is messed up, I can open Mission Control and the desktop looks as it should. Go back to the desktop and it's still messed up. Mentioning PlistEdit, the MC picture of the desktop will show a fully opened file selector waiting for me to pick a file. Go back to desktop and it's in a part animation.


Bizarre thing is that if I put my mouse over the part animation of an open window, I can partially interact with it. i.e. click on the minimal cancel button and it will cancel - but leave the window picture there. (goto MC Desktop picture and it's gone as it should be)


Additionally, animations of the opening of app's icons can leave a ghost image - removable by restarting finder. Still - not there on the MC pic of desktop.



Is this something simple that I'm over looking ? I figure it has to be 285 related.

Share this post

Link to post
Share on other sites

Trying same rig with 9800 to see if it's definitely the 285.


EDIT: Same thing happens with the 9800. Have to check something else.

Share this post

Link to post
Share on other sites

I wish I knew what the problem is - I've had the same issue constantly. I've been running 10.7 & 10.7.4 vanilla and I can't figure it out - it doesn't seem like many people are complaining about it but it's been a constant problem which now leaves me stuck at 10.6.8


also, FYI I have a gigabyte mobo GA-P43-ES3G and evga 560 ti graphics card. Running intel QX6850 quad core extreme processor

Share this post

Link to post
Share on other sites

I put the x9650 in an EP45-DS5, as I've used this mobo before, and the same thing happened.


So I then thought along the lines of Apple's expiry dates on installs/combos - but that's not even remotely the case.


I dragged another G41MT-D3V out and put another E8500 in it - and it works first time - no problems with install or updates.


The only common thing here is the QX9650.


As you'll know yourself, Snow Leopard or Leopard runs absolutely fine. I'm now thinking along the lines of the Lion install not liking the QX9650, it does call it a Xeon, but is it just in the name or is it making expectations on it. Weird thing to me is that others have boasted using it but haven't mentioned doing anything special during install/post install.


I'm about to try a Q9400, which I'm pretty sure will work 100%, and then swap in the QX9650 to see what happens.

Share this post

Link to post
Share on other sites

Q9400 seems to be fine. Detected as "Quad-Core Intel Xeon".


I'm going to recheck next with the QX9650 dropped in, cos I seem to remember it just saying "Xeon", which could mean it's assuming 2 cores or something and would explain some people posting about having to set cpu=1 or 2 to get it working properly. If it shows the same description, then I'm stuck.


EDIT: nah I was mistaken, it says "Quad-Core Intel Xenon" ... however, using cpu=2 gets it booting ok and working fine. I thought cpu=2 would make it use less cores - never mind. Seems we're good to go :)


EDIT2: wrong flag, should be cpus=2 - BUT - entering the wrong flag worked once. Entering 2 does of course use 2 cores. With 4 I briefly saw a "TSC blah blah 3" and 2 error and boots with problems thereafter.

Share this post

Link to post
Share on other sites

Hmmm. I'm in the process of installing 10.7 again right now and going to see if the boot flag helps. This seems to be one hard nut to crack as I don't see many other people reporting this problem

Share this post

Link to post
Share on other sites

the cpus flag doesn't seem to help me :-( and even if it did I can't say that's an attractive solution - this is so weird

Share this post

Link to post
Share on other sites

I have the same problem, narrowed it down to using the "cpus=2" flag as a solution, and then using only 2 cores of my QX9650 in my Hackintosh setup (Gigabyte EP45-UD3R, 2x2GB 1066 Ram, GTX570). "cpus=1" works, of course, but "cpus=3" does not (graphics gltiches)!


I've tried 10.8, 10.7, same graphics glitches as others describe here. I was able to define the problem ever more exactly: windows don't refresh their content properly: for example, open an Activity Monitor and see what the CPU cores are doing. Now open another windows AND IF THE CPU CORES stop refreshing in the Activity Monitor window. This is the easiest way to check if the glitch exists in a certain setup. Now move your mouse back to the Activity Monitor's windows, click anywhere within (does not have to be an active menu or function) and updating starts again, voilá! 2 seconds later it stops again...


Took a ton of time to figure this out. Went nearly mad in the process... :)


I'm using now iAtkos 10.8.2, with minimal changes. Actually it works perfectly out of the box, with "cpus=2" and "PCIRootUID=1", "NPCI=0x2000", "GraphicEnabler=1".


It even updates to 10.8.4 fine.


But I could not get all 4 cores running without the graphics corruption.




Ideas are welcome.


PS: Hwmonitor is up and running, CPU voltage does change, multiplier does go down to 6 from 9, although cores are a bit hot compared to Windows' temps.


PS#2: How can we get the GTX570 to go into 2D mode, and Low Power 2d mode (lower clocks)? It consumes a ton of power at full speed.

Share this post

Link to post
Share on other sites



"TSCsync cpus=1 issue permanent fix ML"




This handled the problem, all CPU cores are working, no graphical glitches, no lagging, no KPs anymore. 


I'm using iAtkos ML2, during OSX install, tick this: "TSCsync patch" to install. Now I understand why it was a built-in option... :)



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.