Jump to content

Retail 10.6.8 Sleep on Asus X71Vn (M71VN)

11 posts in this topic

Recommended Posts

Hey guys!


Here I have some problems with Sleep on my OS X on my Asus X710Vn Intel Core 2 Duo!

I already tried out to create a "dsdt.aml" on my Macintosh HD. I also installed the SleepEnabler.kext for 10.6.8 - but it does not work.

When I close my notebook, it´s okay that it is going to go into the sleep-mode; but the Sleepmode does not work.

The screen turns off and the computer is still working. (Fan, Power-LEDs...) After that I cannot do anything, so I have to take a "hard-turnoff" with holding the power-button.


I've posted this to other forums, but I didn't get help so I'll try it here. I hope you can help!


Thank you,


Link to comment
Share on other sites

  • 3 weeks later...

Hello there !


Not to hijack your topic, but your message is a true beacon of hope for me! ;-)


In deed, I have the same Laptop X71Vn, and have also problem with sleep, internal mic, Webcam and others...

I'm not using DSDT but just Myhack.


Can you share your experience about kext installed (which kexts and where), and what's your method for installing Mac os X (DSDT or other method) ?


Great thanks in advance.



Link to comment
Share on other sites

Although you may have some more configuration to do before sleep works, you can change the sleep mode in terminal which may help depending on what it is set to now. To see what sleep method it is currently using in terminal type:

pmset -g

you should get a result including a listing for hibernate mode, either 0, 3 or 25

zero is for desktop sleep and saves everything to ram and keeps the ram powered on while sleeping. 25 is hibernation mode used on older mac laptops, the ram contents are copied to the hard drive and the ram is powered down during sleep, wake will take longer as data needs to be written from the hard drive back to ram again, aka "deep sleep". the last mode is safe sleep and used on newer mac laptops, it copies everything to hard drive, but still keeps the ram powered on for fast wake and added security against data loss. This should be your best option. You will also be able to see what sleep behavior is currently set for closing the lid or waking when lid is opened, or if any process or system setting is currently preventing sleep mode. Each different setting is changeable but I don't want to write an essay or be responsible for anything that gets screwed up, so you can get more info from the man page by typing into terminal: man pmset

Link to comment
Share on other sites

Hi eep357,


I have the same laptop that UltimateStar, I already posted a message earlier (post 2).

Not using DSDT, I need more your help than that of buoo..

So, I understood very well your answer but I confess that it's little difficult for me to implement your recommendations related to the sleep mode.

To be clear, I've sleepenable.kext in S/E and here is what gives me the terminal command that you cite :

Active Profiles:
Battery Power  -1
AC Power  -1*
Currently in use:
hibernatemode 3
halfdim 1
womp  1
sleep  10
disksleep 10
hibernatefile /var/vm/sleepimage
ttyskeepawake 1
displaysleep 10

Since I have the same problem as UltimateStar, could you precise what should I change in the configurations of the sleep mode to make it work?

Do not worry about the damage that this could make ;) I generated a backup of all my data.

For your information, I am under SL 10.6.8 64-bits and all my kexts are also in 64 bits.

In my S/E I've also EvOreboot.kext, and in my org.chameleon.Boot.plist I added the "Kernel Flags" "pmVersion = 23". This still unsuccessful.


All suggestions and / or recommendations are welcome.

In advance thank you for your time,

Wonderful forum!!


Link to comment
Share on other sites

  • 1 month later...

Sometimes the sleepimage file can not be written to the hard disk for whatever reasons and everything just hangs.


If hibernate is set to anything other than 0, then the computer just hangs after it goes to sleep if the sleepimage file can't be written and then a restart is necessary.


A possible solution is to set the hibernate mode to 0 which is sleep that doesn't use the sleepimage file.


In terminal enter


sudo pmset hibernatemode 0


and enter your password to execute pmset.


The currently set hibernate mode can be viewed by entering in terminal

pmset -g

Link to comment
Share on other sites


  • Create New...