Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
ashrid

CPU Shutdown on AMD/VMWare Player 4.0.3

4 posts in this topic

Recommended Posts

Hi,

 

I'm trying to get Snow Leopard running as a VM under VMWare Player 4.0.3 on my AMD Phenom 9350 (NVidia chipset)

 

I've managed to install Snow_Leopard_10.6.1-10.6.2_SSE2_SSE3_Intel_AMD_by_Hazard but on the first boot after install the VM is shutdown with the following message

 

"A fault has occurred causing a virtual CPU to enter the shutdown state"

 

I've tried booting with -v but the last page is replaced by the error too quickly to see what is says and -x displays 1 line (again removed too quickly to read) before the same error occurrs

 

I've done some searches and added various things to the bottom of my vmx file none of which appear to have helped, some of the search results give me the impression that I need to use a CPUID mask but I also get the impression this is just for intel chips and not AMDs

 

I've attached my vmx and vmware.log files (theres probably alot of junk in the vmx files from my many install attempts)

 

Appreciate any assistance

Mac OS-X 10.6.vmx.txt

vmware.log.txt

Share this post


Link to post
Share on other sites

I have the same problem with Vmware Workstation 8, I get that same CPU error. I have an AMD FX8120. Someone please shine some light on what is causing this CPU fault error.

Share this post


Link to post
Share on other sites

You have to use a legacy kernel for AMD,you can't use the default vanilla kernel as it's not an Intel processor.

Share this post


Link to post
Share on other sites

You have to use a legacy kernel for AMD,you can't use the default vanilla kernel as it's not an Intel processor.

Does that mean that I have to use an install disc that already has an AMD kernel patch? If yes, which release includes AMD kernel?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×