Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[SOLVED]Cannot repair permissions in MLion!

3 posts in this topic

Recommended Posts

After install, it gives me a "classic" error "Installation failed" but I've but all the kext and everething works good.

Untill...I try to repair permissions!





I think all the problems are causet just by DP3, which is a total {censored}!



Seems to be OS X 10.8 DP3 corrupted install image! I succed insalling with another one!

Edited by Kynyo

Share this post

Link to post
Share on other sites

Yep, then the install failed. It may fail to install also the .pkg files in /Library/receipts or / System/Library/receipts which are .pkg files (named same as install .plks) which contail all permission infos about the files installed.

Without them you can never repair the permissions.

Not good.

At least for right system kext permissions you can set them by using:

sudo chown -R root:wheel /System/Library/Extensions

Share this post

Link to post
Share on other sites

I have this same problem with ML gold master; I have installed three times, each time I get an "installation failed" at the conclusion of the installer. Then, everything reboots and ML works fine until I try to repair permissions. Is there anything I can do at this point to fix this? By the way I have used the same ML gold master image to install on two MacBook Pros without any problems, I think my .dmg is fine. Thanks for any help!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By yusz
      Need help on bluetooth with OSX 10.9 DP3.
      I'm using Apple Bluetooth Module from Macbook Pro A1260 (BCM2046 Chipset). It was working great under Mountain Lion 10.8.4. It also work under OSX 10.9 DP1 and DP2. However, when I upgraded to DP3, the bluetooth module is no longer detected by the OS.
      I've checked and verified that Device ID and Manufacturer ID are available in Info.plist in the IOBluetoothFamily.kext and its related kext.
      I've also tried with various USB Bluetooth dongle that worked with 10.8.4 up to 10.9 DP2, however they did not work under 10.9 DP3.
      I've also tried to use the kext from OSX 10.8.4, but still no luck.
      Any advise to resolve the issue is very much appreciated.
      System : Gigabyte GA-Z77P-D3 (Ver 1.1), i7 3770, Gigabyte GTX 650 OC, 8MB RAM, 1TB Samsung HDD, 1TB WD HDD