Jump to content
InsanelyMac Forum
Sign in to follow this  
danill2008

Sapphire 6870 on Lion?

Recommended Posts

Hi,

 

I successfully installed Lion 10.7.2 on my Asus P8H67-V, with Sound and Network working so far (can't be bothered at the moment with Sleep and USB3, first want to get my graphics up and running)

 

For this build I used iAtkos L2 10.7.2, without selecting anything before installation.

 

Unfortunately after the install, when I tried to boot, it loaded (showed the Apple logo) and after a while totally went black and stayed that way (screen lost signal). Initially I though there was something wrong with the build, but then realized it could be my graphics card, which indeed was the case. So I removed the Sapphire, started up with success and installed all the drivers etc. When it was time to install my graphics card, I located a 6870 kext on osx86.net (well 4 kexts in one file actually - ATI6000Controller, ATIFramebuffer, ATISupport and ATY_Init). I installed via Kext Wizard and shutdown my mac, plugged in the Sapphire and started-up. Only problem is, black screen again.

 

I tried: "GraphicsEnabler=Yes" and "PCIRootUID=1", but still no joy.

 

I saw that all XFX 6870 are supported natively, but currently I have a Sapphire (can't imagine that the two is that much different). Does somebody perhaps have a solution for me or any advice?

 

I would appreciate if very much :wink2:

 

Kind Regards

Share this post


Link to post
Share on other sites
Advertisement

i have the same card and it works out of the box . i have just chameleon 1803. this is whats in my boot plist

 

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>Kernel Flags</key>

<string>Yes</string>

<key>Theme</key>

<string>default</string>

you could try changing the frame buffer at boot screen type in. AtiConfig=(then the frame buffer.) here are some to try

 

Pithecia, Bulrushes, Cattail, Hydrilla, Duckweed, Fanwort, Elodea, Kudzu,

Gibba, Lotus, Ipomoea, Muskgrass, Juncus and Osmunda.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By Newbie Mac
      Ciao a tutti,
      sono felicemente riuscito a installare Lion sul mio Optiplex 330.
      Funziona tutto tranne la scheda audio interna ma non importa perché vorrei installare una USB esterna: una Yamaha AG03.
      Dalle istruzioni questa dovrebbe essere installata su Lion senza driver e riconosciuta subito (http://www.yamahaproaudio.com/global/en/products/mixers/ag/manual/mac/index_en.jsp).
      Su un altro hackintosh sempre con Lion viene riconoscita perfettamente.
      Il sistema la vede, nel System Report, correttamente collegata all'USB ma da Audio Midi Setup mi dice "NO DEVICES FOUND".
      Temo che mi manchi qualche parte software per far riconoscere la scheda esterna.
      Ho installato i VoodooHDA ma mi hanno mandato in crash il sistema quindi li ho rimossi.
      Avete consigli?
      Grazie mille
       
      Retroman Newbie
       
    • By alainkalender
      Hello everyone,
       
      I'm new to this forum, I'm really searching for some help with my "project" and hope some of you can help me out with this one!
       
      It's all coming down to a not starting "Finder"
       
       
      The full story,
       
      I bought a Mac Pro 1.1 (2006) a few day's ago. All stock, dual Intel Xeon 3Ghz, 5GB Ram and the stock video card (256MB). (Lion freshley installed)
       
      I wanted to upgrade to OSX El Capitain, and after a lot of research and a lot... yes a lot of trouble in making it all work I finally got it. I've thrown in a Geforce GTX 760 2GB Jetstream... couldn't wait to get cables for powering it, so I frankensteind it all with a second PSU. Installed Lion on a Samsung 850 EVO, and then followd a tutorial on how to install el capitain using Piker's boot. 
       
      After 12 hours non stop messin around it worked, only after some time the mac froze and rebooted. I noticed that maby Google Chrome caused this to happen, and when using Safari it would work without any problem. I even can play 4K flawless.
      But still after some time it would crash, I monitored the CPU and Ram Usage, but there wasn't anything crazy happening at those things.
       
      .. didn't really got the time to instal other apps. Then I found out Finder wasn't responding. It kept on crashing. I tried a lot of things... deleting the plist files, resetting PRAM, VRAM, Savebooting, deleting cache, Disk repair (Disk Aid)... nothing worked.
       
      Is this maby a problem with the bootloader (Pike)?
       
      I hope someone can help me out!
       
      Thanks in advance,
      Greetings from Holland 
       
    • By spec3
      Ciao,
       
      Qualcuno potrebbe aiutarmi con questa scheda? non riesco a farla andare su Sierra. Con la scheda riesco ad entrare nel sistema operativo ma sfarfalla tutto e ho disponibile solo una risoluzione. Sto utilizzando Clover su una scheda madre  asrock h110m hdv
       
       
      grazie
    • By DenisGrusz
      Hi guys. I just try to get work my first eGPU, and unfortunetlly i have a little issue. 
      I use Sonet Echo III - D TB2 and Saphire Radeon RX480 Nitro 4g. I just install fresh system (sierra), have plug-in everything, but my system doesn't see the graphic card.
       
      In "This mac" ---> system report ---> PCI there is an information "An error occurred retrieving information about the PCI device." 
       
      I make change in the System ---> Extension ---> AMDRadeonX4100.kext and add to the strings correct ID and now it looks like: " <string> 0x67EF1002 0x67DF1002 0x67FO1002 </string> 
      I try other configuration with other order, but it still don't work.
       
      I really try to read a lot about this, but still can't find solution, 8 hours of research is to much for me so I decide to start new topic. 

      Does anyone have an idea what may go wrong ? Thanks for the replay !
    • By formatyourpartition
      I'm trying to install Mac OS X Lion onto a kinda old PC, the specs are:
      AMD Athlon X2 4450e NVIDIA GeForce 6150SE 3GB RAM I've successfully installed Snow Leopard on it, and then I tried OS X Lion which gives me "[ PCI configuration begin ]" and then it will give me "console 1024 x 768 @0xe0000000" if I add pci=off, I've tried Yosemite and Mavericks (and they give me the same results) but I'm trying to stay away from them as they probably don't support my graphics card, and weirdly, I've tried Mountain Lion which boots into the installer no problem but it doesn't show my hard drive, so i tried to install it onto a flash drive (which takes ages!) but then at the last moment it tells me that it was unsuccessful, so I try to boot into Mountain Lion and I get the same errors (except I haven't tried pci=off, but I really don't want to try again unless it's really needed.)
       
      Is there anything I can do or am I just stuck with Snow Leopard?



×