Jump to content

Slow hard disk


57 posts in this topic

Recommended Posts

hello all

I'm having slow hard drive reads. Suddenly, it stops for 10 seconds, keeping the hd activity led steady on.


When this happens i cant open any program , till i hear disk click click then system back normal ,,


my Hard disk is healthy , i checked SMART and is goood,,, performance is good in Ubuntu and Windows 7


i saw some fix for it but include edit the DSDT.AML but i dont have one and i tried to create one but looks hards to do and i have so much errors in it,

is there any other ways


My Mobo:


asus m3a76-cm

Link to comment
Share on other sites

thanks for fast replay ,


when the freeze comes, then i cant open the activity Monitor,


and when i let it open then i try open any programs that effects hard disk to freeze then also the information in Activity Monitor freeze so is really hard to trace it

Link to comment
Share on other sites

Hm...have you tried reinstalling?


Don't try to open anything while Activity Monitor is running. Select All Processes and see if there is anything using too much CPU/RAM.

Link to comment
Share on other sites

yes i did reinstall 2 times,, and i updated from 10.6.2 to 10.6.7 and 10.6.8 and all same problem freezing,,


freeze when open applications like final cut , adobe after effects, iweb, ,,,, also when try access other partition in hard disk


there is nothing using aLot RAM/CPU ,



my spece ;


mobo : asus m3a76-cm

AMD Athlon II x3 435

Ram 4 Gb DDR2

Disk seagate 500 Gb

Cart Ati hd 4850 1Gb

Link to comment
Share on other sites

i did research in google and i found some people had same in asus Mobo and they had to modified DSDT and delete some lines of IRQs in some devices ,,


i cant do that coz i dont have DSDT and i couldnt create one byself,, i got alot warning in it

Link to comment
Share on other sites

Did you extract it from OS X or Linux?


If you're having problems with OS X, I can give you instructions on DSDT extraction in Linux (Ubuntu).

Link to comment
Share on other sites

Okay, so now you need to get to the Terminal. If your graphics card doesn't have drivers (it's running in Classic mode) than go to the Applications menu in the top-right corner, choose Accessories > Terminal. If Unity is loaded, go to the Ubuntu icon at the top right and search for Terminal. Now type: the following commands:


cd ~/

sudo cat /sys/firmware/acpi/tables/DSDT > dsdt.aml


Bingo! You now have the DSDT in your home folder; now you can drag it onto a flash drive and upload it. :) If you want to be a dear, you can also decompile it by entering the following commands:


sudo apt-get install iasl

iasl -d ~/dsdt.aml


Then drag dsdt.dsl onto your flash drive. :)


You can edit it in either. It doesn't really matter. I would post this issue with your DSDT up in the DSDT forum and see if any DSDT gurus know what to do (I'm a noob to DSDT; I only know how to fix the RTClock, which is totally unrelated to your issue :rolleyes:).

  • Like 1
Link to comment
Share on other sites

I'm so sorry - I accidentally gave you the DSDT for my MacBook!!! Don't use it; I will patch the real DSDT.


I think the DSDT Patcher is malfunctioning...I'll do what I can.

Link to comment
Share on other sites

I wouldn't worry about warnings. I'll add the patches for the SATA. :)


However, I'll have to send you dsdt.dsl as for some unknown reason DSDT Patcher will only compile the DSDT for the machine you're operating on. I'll be back in a little. ;)


It seems that the DSDT Patcher fixed all the issues listed in the SATA fix post. I only added a group of lines in the TMR device. Compile it and see if it works. :)



Link to comment
Share on other sites

thank u my friend


i did it in extra and i have com.apple.boot.plist and i did flag




in boot i got some Panic and alot numbers and i only can understand this :P :

Kernel extensions in backtrace ( with dependencies)







and then restart again couple times then works with no keyboard


and now i use flag DSDT=none




Update :


now boot good when i used GraphicsEnabler=Yes


i'll test if hard disk gonna freeze or not


P,S: how i know if DSDT is loaded ??

Link to comment
Share on other sites

Don't know how to tell if DSDT is loaded; but if it's dsdt.aml inside the Extra folder, and you didn't type DSDT=none, it should be loaded.


If you still get panics, I may need to remove those lines I added in your DSDT.

Link to comment
Share on other sites


  • Create New...