Jump to content

Seeing only left part of screen, tinted in red - Lion HD 3000 *New issue, new thread!*

Jimbolaia Jones

14 posts in this topic

Recommended Posts

Specs for my PC:

Intel Core i7 2.2GHz


Intel HD Graphics 3000

ATI Radeon HD 4750M

All packed in a Samsung 700Z5A Chronos


Before I had issues with AppleIntelSNBGraphicsFB.kext, which did not load at all.


When I updated my SMBIOS to MacBookPro 8,1 (or 8,3, same issue), I get the current error.


I see half the screen, tinted in red, sometimes blue or green, but most often red.



Pic attached, shows the error. People at tony tried to help, but I got banned, I forgot they aren't to happy about prehacked versions of OS X, which I unfortunately used.


EDIT: Did I mention I do have full resolution and QE/CI (afaik, no lag in Chess). This means the drivers are working, but I guess the framebuffer is doing this, as it controls the resolution and color?

Also, it works perfectly on an external monitor. It is only on the laptop display I get the half screen tint error.

Edited by Jimbolaia Jones
Link to comment
Share on other sites

Tried Enabler on and off

Smbios for Mac Pro, Macbook Pro 8.1, 8.2, 8.3, Mac Mini 5.1

Entering my DevID in other places in the kext (where an ID is present, i.e in this file, there is one id, one id, then 5 ids, mine is in the latter)


Now I screwed up, the mac mini smbios screwed my system, can't boot.


Anyone know how to mount my USB pen in -s? :P

Link to comment
Share on other sites

Can't mount FAT from disc apparently. I have to write the file by myself. Doing it from the install disc, impossible, the controls are stupid! Have to do it from vim in -s. Will take 20min at least... Will give it a try.


Up and running again. Getting panics on a PCI kext, will note the name if I see it again. Only in boot, never after.


I deleted the HDGraphics kext, having only the GMA and SNB kexts, still had QE/CI. This means there is something else giving me QE/CI, maybe my ATI card, but as the SNB is used as framebuffer, I doubt it? However, I dont know, as the ATI cards I/O goes thru the Intel card.


Quick addon: Only running the AppleIntelSNBGraphicsFB.kext of the Intel kexts. Guess what, still got full reso and QE/CI. That is just WACKED!


Deleted the ATI and GeForce drivers too, still got full res and QE/CI.


What the hell is causing that? The Framebuffer doesn't give QE/CI for sure!


Sorry, just bull{censored}ting you, got NO QE/CI!


I only got detection and full resi, still half screen tint bug... Broken Framebuffer, problems with display, or problems with switchable graphics?

Link to comment
Share on other sites

I was thinking this might be a gfx power issue... Have you tried to edit AppleGraphicsPowerManagement.kext?

And maybe try to insert "AAPL00,InverterFrequency" and "AAPL00,DualLink", if it is present on a real mac with this graphics card?




And remember to restart with -f -v options :)

Link to comment
Share on other sites

I seem to have a simmilar issue with the Intel HD3000 in my Samsung QX311 (specs in my signature). But instead of a partial red tint, I have a full screen white tint.


Connecting an external monitor to the VGA port doesn't seem to do anything for me, as the laptop doesn't recognize it and the monitor indicates "no signal". I have to say this issue started when I defined the system as a MacBook Pro 8,1. Before that, I had the standard resolution but no white tint. Now I have the full resolution I need (1336x768) but this annoying white tint.

Link to comment
Share on other sites


  • Create New...