Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ants

[GUIDE] Samsung RF511 S02 sandybridge with LION "Updated"

17 posts in this topic

Recommended Posts

THIS IS A SMALL (PERFECTIBLE ) GUIDE FOR INSTALLING IATKOS L1/L2/L3 ON A SAMSUNG RF511 S02 SANDYBRIDGE LAPTOP

 

After many attempts with ######'s method and SL I decided to switch back to my old method with iAtkos (I've a fully working Hackbook core 2 duo with iAtkos v7, and a intel d945gclf2d MiniHack, atom dual core, with the same v7).

 

What you need:

  • iAtkos L1
  • ###### 4.0.2
  • CARBoncopy CLONER
  • Lion_install_volume
  • Sleepenabler
  • Voodoobattery
  • Elan touchpad Lion v1.5.3 from: http://forum.osxlati...driver-mac-osx/
  • Kext helper or Kext Utility
  • External disc USB for backup
  • Usb mouse
  • Cd or dvd (MAC formatted) with all the stuff on it ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], ccc, kexts, etc..), as it won't read fat32 or ntfs til step 4.

Just an advice: if you're double booting or triple, you may want to disconnect the battery while you're often switching between systems. OS's manage the battery differently and this will discharge it very soon.

If you want the battery to last normally, then use it with just one system.

 

- 1) Install iAtkos

the install should be flawless, maibe slow.

It seems to almost stuck at the end, but it is not, it just takes almost double the time it says.

 

install:

Chameleon, (it works also with Chimera)

fake SMC,

Disabler,

RTC,

Evoreboot

 

Drivers: intel SATA

USB 3.0

PS2

 

No sound drivers, due to conflicts and some KP you may experience,

No usb, it works oob

No video kext, the system has the conflictive NVIDIA Optimus with a double gpu intel 3000HD/NVIDIA GT540M so let's leave it for a later attempt. For now we'll just work with VGA.

 

If you start normally it stuck on the very same ACPI error many had:

ACPIPlatformPlugin not found:: timed out (something like it)

 

 

Start with -v -x flags

it asks for a bluetooth keyboard, but the internal keyb. works,

connect the usb mouse.

VGA res 1024x768, no sound, no fat 32/ntfs mounting, no network, no webcam, no Wifi, etc..

 

-2) Put in the CD with all the stuff and open ###### 4.0.2

Install: NETWORK: Realtek Gygabit kext

update permissions

reboot

 

-3) Backup with CCC of course before going on.

 

-4) Read this guide:http://www.insanelym...howtopic=263265

(the guide is for a Sandybridge laptop with i7 proc ) and follow it. Thanks to BlackestEyes.

 

...or just:

download Lion_install_volume.zip

it contains just 4 kexts: install them with Kext utility

open ###### and select:

Drivers and Bootloaders > Kexts & Enablers > fakeSMC Plugins (I assume FakeSMC already installed) > Motherboard plugins.

also from Customization>System Definitions>Macbook Pro 8,1

then select System Utilities>Rebuild caches, Repair Permissions

Install.

 

reboot normally:

 

If everything's ok you should have no boot conflicts, native 1366X768 res. IntelHD 3000 384Mb full QE/CI on sys specs

 

Backup the system again.

 

-5) Remove AppleHDA.Kext from System/Library/Extensions

 

​install VoodooHDA 0.2.7.3 mod attached, and sound it's ok.

 

Sleep with Sleepenabler.kext.

it works with stop menu, but closing the lid just turns off the screen.

Not reliable

 

Battery: install the 2 kexts in Lion Battery

 

Webcam should work with Skype and photo boot

 

screen brightness

 

WIFI: switched card with a BCM94321mc.

 

removed the broadcom useless card and installed a bcm94321mc card.

 

Mistake made: the size of the card is too big!! :wallbash:

anyway had to remove a skrew slot and reduce a cable support to put it in, but it finally fits.

I recommend, if you're dumb like me to order the wrong card, to put a drop off silicone on it to keep it in place.

 

Assuming you have the right card size:

 

I got a BCM 94321mc - AR5BXB72 (Atheros card) signed by Apple.

The card is not recognized oob, so you have to start with windows or linux and find out the Device ID and Vendor ID.

In my case it was 168c 0024.

 

Look inside the info.plist in Atherosfix.kext and find out if yours is there, otherwise edit it.

Install AtherosFix.kext

 

restart

enjoy! your wifi card.

 

You can also enable Airdrop following this link:

 

http://www.redmondpi...s-via-ethernet/

 

P.S.

My card was supposed to be only 802.11 b/g, but in the infos it is enabled also for n networks and have to say its got twice the reception than the previous one with windows.

 

good luck to all, and keep posting progress :wink2:

 

Update 1:

just applied combo update 10.7.2 and all seems fine:

  • got iCloud
  • the icons on launchpad are twice as big as before strong>ression.gif
  • seems a little faster
  • it' a little unstable: usb 3,0 ports lead to KP after a while

Update 2:

iAtkos L2 just installed, (clean install, just a problem with graphic at boot, solved starting with L1 CC backup disk and installing MacBookPro 8,1 smbios)

  • Seems to be more stable,
  • faster
  • sleep works better and battery too (finally got 4 hrs battery life)
  • the install method will be the same as L1, avoid step 4 (just install MacBookPro 8.1 smbios)
  • card reader fully working
  • USB 3.0 not fully working (my printer is detected but doesn't get the datas) also kp if you extract devices.

Update 3:

Applied 10.7.3 comboupdate, just remove Sleepenabler before or it gets KP.

 

All seems ok beside Garage Band not loading and Logic too.

  • Switched back to 10.7.2

Just a note here:

 

if you're using time machine then you'll have to start from iAtkos disk and from Utilities menu start Time machine recovery.

But then system won't boot because this is not a real mac and the bootloader is gone.

CCC disk is not booting either also using ###### disk.

Anyway, the system is there, just no bootloader.

Insert the iAtkos disk again and at the chameleon screen push F8 for start options and then select your Macdisk.

Once you're there reinstall Chameleon and u'r done... strong>ression.gif

 

Update 4:

Here's a dsdt for the system.

working but nothing special:

brightness bar on control panel (not working)

sleep working sometimes with lid closed too!!!

nvidia card detected (just it's there, nothing else)

 

If there's someone willing to help, would be nice :wink2:

 

 

 

Update 5:

 

Major improvement!!

 

ELAN TOUCHPAD FULLY WORKING!! :thumbsup_anim:

 

Thanks to:

EMlyDinEsH

in this post:

 

http://forum.osxlati...driver-mac-osx/

 

I've installed version 1.5.3 and ApplePS2Generic.. for keypad and it's fully working, two fingers scroll, horizontal scroll, gestures, etc..

 

You can find the drivers versions and other stuff in TonyNac forum too, just look for Elan Touchpad driver.

 

Remember to move the vertical scrolling bar slider on the prefpane to switch on the scrolling feature!

 

otherwise it may seem stucked.

 

At last we got it!! Thanks EMlyDinEsH

 

 

 

 

__________________________________________________

 

SYSTEM SPECS:

 

SAMSUNG RF511 S02

 

Intel core i7 2630qm sandybridge

ram 4gb ddr3 1333mhz

HD 500Gb WDC sata

video intel HD3000/Nvidia GeForce GT540M optimus

audio Realtek ALC 269

lan Realtek GBE RTL 8111

wifi BCM 94321mc/AR5BXB72

Elan PS2 Smartpad

webcam SCB-1100N

usb 3.0 Nec

ElanTouchpad.zip

lion_install_volume.zip

SleepEnabler.kext.zip

VoodooHDA 0.2.7.3 mod.zip

Lion Battery.zip

chameleon.zip

smbios.plist.zip

dsdt.aml.zip

AtherosFix.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

I have a Samsung RF 711 -s02 (core i7 2630qm intel hd3000 geforce gt540m). Tried to install with Iatkos l2. Installation proces ok, but when I boot i get stuck on the famous 'ACPIPlatformPlugin not found:: timed out '. tried boot option -v -x to no avail (same error). I don't have a spare mac :-) so I don't think uni/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is an option. Are there any kexts I can delete? (via live linux distro or something with terminal access).

 

Thx in advance

Share this post


Link to post
Share on other sites

ok, let's think..

 

First of all linux live may not work due to a permissions issue. You may have to change permissions to access osx partition but then you wan't be able to access it again as a startup disk.

you better check this out before doing things..

 

Anyway it's weird because L2 should have no issues with ACPI, it should work oob.

 

I can point to a couple of options that could work.

  1. In ######'s forum they stress to remove any RAM exceeding 4 gigs before install; if this is your case then give it a try.
  2. It's weird it doesn't start up with -x flag. Give it some more try, sometimes it starts at the 3d or 4th time...
  3. try -f flag, or cpus=1 and busratio=20.
  4. It is really a question of startin up the system once, and from there apply the ACPI solution. So you should have a backup disk or you can try to install from usb. There are plenty of guides out there to do so.

Once you start up, just install the kexts from Lion_install_volume and you should be ok

 

Remember that you'll probably never have a scrolling trackpad, and some other stuff..

 

Anyway good luck

Share this post


Link to post
Share on other sites

Removed 4gb of ram (toggled hyperthreading,... in bios and back). Even tried Paragon's hfs+ for windows but it fuc*ed up my OSX partition.

Md5 check of IATKOS L2 checks out ok.

I don't think my screen can be the culprit? (1600*900).

As far as I know I have exact the same specs as your samsung lappie

screenshot of error attached. (ps2 is because I enabled PS2)

 

And wtf is that DSMOS - thing?

 

I'm in deep water now, any help is greatly appreciated.

 

Cheers

post-974866-0-52600700-1331015774_thumb.jpg

Share this post


Link to post
Share on other sites

ok, listen; from the screenshot u posted it appears is not an ACPI issue. It seems all ok, very similar to mine.

 

On the first startup, immediately after install, when the screen stops, are u able to hear the welcome song or system sounds?

 

try to push volume buttons up or down: it seems like system is loaded but no video?

 

If so, it's a Smbios issue. You have to install MacBookpro smbios 8,1 or 8,2. There's a page somewhere where you can look at actual macbook models and see what's your lap like. I guess u have a 17" screen?

 

Anyway with champlist you can customize smbios at your like.

 

i hope it's so, but this reminds me again you'll have to start up with a disk or usb to install smbios..

 

Hope it works.

 

Got a question for you.

 

What ps2 kext did you installed? It seems to load ok voodoops2 and find an alps touchpad?

Is it yours a elan smartpad like mine at all? (look for it in windows)

Share this post


Link to post
Share on other sites

I'm trying to install iATKOS L2 in this Samsung model, (Samsung NP-RF511-S02US), with 8Gb RAM.

 

Last try was closer, haha, saw the mac logo at boot, background music, but no install procedure, just logo and music.

Rebooted at Verbose mode, and i got:

 

Waiting for DSMOS...

Previous Shutdown Cause: 3

Controller: Intel Cougar Point (Vendor ID: 8086, Device ID: 1c20)

NVDAGF100HAL loaded and registered

ACPI_SMC_PlatformPlugin::start - wait for service (Resource Matching(AppleIntelCPUPowerManagement) timed out

Transcript Offline - Buffer Pool Allocate [181000] failed

DSMOS has arrived

 

// Freezes.

 

I didn't select the nVidia GF100 driver at install tho, weird.

As I recall, I selected:

SATA AHCI

Sensors for CPU and Motherboard

USB 3

Realtek LAN

VoodooHDA 0.2.7.3

 

Any thoughts?

 

I'll try without some drivers...

Share this post


Link to post
Share on other sites

@ants.

 

My trackpad is of type elan (same as yours) don't know if it works i still didn't have complete macosx (gui) boot. I enabled it in iatkos l2 boot disk.

 

Problem I'm facing right know is that my screen turns black (also in -v -x, and single user).

Trouble with hda3000?

and weird enough something like nvdxxx (nvidia) is recognised. I understand that this is not supported (only intel hda3000).

question : I can't compile your attached dsdt.dsl. Is it possible to post a compiled dsdt.aml from your system. Also : what is your screen resolution (mine is 1600*900). your attached smbios.plist is for 8.2 macbook pro. (I have discovered that for my system it should be 8.1).

 

cheers

-P-

Share this post


Link to post
Share on other sites

@mencargo

 

your problem is with graphics.

Have to load the Macbookpro smbios 8.1 as described on the guide (Update 2). You need a startup disk.

 

GF100Hal loads by default from the system when it detects a compatible nvidia card. But isn't working..

 

@petruz2

 

I'll post my dsdt.aml asap

 

my resolution is 1366x768 15"

 

you can find smbios 8.1 in multi_beast

but I'll send you one..

 

anyway when you'll startup the system keep me informed on the trackpad..plz

Share this post


Link to post
Share on other sites

Update : Finally got Osx working on my laptop. Had to use patched dsdt.aml and macbook pro 8.3 smbios.

Full resolution 1600*900 full QE/CI :results Geekbench around 7500.

@ants : Trackpad sometimes works/sometimes not : not reproducable. sometimes results in kernel panic. no multitouch.

 

Only problem I'm facing right now is that I have to restart several times (like 3 times) due to KP's. Console /var/log/messages doesn't help.

Strangely enough after third or 4th reboot I have a working Mac !

Share this post


Link to post
Share on other sites

Thanks man ! Some of your kext was very usefull ;-)

Samsung np300e5a here, got some problem with my extended keyboard layout/keymap.

Numpad doesn't work proprely and I cant print back slash (key is at the top on the left). It just print "<" when pressed.

Where I can "recompile" the keymap ?

Remove com.apple.keyboardtype.plist to force rescan, won't help.

 

Thx for your time !

 

Gurzo

Share this post


Link to post
Share on other sites

Sorry for late reply

The keyboard layout is almost fine, except for the numpad that can be used with the Fn key pressed..

 

I've the Italian Pro layout and the \ key is there..

Share this post


Link to post
Share on other sites

@Ants

Grazie molte !

Ok same to me ;-) I've got the italian pro and it works a bit better . . I dont care about numpad at the moment ;-)

 

Thx for your answer

Share this post


Link to post
Share on other sites

Hey Guys, first Forum post!!! :thumbsup_anim:

 

I have this laptop, but am facing a HUGE problem :(

Mavericks will not load without a USB bootloader, I have tried to install

Chameleon and Enoch on to the HDD multiple times, but with no luck. :blush:

I think that it has something to do with the F4 Recovery option on the POST or BIOS startup screen B)

as when I pressed it, it booted a screen that showed chameleon, so I selected OS X, but then it crashed.

I then went to format the HDD, rebooted, and nothing happened :(

if ANYONE knows of any solution, I would be of great appreciation :yes:

ALSO, when I plug in the USB, it boots it up, but when its out, it says

"Reboot with a proper boot device or insert a device and press a key"

Share this post


Link to post
Share on other sites

Hi, i started with flags -x -v because the log hav ACPI problem, and i can see the startup screen, but appears one animation that show something like a mac saying that i press the shutdown button.

Whats happened??

I try install Aitkos L1

 

2n18g1y.jpg
Greetings

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×