Jump to content

nullcpupowermanagement and bios settings


10 posts in this topic

Recommended Posts

Unless you have good cooling, shortening of CPU life and possible overheating which can lead to thermal throttling kicking in, causing your CPU to automatically lower its clock speed.

 

But why do you want to do that? You should try getting native power management working instead of disabling it. There are plenty of recipes out there.

Link to comment
Share on other sites

I don't know...maybe. I don't have any Sandy Bridge experience, I don't know what the issues are.

 

I have C-, P-states and sleep/wake working here but I have P45/ICH10R/Core 2 Duo.

 

I haven't been able to get Hibernation working and I don't like to experiment with it as I already lost my whole installation once in a freak hibernate accident.

 

Follow the link I posted above, the thread deals with native power management on a Sandy Bridge platform.

 

General requirements for native power management:

 

An Intel CPU that can run the vanilla kernel

Power management features and ACPI 2.0, ACPI APIC enabled in the BIOS

Chameleon 2.1 (or derivative) with GeneratePStates=y and GenerateCStates=y set in /Extra/org.chameleon.Boot.plist.

"best match", complete model identifier DMI data in /Extra/smbios.plist. Use a model identifier from a Mac with the same or similar CPU microarchitecture. Use a Macbook identifer for a laptop, MacPro or iMac for a desktop. If you can find one with a similar Intel or Nvidia chipset and even on-board video, then that's a plus.

AppleLPC.kext and AppleIntelCPUPowerManagement.kext must be loaded

Sometimes DSDT patches to USB and other devices are required for S3 sleep/wake to work properly

Link to comment
Share on other sites

 Share

×
×
  • Create New...