Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[SOLVED]10.7.2 - IOHIDFamily KP (was PCIConfBegin)

7 posts in this topic

Recommended Posts

After updating to 10.7.2, I am not able anymore to boot my installation since it hangs as it reaches "PCI Configuration Begin".

In com.apple.Boot.plist, I have both the flag npci=0x2000 and GraphicEnabler=Yes.


Does anybody know how can I solve this issue?


Thanks in advice for the help!

Share this post

Link to post
Share on other sites

I would like to try to restore old AppleACPIPlatform and IOPCIFamily from Lion 10.7.. can anybody pass them to me?




I have tried the ones in 10.6.8 Combo Update's package, which should be the same as 10.7, but I get the same error.

I have tried also the one in 10.6.7, which let me pass on, yet the system then hangs at


DSMOS has arrived

macx_swapon SUCCESS


after a LONG wait, I get


Resetting IOCatalogue.


But then, even waiting one hour, nothing happens.


I tried many other solutions, changing DSDT, installing in E/E EvilAppleACPIPlatform and EvilIOPCIFamily, but nothing seems able to make my system boot... right now I really have no idea how can I solve this problem...

Share this post

Link to post
Share on other sites

Thanks but it didn't help...


I started thinking there should be something involving the bootloader too, so I installed in my Lion hdd the last Chimera bootloader.

And yes, now the system is not stuck anymore at the PCI Configuration Begin point.

Yet, I got a Kernel panic when it tries to load NullCPUPowerManagement... removing it results in a different KP.




Here I attach the verbose report of the Kernel Panic I got once I remove NullCPUPowerManagement.kext from Extra.

There I have only 3 kexts: ElliottForceLegacyRTC FakeSMC and JMicronATA.


Share this post

Link to post
Share on other sites

The situation has changed again, though I am not yet able to boot the system.


Here what I did: (from a SL installation on another HDD)


Restored all the vanilla 10.7.2 kexts in S/L/E

Upgraded motherboard's BIOS to F11

Installed the corresponding DSDT from tonymacx86 database

Used Chameleon Wizard to rebuild SMBios

Used Chameleon Wizard to update to last Chameleon release

Used Chameleon Wizard to build the org.chameleon.Boot.plist, adding the npci=0x2000 flag


Then I try to boot -v -f, and I have a KP due to IOhidfamily ..


Share this post

Link to post
Share on other sites

Well guys, I am writing from a perfectly functional 10.7.2 installation now.


At the end, I wiped out my SSD with Lion (my Home is in another disk, so it was not a big deal) and freshly installed again using the xMove/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/Chimera method, then combo-update to 10.7.2 and everything simply worked fine! ;)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.