Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Lion post install drivers

5 posts in this topic

Recommended Posts

Hi All,

I have a notebook DELL Latitude E6520 and I have installed OS X Lion from USB with tool myHack. Now the OS boot correctly but keyboard, touchpad, audio, network, wireless and larger resolutions not work.

Please, what are the correct steps for drivers installation?



Network: 00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection

Audio: 00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller

Wireless: 02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205

Video: Intel HD Graphics 3000

Chipset: Mobile Intel QM67 Express Chipset





Share this post

Link to post
Share on other sites

My E6520 is "functional", (10.7.0 upped to 10.7.2) with the following issues:


1. TracPad doesn't work (use external mouse) Works using kext uploaded by Theta (http://www.insanelymac.com/forum/index.php?showtopic=261313&mode=linear) look for KB_Trackpad.zip

2. WiFi not working (using Ethernet)

3. Sound work, but at fixed volume (VoodooHDA

4. Since 10.7.2 I had to load KeyRemap4MacBook to get my`~ keys back for a while (was mapped to §±). This reverted back later after I mucked around with the VoodooHDA (did a few repair permisssions and cache refreshes too). I have no idea what exactly fixed it.



Bootloader is Chimera, and with GraphicsEnabler=Yes I get full resolution + external monitor work too.


I used to be able (10.7.0) to even load this same installation under VirtualBox, but this is now broken (10.7.2).

Share this post

Link to post
Share on other sites

Yo register on OSX Latitude Forum. We need to stay on one collected site for our Latitudes. We have made a lot of progress with the E.D.P. method. I am working on getting the battery indicator working along with biometric fingerprint reader, RFID reader, Sleep, Two-Finger scrolling. See you there!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.