Jump to content
InsanelyMac Forum
Sign in to follow this  
Paoz

[Full Guide] to Perfect! Mac Pro (SL 10.6.7) on "Acer Travelmate 4740G"

Recommended Posts

[update : 17/6/2011]

 

0. Prepare your Computer For Perfect Macbook!

 

- make your Windows 7 OS bootable in AHCI mode by

Type Regedit in RUN

And find HKEYLOCALMACHINE/System/Current Controlset/Services/msahci

Modify DWORD Value named "Start" From 3 to 0

Reboot And change your BIOS Settings From IDE Mode to AHCI Mode

 

- Install Macdrive 8 in windows to make windows can see the Mac's HFS Volume

(Google is your friend)

 

- Shrink a volume to be your mac partition with

 

 

1. Installation Disc

 

- Use "Hazard's Snow Leopard 10.6.6i" WITH "ATA Patch" which filename is

 

"SL_10.6.6i_IOATAFamily.ppf"

 

You can find the original CD file in iso format in Bittorrent

You can find the PPF file in google by use "FILENAME" in search box

 

Patch it to the original Hazard 10.6.6i Disc with PPF master or else...

 

- Boot the CD WITH these commands : "-v busratio=17 cpus=1"

[for my i5 460M@2.53 GHZ I must use the busratio=17]

but for others CPU it use different number... (google is your friend)

 

- Use Utility to format a mac disc with format "Mac OSX Extended (journaled)"

 

- Then Select the drive BUT don't click install yet!

 

- Click customize and choose these

☑ Chameleon RC5

☑ Bootx86

☑ Graphics enabler

☑ Kernel (It's Legacy kernel for 10.6.6)

☑ Sound VoodooHDA 0.2.7.2

☑ VoodooBattery

☑ Additional Fonts

☑ X11

 

And then click Install!

 

2. Welcome to your mac!

 

- First Time, If your computer have Win7 Installed before you will not be able

 

to use the bootloaders so you must boot with the CD in the first time

([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] will fix it later)

(Dont have to boot with -v busratio=17 cpus=1 anymore, just choose mac)

 

- First go to Preference > Keyboard and Mouse ; Switch to tab "Trackpad"

and ☑ Tapping as click

- And now you will see these things is usable by "OUT OF THE BOX"

☑ Graphics nViDia geforce GT330M with DVI output! [For HDMI you'll need to update Chameleon]

☑ Sound Realtek ALC 272X (not perfect yet, but!! after this... :)

☑ Card reader

☑ Battery (You have to reboot for the first time)

☑ Synaptics touchpad with tapping ability (For scrolling ability, You later need to install the additional kexts)

☑ USB Mouse

☑ DVD Drive

☑ Keyboard

 

- Download My KEXTS : http://www.mediafire.com/?au6xm45ogj5223z

2.1 Unpack Kext helper b7

 

2.2 install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] by

☑ Chameleon RC5 Prerelease

☑ Theme > Tonymac Remix "OR" Chameleon Defalut

☑ System Definition > Macbook Pro 8.1

☑ Showallfiles

Reboot And now you can ejext the CD and boot with your own bootloader!

 

2.2.Special : Update Chameleon RC5 to make HDMI Output Functioning! :

http://www.tonymacx86.com/Public/Chameleon%20RC5.zip

 

2.3 Install Driver for sound in the order!!!

1st : VoodooHDA-2.7.2.pkg

2nd : VoodooHDA.kext with kext helper b7 I gave before

Reboot

Go to Utilities > Audio and Midi Settings Change all hardware to these settings

Sample Rate : 48000 MHz

Channel : 16 bit 2 Channels

And then you get ☑Sound and Mic in : Work!

 

2.4 For Webcam install Camtwist and set up the program by

2.4.1 Choose your webcam and save a Profile

2.4.2 Click "Autoload"

2.4.3 close Camtwist

2.4.4 Open Photobooth ; it will be in black

2.4.5 Open Camtwist and choose Don't check for update

2.4.6 See at your screen by yourself ;D

Do this method whenever you want to use the webcam and it go black

Just think "Camtwist" is your "Webcam Enabler" lol XD

 

2.5 Update to 10.6.7 ; Download Apple Combo update 10.6.7 :

 

http://support.apple.com/kb/DL1361

And install BUT!@!@!@!! When it finish Don't Restart Yet!!!

Install Nawcom's legacy kernel for 10.6.7 and sleepenabler

And then you can Reboot

 

2.6 Wireless

Install the kext by type of your hardware

- In Acer Travelmate 4740G Older Gen It is Atheros AR9285

- In Acer Travelmate 4740G Newer Gen It is Atheros AR9287 (As mine :P

Reboot

 

2.7 Install Kext for Lan : Broadcom BCM57780

Reboot

You will find that Mac Address is 00:00:00:00:00

Don't shocked XD just go to SLE (Your Mac Partition/Systems/Library/Extensions)

And Delete "AppleBCM5751Ethernet.kext" !!!

Then Reboot ; When then screen turn to black your power will still on because of

 

the mac address. So, just Hard close (It's safe because your CPU has already

 

been halted)

 

2.8 Install NTFS solution : this will add an ability to "Write" in your NTFS

 

partition

For SN : Go find it for yourself ; Google again, is your friend...

Reboot

 

2.9 If you want to change icon in "about this mac" to rainbow apple

look in folder "14 Apple Rainbow Logo"

 

2.10 Install time sync because If you have both Mac and Windows If you set the

 

Correct time in Mac, The time in Windows will shift and so in the same way ;

 

windows to mac.

- then Set the correct time in your BIOS

 

2.11 Disable Sleep Mode by InsomniaX 1.3.5

- Right click InsomniaX icon in dock and Add ☑Open at login

- Enable InsomniaX Mini Icon on the top of screen and select option "Load on

 

start"

 

2.12 Install JRE

 

2.13 For bluetooth just press Fn+F3 and You'll see

 

2.14 Enable Dock's Magnification effect in Preference

 

2.15 For Scrolling and Multifinger Scrolling Install these kexts with kext helper b7

http://www.kexts.com/view/1107-two-finger_..._1520-1720.html

 

Done!!!

And now you'll get the MaCer!! Travelmate 4740G ; Not for sell in the world XD

 

But there is only one thing left in my mind...

 

I have tried to patch DSDT with DSDT Auto Patcher :

http://www.insanelymac.com/forum/index.php?showtopic=235523

But it doesn't have right method for my Acer travelmate 4740G So I choose the

other that have some similar Specs (Aspire 4740G and Aspire 5742G)

And then...

 

I can successfully Sleep!!! (Cause before the power don't go off when It sleep)

But it don't wake anymore!!! XD lol

So I suggest that DSDT will be Sleep and wake Solution

But I don't know how to do it or where to start

 

-- Summary --

O W☑rked O

☑ Graphics Card nvidia geforce GT330M with DVI output! And HDMI output [but no sound] = ='

☑ Sound Realtek ALC 272X (Perfect!)

☑ Speaker and Built-in Microphone

☑ Wifi Atheros AR928x

☑ LAN Broadcom BCM57780 (With no Mac Address Problem)

☑ Bluetooth (You have to Fn+F3 to Open it)

☑ Card reader

☑ Battery

☑ Synaptics touchpad with tapping ability (Now with the new kext : Scrolling work!)

☑ DVD Drive

☑ Keyboard

☑ USB Mouse and other USB Devices

☑ Fan and cooling system (average 50-60 C)

 

O Not worked O

☑ Sleep

 

If anyone Have the solution ; How to Patch DSDT in Acer "Travelmate" 4740G

 

Please tell me :)

 

Thank you...

Insanelymac.com

Kexts.com

And everyone who replied me before :)

Share this post


Link to post
Share on other sites
Advertisement
Sorry for offtop but could you give a score from geekbench on your machine. Thanks

 

4883 points

http://www.mediafire.com/?9y9w6awi9wlafp1

 

All of your comments are welcome for my improvement -/\-

 

4883 points

http://www.mediafire.com/?9y9w6awi9wlafp1

 

All of your comments are welcome for my improvement -/\-

 

I just have tested it in my Win7 It earn score : 4184

In mac Is it faster? = ='

Share this post


Link to post
Share on other sites

Wow pretty cool. Mac better than the windows of 699 points I have a one more quastion but you chose Distro not Retail installation?

Share this post


Link to post
Share on other sites
Wow pretty cool. Mac better than the windows of 699 points I have a one more quastion but you chose Distro not Retail installation?

 

I use "Hazard 10.6.6i" with IOATA Patch ppf

 

It's not a retial

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • For me the forum seems quite quick, except whenever I see the word 'LOADING' - like when clicking another page of a thread - when it just stops completely and never returns.   I use an adblocker, so adverts aren't slowing me down.  Browsing the forum indexes is OK, as is clicking to view any thread.  Ditto clicking a link in an email notification to go to a particular post in a thread.   But then whenever I click on any other thread page, which tries to do the in-page content load (without a full page refresh), I see LOADING and then nothing further happens, even after minutes.   It's definitely not related to which content is loaded, but rather how it is loaded.  For example if I go to the index for this forum, then click directly to page 10 of this thread, it loads in a second or two.  But if I click page 10 while in the thread, it never comes back.  I just see this, forever:     To me this strongly suggests something is broken (code or configuration?) rather than a general slowdown of the server.
    • This is as far as I can get with the AMD kexts and the device ID added. They load but the frame buffer isn't loaded. I've tried loading all 7 frame buffers included in the X1000 kext with no luck. From the tests Gigamaxx did there seems to be more luck spoofing as Intel graphics there. More support may come from integrated Vega though, hard to tell.    
    • as documented here it is a sample rate standard and i have also tested it and i can confirm that it works with my audigy rx at least, i have to test it with other cards   https://github.com/audiojs/sample-rate
    • Yes, if i use the EFI folder that I uploaded to the google drive then i do have Intel working properly with QE/CI.
    • ubuntu@ubuntu:~$ sudo -s
      root@ubuntu:~#  superiotool -d
      superiotool r6637
      Found SMSC FDC37N972 (id=0x0b, rev=0x00) at 0x2e
      Register dump:
      idx 02 20 21 22 23 24 25 26  27 28 29 2a 2b 2c 2d 2e  2f
      val 00 0b 00 00 00 00 00 2e  00 00 00 00 00 00 00 00  00
      def 00 0b 00 00 00 04 04 NA  NA 00 00 00 00 00 00 00  00
      LDN 0x00 (Floppy)
      idx 30 60 61 70 74 f0 f1 f2  f3 f4 f5
      val 00 00 00 00 00 00 d1 15  0b 00 10
      def 00 03 f0 06 02 0e 00 ff  RR 00 00
      LDN 0x01 (Power management (PM1))
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      LDN 0x03 (Parallel port)
      idx 30 60 61 70 74 f0 f1
      val 00 00 00 00 00 00 d1
      def 00 00 00 00 04 3c 00
      LDN 0x04 (COM1)
      idx 30 60 61 70 f0
      val 00 00 00 00 00
      def 00 00 00 00 00
      LDN 0x05 (COM2)
      idx 30 60 61 62 63 70 74 f0  f1 f2 f7 f8
      val 00 00 00 00 00 00 00 00  d1 15 00 00
      def 00 00 00 00 00 00 04 00  02 03 00 00
      LDN 0x06 (Real-time clock (RTC))
      idx 30 60 61 62 63 70 f0 f1
      val 00 00 00 00 00 00 00 d1
      def 00 00 70 00 74 00 00 NA
      LDN 0x07 (Keyboard)
      idx 30 60 61 70 72 f0
      val 00 00 00 00 00 00
      def 00 00 00 00 00 00
      LDN 0x08 (Embedded controller (EC))
      idx 30 60 61
      val 00 00 00
      def 00 00 62
      LDN 0x09 (Mailbox)
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      Found SMSC SCH5027 (id=0x89, rev=0x03) at 0x4e
      No dump available for this Super I/O   i was some kind of lucky to dump some information but i am still not able  to dump the sensor chip Ubuntu Dumps.zip


×