Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Alien1959

Snow Leopard AMD Phenom ASUS Mobo

Recommended Posts

Hello everyone!

Nice to meet all the nice people here who have gave me invaluable knowledge on osx86 project.

 

I have been trying for about 3 months to boot Snow Leopard 10.6.3 on my AMD build. Seeing that I have found no other way, I have decided to consult the pros!

 

Here are my specs:

 

 

AMD Phenom II x4 BE 3.2Ghz

Asus MBA M4A87TD/USB3

Kingston Value Ram DDR3 1333 - @ GB x2

WD Desktop SATA 500 GB BLUE

ASUS 24x DVDRW SATA BLACK

ASUS EAH5750 FORMULA 1GB GDDR5 PCIE

CoolerMaster ELITE 335

VANtec ION 2 620Watt PSU

Coolermaster Hyper TX 3

AOC E2240VW BLK 21.5 LED

 

From above, yes, I am running an ASUS-AMD rig.

On the Harddisk is Win7 Ultimate, with Ubuntu Linux (made it looking like Snow Leo by using Macbuntu. heheh)

 

So i am very interested in booting MacOSX. I have tried:

-iATKOS (latest)

-MacOSX Retail 10.6.3 (I have the DVD)

-Hazard Snow Leo (latest)

 

Preboot discs I have tried:

-Nawcom ModCD (best so far)

-[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

-Mohamed's Selfmade BootCD [click here]

 

I have searched pretty much everywhere. And i have not succeeded in getting to the boot screen.

On my VM Workstation i can install iatkos and hazard fine. But i want it tri-booting. if possible.

 

I have also tried attaching a seperate SATA hdd with nothing on it, in hopes it will install. But no avail.

 

Using iATKOS and Hazard, the computer either reboots after a few fast lines of code, or black screen, with the dvd drive spinning down after awhile, then hanging.

Using the Chameleon inbuilt with those distros, it auto resets, and using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], it hangs, best luck so far is Nawcoms ModCD

 

I have tried Nawcoms ModUSB as well. With the 10.6.3 Retail, using the vanillla kernel will bring me to __kernel__ not loadable and then pointing to the final error/result here. [see image]

 

dsc01622g.th.jpg

 

dsc01623sw.th.jpg

 

That's is the dead end, or rather as far as i can go.

Always MAC Framework successfully initialized and then the IOPIC and Vector 64:87 thing.

 

-The DVD spins down, there will be no response anymore, USB also, nothing even after half an hour, leaving me with no choice but todo a hard reset. (pressing the power button for 10secs)

 

Using Nawcom's (thanks for this btw, real nice!) Modbin kernel, I don't get a kernel not usable thing.

I have also tried using that very famed mach_kernel.test7 that seems to work on Phenom builds, same thing, i get stuck there.

 

I used Nawcom's ModUSB too, made with the original retail disc.

 

Strange thing that puzzles me, my OSX, iATKOS, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], Hazard DVD never shows up as a regular DVD thumbnail image at Chameleon, (it does on intel build, have tried, and succeeded) rather its shows up as a hard disk icon. e.g:

 

dsc01617mi.th.jpg

 

and

 

dsc01618e.th.jpg

 

See? even on the Chameleon in iATKOS.

 

This is the image of my ModUSB. 16GB Cruzer!

 

dsc01619fe.th.jpg

 

This is the final code i see after it loads all the HFS+ files and before it hangs at that IOPIC thing.

 

dsc01620e.th.jpg

 

dsc01621jp.th.jpg

 

 

So, please advise? ;)

Fyi, I have set my BIOS settings as they should, AHCI, etc etc, all are SATA drives!

*this is me wanting an install, not an upgrade from Leo.

 

Upon digging around, i have seen threads using a similar M4A87 mobo, but either all fail, or no reply, or no working solution. Perhaps this mobo just doesnt work? Using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and iATKOS, i read no SMBIOS replacement found, nawcom however finds one!

 

Also, I used bootstraps like -v -x -f -s cpus=2 fsb=200000000 maxmem=4096 (chameleon says 4092 tho) busratio=20 cpus=1 etc etc all in combos.

 

I've come this far, I dislike giving up, its a geek thing right? hahaha, if this works, I'll make a full tut for this!

 

Thanks in Advance! :D

U guys rock!

Let me know if you need more info! :)

 

Alien1959

 

*Reserved for Tutorial if successful*

 

PS: Also, DSDTSE can't compile a DSDT for my system without 201 erros. smile.gif

Share this post


Link to post
Share on other sites
Advertisement
Hello everyone!

Nice to meet all the nice people here who have gave me invaluable knowledge on osx86 project.

 

I have been trying for about 3 months to boot Snow Leopard 10.6.3 on my AMD build. Seeing that I have found no other way, I have decided to consult the pros!

 

Here are my specs:

 

 

AMD Phenom II x4 BE 3.2Ghz

Asus MBA M4A87TD/USB3

Kingston Value Ram DDR3 1333 - @ GB x2

WD Desktop SATA 500 GB BLUE

ASUS 24x DVDRW SATA BLACK

ASUS EAH5750 FORMULA 1GB GDDR5 PCIE

CoolerMaster ELITE 335

VANtec ION 2 620Watt PSU

Coolermaster Hyper TX 3

AOC E2240VW BLK 21.5 LED

 

From above, yes, I am running an ASUS-AMD rig.

On the Harddisk is Win7 Ultimate, with Ubuntu Linux (made it looking like Snow Leo by using Macbuntu. heheh)

 

So i am very interested in booting MacOSX. I have tried:

-iATKOS (latest)

-MacOSX Retail 10.6.3 (I have the DVD)

-Hazard Snow Leo (latest)

 

Preboot discs I have tried:

-Nawcom ModCD (best so far)

-[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

-Mohamed's Selfmade BootCD [click here]

 

I have searched pretty much everywhere. And i have not succeeded in getting to the boot screen.

On my VM Workstation i can install iatkos and hazard fine. But i want it tri-booting. if possible.

 

I have also tried attaching a seperate SATA hdd with nothing on it, in hopes it will install. But no avail.

 

Using iATKOS and Hazard, the computer either reboots after a few fast lines of code, or black screen, with the dvd drive spinning down after awhile, then hanging.

Using the Chameleon inbuilt with those distros, it auto resets, and using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], it hangs, best luck so far is Nawcoms ModCD

 

I have tried Nawcoms ModUSB as well. With the 10.6.3 Retail, using the vanillla kernel will bring me to __kernel__ not loadable and then pointing to the final error/result here. [see image]

 

dsc01622g.th.jpg

 

dsc01623sw.th.jpg

 

That's is the dead end, or rather as far as i can go.

Always MAC Framework successfully initialized and then the IOPIC and Vector 64:87 thing.

 

-The DVD spins down, there will be no response anymore, USB also, nothing even after half an hour, leaving me with no choice but todo a hard reset. (pressing the power button for 10secs)

 

Using Nawcom's (thanks for this btw, real nice!) Modbin kernel, I don't get a kernel not usable thing.

I have also tried using that very famed mach_kernel.test7 that seems to work on Phenom builds, same thing, i get stuck there.

 

I used Nawcom's ModUSB too, made with the original retail disc.

 

Strange thing that puzzles me, my OSX, iATKOS, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], Hazard DVD never shows up as a regular DVD thumbnail image at Chameleon, (it does on intel build, have tried, and succeeded) rather its shows up as a hard disk icon. e.g:

 

dsc01617mi.th.jpg

 

and

 

dsc01618e.th.jpg

 

See? even on the Chameleon in iATKOS.

 

This is the image of my ModUSB. 16GB Cruzer!

 

dsc01619fe.th.jpg

 

This is the final code i see after it loads all the HFS+ files and before it hangs at that IOPIC thing.

 

dsc01620e.th.jpg

 

dsc01621jp.th.jpg

 

 

So, please advise? :D

Fyi, I have set my BIOS settings as they should, AHCI, etc etc, all are SATA drives!

*this is me wanting an install, not an upgrade from Leo.

 

Upon digging around, i have seen threads using a similar M4A87 mobo, but either all fail, or no reply, or no working solution. Perhaps this mobo just doesnt work? Using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and iATKOS, i read no SMBIOS replacement found, nawcom however finds one!

 

Also, I used bootstraps like -v -x -f -s cpus=2 fsb=200000000 maxmem=4096 (chameleon says 4092 tho) busratio=20 cpus=1 etc etc all in combos.

 

I've come this far, I dislike giving up, its a geek thing right? hahaha, if this works, I'll make a full tut for this!

 

Thanks in Advance! :D

U guys rock!

Let me know if you need more info! :)

 

Alien1959

 

*Reserved for Tutorial if successful*

 

PS: Also, DSDTSE can't compile a DSDT for my system without 201 erros. smile.gif

 

 

 

 

IN CONCLUSION, I DONT THINK WE CAN INSTALL MACOSX on this... Sorry Guys.

Share this post


Link to post
Share on other sites

Try again.

I have iATKOS S3 v2 running on my Asus M4A78 mobo with AMD Athlon II x2 250 cpu.

 

-v -x -f cpus=1 busratio=20 arch=i386 to get into the install disk.

 

Qoopz 3 kernel, and anV bootloader were chosen to be the startup on the new disk. Use a separate disk for this. Doesn't tend to work very well with double or triple boots on the same disk.

 

-v -f cpus=1 busratio=20 arch=i386 PCIRootUID=1 (and possibly USBBusFix=yes to have your USB peripherals working.)

Share this post


Link to post
Share on other sites

ah i see. Ok then, will let you know asap. iATkos L1 doesnt work yet due to lack of kernel I suppose?

Even more, its not possible to boot retail? with nawcoms amd kernel....

 

and do you have DSDT?

 

Thanks! ;)

Share this post


Link to post
Share on other sites

I got a Biostar GF8100 M2+TE with a Athlon2 x4 640 cpu. After a dozen tries I could install Snow with the Nawcom ModCD from March.

Using the CD bootloader the installed system works more or less. Ethernet and USB are hit and miss, screen is 1024x768 only.

Still thats not bad for a AMD powered system.

 

I would like some advice how to proceed best:

How can I get the GeForce 8100 mGPU working with bigger screen res? (EFI strings did not work, so far)

Which bootloader version could I try for the HDD? ( recent Chameleon pre releases gave me KP)

How could I get Ethernet and USB working more reliable? (Net and some USB ports usually work with booting from CD)

 

Many thanks in advance!

Share this post


Link to post
Share on other sites

One thing not mentioned anywhere was the burn speed of your DVD burner. You want to burn at the slowest speed available. 4x or slower. Less errors this way.

Share this post


Link to post
Share on other sites

ihave used nawcom cd and usb.Ihad to type the first line shown for modbin kernel. It booted ran instller rebooted off nawcom and selected new drive. I then put specifickexts there. Iwill say that its a pia if u use usb as I had to turn on legacyusb and os x gets pissy. Best working on M4n82 Deluxe Ph II x4 955BE. SATA=AHCI, CPU=C1E=disbled, Legacy USB=Off, and PowerManager? =S3 (I had s1/s3/off),ACPI 2.0=Yes, and APIC =Yes/Enabled. Some guides say s1. You will get faster booting from c1e setting. Better usb and no errorsfrom that setting. Dunno about S1/S3 Geforce 9500works with Graphicsenabler=y also my gtx 560works too, working on getting full support on that one. Read its not possible on Snow?? use google fr directions on linux live boot cd, i used ubuntu. Extract dsdT and save to flash. download dsdtse from osx86.es open dsdt in app click compile and zero errors or warnings. put in /extra and edit smbios.plist. I have found chameleon wizard 4.1 works well with dsdt editing as most or all i needed was there. avoid lizard app it has issues with asus mobos, an always managesto f-ck up my install. I hopethis helps. It took a few days for os x insall. and months for dsdt. I thank osx86,es as i submitted many dsdt files to them and without them would not have a proper dsdt. I thank nawcom too. he even once told me amd dsdt is a {censored}!

 

I always had plug and play =off also I used nawcom legacy kernel 10.6.8v2. Anyone reccomend other kernels 10.6? I am also looking for a 10.7 amd kernel. I applied for beta test but was left out.

Once u r up and running... i had to use in boot.plist actually org.cham arch=i386 -force64. i have argued with many over thisfrom tony mac to voodoo team. It just works this way!

 

PS- custom discs like iatkos, etc always fail! it willsometimes boot or even install, but in the end a headache. use a nawcom cd preferably and retail dvd (easiest). Those dics are great for old pentium era builds.

 

PSS-When taking advice click on members name and look @ how long thy have been a member!

Share this post


Link to post
Share on other sites

Hello all! :D After giving up in my last attempt, recently I got that sudden drive to try it again. It all started with my trying on an old Socket 478 Pentium 4 2.8 Ghz.

 

After failures, I just decided to try it on that computer as previously listed.

 

AND OMG! I got past that vector!

 

all I had to do, was as unimatrix725 said, (although I previously found the fix on osx86. thankfully it was after my attempts last year.)

 

YOU NEED TO GO To BIOS, CPU FEATURES, and disable CE1. or 1CE. Depending on your mobo.

 

 

Essentially what that does is save more watts of power when the cores are idle. Which when used with an osx. Will cause it to hang there. at the Vector thing.

 

 

Also, it works on iatkos. haven't tried vanilla retail. But the results aren't really good.

 

Choose qoopz kernel, and tick the voodoo ps2 keyboard, else you are going to have a no keyboard error and -x can't boot (kernel panic).

 

graphics suck. so hopefully I'm going to use that install to make a boot disk. :)

 

Cheers to everyone and thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×