Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Jeremy Pevar

SiL3132 eSATA RAID Driver Problem

2 posts in this topic

Recommended Posts

Although this is not, strictly speaking, a Hackintosh specific question, I have searched everywhere for a solution to this problem and come up empty.

 

So, here it is: I am running OS X 10.6.7 on a shiny new 17" i7 MacBook Pro. My previous machine was a 15" Core2 Duo MacBook Pro running 10.6.5. I also have a SIL3132 based Rocstor ExpressCard eSATA adapter controlling a 4 bay Sans Digital RAID 5 array. On the 15", running 10.6.5 this all worked flawlessly. However, when I plug the ExpressCard into the new machine, it is not recognized. It comes up as an generic mass storage device, and the drives in the RAID don't even spin up. Also, when I upgraded the OS in the old 15" to 10.6.6 the eSATA adapter stopped working.

 

I have tried all of the obvious things:

-downloaded the latest driver from the Silicon Image website

-booted up in 32 bit mode

 

But, nothing works. It seems clear to me that this is an issue with the SIL3132 RAID driver, but no one (Rocstor, Silicon Image, Sans Digital, Apple) can give me a solution to the problem.

 

So, the question is: is anyone in the Hackintosh community successfully using a SIL3132 based eSATA adapter in RAID mode? And, if so, how have you gotten it to work?

 

Thanks!

Share this post


Link to post
Share on other sites

I have an assortment of Silicon Image-based mini-PCI-express cards (Si3132, 3124). I use the Sonnet Tempo E2P (Si3132) on my main system, attached to two 5-disk enclosures. They run fine under MacOS X 10.7.2 (in 64-bit mode).

 

As far as the driver is concerned, I think one's best bet is to download the Sonnet drivers, which were updated for Lion this past summer. Here's the link:

 

 

 

http://www.sonnettech.com/support/kb/kb.ph...mp;action=a3#a3

 

If your mini-PCIe card is based on, say, the Silicon Image 3531 chip, you can use the same driver, but first modify the kext's plist to reflect the chip's name. See my notes at - http://lycabettus.wordpress.com/2011/03/06...h-snow-leopard/

I've done that with my MacBook Pro and a D-Link 3132-based express card. Make sure it's seated firmly, though, or you get a kernel panic.

 

 

Hope this helps.

 

Xen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×