Jump to content

MSI Click UEFI BIOS - A Warning!


4 posts in this topic

Recommended Posts

I've just posted this on MSI's forum.

Frankly I've had it with MSI!




I've got to be honest - at this point I believe I will never buy an MSI motherboard again!


This is the second I've had that has been rendered useless by following MSI directions for BIOS flashing.


I understand the click bios project is no longer - however the MSI page offering download of this BIOS still exists despite MSI updating it's global website!



The version of UEFI BIOS available on this official site for both the P45 Platinum and P45D3 platinum are desperately out of date! And one must search a German language msi forum to find a workable update.


As stated above I have just bricked a BRAND NEW P45D3 platinum flashing E7513IMS.120 using the MSIFLASH.EXE and a bootable USB as downloaded from the OFFICIAL MSI site!

As far as I can see MSIFLASH.EXE operates no check-sum at any stage of the flash operation! IS THIS FOR REAL!??


As stated above I have bought MSI recommended RAM for this board. Yes I have removed power and battery from the MB and cleared CMOS with each FSB setting I have tried. And yes I have tested with nothing but my GPU and 1 stick of RAM!


Also tried recovery methods using standard AMI bios file (as factory flashed V1.2) renamed to AMIBOOT.ROM and A7315IMS.ROM on DVD ROM and USB formatted to both FAT and FAT32.

And the same with E7513IMS.120 and 143


My previous Platinum P45 7512 was bricked because I used MSI's M-Flash from BIOS. Why add software that is KNOWN NOT TO WORK!

MSI support didn't even credit me with an response to the ticket I raised on this matter over 5 months ago and I have had to settle for a £60 return on a £120 purchase from the my UK supplier as having waited 3 months for a replacement board I gave up!


I refuse to waste any more money on tinpot hardware!


I will also be posting this as a warning to others on the various forums I frequent!



Link to comment
Share on other sites

For anybody who's interested in my drivel ;) :


I've managed to finally flash back to standard AMI BIOS.

The main beef of the problem was the RAM SPD wasn't being read properly with the UEFI BIOS (I even tried the latest E7513IMS.143 with the same results.) timings where well off and voltage set @ a shocking 1.9v for my poor 1.5v un-heatsinked RAM.


And to stress the RAM is listed as compatible for this MB!


I've spent pretty much all of my weekend (ingnoring time spent in the pub ;) ) tapping the reset button to get the sodding thing past the 'checking RTC' stage and actually boot.

When it did boot I had about 30 seconds to change timings and set voltage before the fu@ker crashed. Not knowing the menu structure I think you can guess how irritating this was


I'm up and running and now do appreciate why I bought MSI as they make good hacks.


Just a shame the UEFI project never really made it past the Beta stage (IMHO) - I say this despite there being a 1.2 release available.


The MSI UEFI Click site should carry a strong warning that it is EXPERIMENTAL!


Dam shame I'd like to have been running and EFI BIOS!



Link to comment
Share on other sites


  • Create New...