Jump to content

Still waiting for root device..


clueless_wako
 Share

9 posts in this topic

Recommended Posts

I come to you, allmighty gurus of hackintosh wizdom, in my darkest hour...

 

Trust me folks, i am not the kind of person who just jumps in a forum and posts, totally disregarding the nice little buttons labled "Search" and, "FAQ".

My setup:

AMD Athelon 64, SSE3 compatible

2 GB ram

74gb NTFS hdd, one partition (windows)

120GB NTFS hdd, one partition (files/storage/backups)

37GB Mixed Hdd, [partition 1, 7gb, mac, image was dd.exe'd to the partition] Remaining space unallocated

 

Image name: tiger-x86-flat.img

 

I read the gude on your wiki on installing to a partition, to avoid the vairable of DVDs. I followed the guide to the letter, and redid the process three times.

When presented with my multi-boot loader (i have a mod'd windows loader), I select Mac, and put -v in the startup options. I see lots of text fly by, then it pauses, with a flashing cursor. After a pause, it displays "Still waiting for root device", and never stops saying this. Booting without the "-v" switch simply produced a gray apple screen, with a spinning thingie, and after a period of time, i get a "no" symbol, and the instalation never passes that screen.

 

Steps Taken (note, after each item, system was restarted and tested)

 

-Unplugged all optical drives

-Unplugged all non-mac hard drives

-Disabled USB and onboard lan

-Became very angry and kicked and swore at computer

-Ate lunch

-Re-imaged the partiton

-Re-downloaded the image

-Re did the partition, again

-Damned the computer to hell

-Posted here.

 

EDIT: My hard drives are SATA, my optical drives (which were first disconnected) are IDE

 

Please, if anyone can help me, i would be your enternal servents!!!!!

Link to comment
Share on other sites

check your jumpers. in many cases the waiting for root device prob is caused by improper jumper setting.

do not use cable select, try setting the harddrive and cdrom manually, master and slave. reverse the order if it is not working.

 

i've been battling this waiting for root device for weeks and still i have not found a solution to my case. i have a sis chipset motherboard and probably thats the cause. :(

Link to comment
Share on other sites

Yes. Have a problem like you.

 

MacOS 10.4.6 HOtISO

Celeron D 2.66 SSE/SSE2 (No sse3)/Asus Deluxe P4P800/2x256 ddr-333/GF5550/ IDE WesternDigital 80 Gb

 

Can't Boot from Installation DVD, because have a something like error: Still waiting for root device.

 

Can anybody help us?

Link to comment
Share on other sites

I have an A8N-SLI Premium, thats an nForce4.. Possibly this isnt mobo related?

and i cant see how to change the "Jumpers" Becuase i beleive SATA dosnt have jumpers? And regardless, i have unplugged all drives but the Hackintosh one...

 

Oh goodness i hope we're not doomed.. :D

Link to comment
Share on other sites

A8N32 Deluxe here -- had this problem with the JaS 10.4.6+patch until:

 

1) Installed BIOS 1303

2) HD on primary master, dvd on primary slave (both with appropriate jumpers), as people were saying.

 

Nothing else worked, if they weren't on the same IDE Channel, including disconnecting the DVD and using a USB DVD ROM (which worked fine to install on my laptop!). I think updating the bios is pretty key.

Link to comment
Share on other sites

I had the same problem on the P4 I installed OS86 on want did work for me was the MacOSX_10.4.6_GoatsecxDVD.iso image. the JaS DVD just would not work on this P4 it would install and the give me a Still waiting for root device after the reboot. I was able to install 10.4.6 and then use the 1.4.7Intel hack update and all is fine. I still do not know what the problem was with the JaS DVD as it worked on the Athlon64 just fine. On a side note the MacOSX_10.4.6_GoatsecxDVD.iso will not work on the Athlon64 as none of the USB device work so no mouse or keyboard plus took 45 minutes just to boot keept spitting out USB device errors the hole time. Anyway it might be worth a shot to try it if the JaS image does not work for you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...