Jump to content

Need guidance with installing SL on my PC


miscbeep
 Share

8 posts in this topic

Recommended Posts

Hi guys !

 

I've been trying to install this baby on my PC since last night, now it's my fourth try. But still no luck on the booting.

First off, let me tell you the details ;

 

MB : ASUS P5LD2 - SE

GPU : ATI 4850 HD 512MB

RAM : 2x2GB @ 667Mhz

CPU : Intel Core 2 Duo E4400

HDDs : 2 x 320GB

 

I downloaded iAtkos S3v2. I'm trying to do it with this very release. I've installed OS X 10.5 before on my PC and it worked, but that was back in '09. Now I want to install SL. Since then I've only changed my gpu.

 

I'm doing everything fresh. So, it's all good - the installation is fast and all, I select some stuff from the "Customization" menu, that I think are needed. But everytime it reboots after the install, I wait and wait - It starts spinning the famous orb.

After that there's something on the screen, like a broken image, with big pixels - different colors. And that's it ! Nothing else happens after this. That leads me to the thought that it may be something related to the drivers I've selected in the custom menu. But I don't know. Maybe it has to do something with the kernels or the bootloaders - I'm not sure which one to choose.

 

That's all I get for now - but no errors LOL

 

If anyone has any advice for my system, it'd be great !

 

Thanks in advance !

 

Edit:

 

Mostly I get those kinds of images when I try to boot, see the attachments.

 

The pic with the text showed after trying to boot with -s -v

The other one was just normal booting after restart. It changes everytime. Sometimes its on lines, last time it looked like oversized pictures of chips. This one particulary is on fat lines.

 

THANK YOU

post-187712-1292591739_thumb.jpg

post-187712-1292591895_thumb.jpg

Link to comment
Share on other sites

I think your problem is ether graphics support, dsdt or fakesmc.kext

 

First Generate a new (clean) dsdt.aml - using http://www.insanelymac.com/forum/index.php?showtopic=235523

 

Second Make sure you have latest fakesmc.kext (try kexts.com)

 

Next Update to 10.6.5

 

Then Install the newest version of Chameleon (R2 v678) and use the graphics enabler yes option - I believe this supports your graphics card (earlier versions may not) I'm not really sure if this will work. Look into it - search.

 

Finally Sound is another issue. Probably the easiest sound fix will be voodoohda.kext. There are several versions - some will work - some wont.

 

 

Good luck !

Link to comment
Share on other sites

Hey Tim,

 

I've managed to figure out what the problem is, and it turned out to be my graphics card.

 

1. I'll generate a new DSDT.

2. Found FakeSMC_rev404, I guess that's the newest one ( from Sept, this year ).

3. Sound is fully working ! - I/O w/ mic, thanks to the VoodooHDA.

4. Yesterday I tried to update in safe mode to 10.6.5, but when I restarted after the update - my mouse and my keyboard ( both USB ), weren't working ). Any ideas on how to keep the usb mouse and keyboard working after the update ? I can't login otherwise.

 

Do you have any idea which kernel version to select ? 10.2.0 or 10.3.0 ?

 

Thanks !

Link to comment
Share on other sites

Did you use any usb kexts when installed? If so you need to reinstall them from the install disk you used.

Yes I did select all of them from the customization menu. But tell me, how exactly do I reinstall them from the installation disk ? If I cannot login in the system after reboot ?

 

Thank you !

Link to comment
Share on other sites

Boot from the install disk and install only the usb stuff you installed before. Make sure select only what you need.

 

Ok, I'll boot normally as if I will install it, and then select only the usb fixes from the customization menu.

 

Thanks.

 

edit ;

 

Can you by any chance tell me which kernel is the best ? I really don't know if I should select 10.2.0 or 10.3.0..

 

snackole - That's impossible, If I boot with the installation disk and I reach the Customization menu, the iAtkos System is grayed out, which means it'll always be installed and I can't unselected/untick it and just choose the usb files..

 

Thanks.

Link to comment
Share on other sites

USB will be fixed with dsdt and/or new sleepenabler.kext.

 

For Sleepenabler --- If you are using sleepenabler.kext or any type of (non-apple) kext for sleep it must be for that specific kernel. This WILL affect USB. Fix this issue first. The 10.6.5 update includes an updated kernel 10.5.0. You should be using 10.5.0 kernel. There is no reason to go back to an earlier kernel.

 

For DSDT ---- Make sure you get dsdt generated properly. You can not get a clean dsdt in osx with out removing the current dsdt.aml and then generating new dsdt. You cannot have any dsdt.aml file running while generating new dsdt because it will corrupt the new dsdt. Many people find it easier to generate a clean dsdt in windows or linux.

 

Wen running osx without dsdt you would also have to remove appleintelcpupowermanegment.kext or it will KP. You can reinstall appleintelcpupowermanegment.kext after new dsdt is applied. You may need a non usb mouse/keyboard for this process.

 

 

Good luck !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...