Jump to content
Intel8051

Driver de Audio Snow Leopard 10.6.5

61 posts in this topic

Recommended Posts

Boa tarde,

 

Instalei o Snow Leopard versao 10.6.5, utilizo no boot do sistema o MutiBeast + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], gracas a ele o sistema reconheceu minha placa de video, a rede e a firewire.

 

Porem estou enfrentando problema no audio, ja instalei diversos driver para ele mais sem sucesso seu funcionamento, no proprio site encontrei dicas para a instalacao dele que no caso e um ALC888, instalei o kext AppleHDA e o HDAEnabler, quando inicializa o sistema o alto falante faz um barulho mas quando estou dentro do sistema ele nao funciona.

 

Ja tentei tambem o VOODOO HDA, porem quando inicializa o sistema da PAnic Kernel, sendo necessario a remocao dele para consseguir inicializar o mac.

 

Coloquei -v com o AppleHDA e HDA enabler instalado, reparei que da um mensagem de erro no carregamento do APPLEHDA.kext, algo relacionado com EFI ROM Failed.

 

Como posso resolver esse problema?

 

Especificacao do meu pc

 

PLACA MAE INTEL DP55WB (AUDIO ACL888)

PROCESSADOR INTEL I5 750

PLACA DE VIDEO NVIDIA GT220 EVGA 1GB

HD SEAGATE 500GB BARRACUDA

Share this post


Link to post
Share on other sites
Advertisement
Boa tarde,

 

Instalei o Snow Leopard versao 10.6.5, utilizo no boot do sistema o MutiBeast + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], gracas a ele o sistema reconheceu minha placa de video, a rede e a firewire.

 

Porem estou enfrentando problema no audio, ja instalei diversos driver para ele mais sem sucesso seu funcionamento, no proprio site encontrei dicas para a instalacao dele que no caso e um ALC888, instalei o kext AppleHDA e o HDAEnabler, quando inicializa o sistema o alto falante faz um barulho mas quando estou dentro do sistema ele nao funciona.

 

Ja tentei tambem o VOODOO HDA, porem quando inicializa o sistema da PAnic Kernel, sendo necessario a remocao dele para consseguir inicializar o mac.

 

Coloquei -v com o AppleHDA e HDA enabler instalado, reparei que da um mensagem de erro no carregamento do APPLEHDA.kext, algo relacionado com EFI ROM Failed.

 

Como posso resolver esse problema?

 

Especificacao do meu pc

 

PLACA MAE INTEL DP55WB (AUDIO ACL888)

PROCESSADOR INTEL I5 750

PLACA DE VIDEO NVIDIA GT220 EVGA 1GB

HD SEAGATE 500GB BARRACUDA

 

se vc for usar a VoodooHda, remova a AppleHda

 

Roda esse programa e me manda os arquivos

http://www.insanelymac.com/forum/index.php...st&id=81816

a gente pode tentar pelo DSDT

Share this post


Link to post
Share on other sites
Obrigado pela rapidez da resposta, logo abaixo esta o arquivo

send_me.zip

 

Vá no SystemPreferences / Som / Saída

e defina como alto falante interno

Tente isso

 

Já te mando o DSDT

as kexts estão carregadas

Share this post


Link to post
Share on other sites
Vá no SystemPreferences / Som / Saída

e defina como alto falante interno

Tente isso

 

Já te mando o DSDT

as kexts estão carregadas

 

Ja defini o som para alto falante interno, ainda nao funcionou o som, fico no aguardo do DSDT.

 

Obrigado

Share this post


Link to post
Share on other sites
So uma duvida, como instala o dsdt, extrai ele e esta em formato aml.

 

coloque o dsdt.aml dentro da pasta Extra ou na raiz do HD

A AppleHda na pastaSystem/Library/Extensions

depois de colocar a kext na s/l/e de dois clliques no Kext Utility

http://www.mediafire.com/?41279tilghd9zrq

e espere ele fazer o trabalho

Share this post


Link to post
Share on other sites
coloque o dsdt.aml dentro da pasta Extra ou na raiz do HD

A AppleHda na pastaSystem/Library/Extensions

depois de colocar a kext na s/l/e de dois clliques no Kext Utility

http://www.mediafire.com/?41279tilghd9zrq

e espere ele fazer o trabalho

 

Nao funcionou, reiniciei o pc o computador demorou pra iniciar uns 16 minutos, e ficou em camera lenta.

Tive que remover o kext para iniciar normalmente.

 

Coloquei em -v nao vi nenhuma mensagem de errro.

Share this post


Link to post
Share on other sites
Nao funcionou, reiniciei o pc o computador demorou pra iniciar uns 16 minutos, e ficou em camera lenta.

Tive que remover o kext para iniciar normalmente.

 

Coloquei em -v nao vi nenhuma mensagem de errro.

 

Continue com o DSDT

Volta com a AppleHda original do 10.6.5

AppleHDA.kext.zip

 

reinicie

 

depois rode isso no terminal

ALC888

 

sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

Vc precisa de uma legacy

nesse tópico tem muitas, não sei se umas dessas vai funcionar, vc pode usar a busca do fórum, ou então usar a VoodooHda, basta remover a AppleHda pra não dar KP

 

http://www.insanelymac.com/forum/index.php?showtopic=140941

 

vc tem certeza que é a ALC888? existem outros 888x

Share this post


Link to post
Share on other sites
Continue com o DSDT

Volta com a AppleHda original do 10.6.5

AppleHDA.kext.zip

 

reinicie

 

depois rode isso no terminal

ALC888

 

sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

Vc precisa de uma legacy

nesse tópico tem muitas, não sei se umas dessas vai funcionar, vc pode usar a busca do fórum, ou então usar a VoodooHda, basta remover a AppleHda pra não dar KP

 

http://www.insanelymac.com/forum/index.php?showtopic=140941

 

vc tem certeza que é a ALC888? existem outros 888x

 

 

Segundo o manual da placa mae o chip e alc888 vc2 gr.

 

Sera que e compativel com os drivers?

Share this post


Link to post
Share on other sites
use a VoodooHda

remava a AppleHda

 

Toda vez que uso VoodooHDA da panic kernel na inicializacao, mesmo removendo o applehda.

 

O voodoo que tentei usar e a versao 2.7.2, sera que ela e compativel?

Por que ele esta dando panic kernel quando uso o voodoohda?

Share this post


Link to post
Share on other sites
Remova o Extensions.mkext da pasta Extra tb

tenta com essa voodooHda

VoodooHDA.kext.zip

 

se continuar dando problemas, eu vou remover o HDEF do DSDT

 

 

Removi o applehda e o extensions.mkext, e em seguida instalei o voodoohda, no boot nao deu panic kernel :D , faz ate um barulho no alto falante durante o carregamento o voodoohda, quando carrega a area de trabalho esta disponivel o icone( altofalante), dando pra ajustar o volume, porem nao sai nenhum audio.

 

Acho que agora estamos chegando perto.

 

UM detalhe alem do voodoohda esta instalado o hda enabler e o legacy, pode deixar esses dois instalados junto com o voodoohda?

Share this post


Link to post
Share on other sites
Removi o applehda e o extensions.mkext, e em seguida instalei o voodoohda, no boot nao deu panic kernel :D , faz ate um barulho no alto falante durante o carregamento o voodoohda, quando carrega a area de trabalho esta disponivel o icone( altofalante), dando pra ajustar o volume, porem nao sai nenhum audio.

 

Acho que agora estamos chegando perto.

 

UM detalhe alem do voodoohda esta instalado o hda enabler e o legacy, pode deixar esses dois instalados junto com o voodoohda?

 

remova a HdaEnabler e a legacy

deixe só a VoodooHda

Share this post


Link to post
Share on other sites
remova a HdaEnabler e a legacy

deixe só a VoodooHda

 

Removi os dois, faz um barulho no carregamento do voodoohda, porem dentro do sistema grafico mac nao tem som, ele possibilita ajustar o volume.

 

Removi os dois, faz um barulho no carregamento do voodoohda, porem dentro do sistema grafico mac nao tem som, ele possibilita ajustar o volume.

 

Outro detalhe interesante, rodei aquele programa que vc me indicou, abri o arquivo kernel, ele mostra todo o processo de inicializacao do sistema, uma das linhas aparece (Dec 12 21:19:16 iMac-de-Daniel kernel[0]: Codec #2: Realtek ALC888 (vendor ID: 10ec, device ID: 0888)), entao significa que ele reconheceu o chip realtek acl888. Agora por que nao tem som no mac?

Share this post


Link to post
Share on other sites
Removi os dois, faz um barulho no carregamento do voodoohda, porem dentro do sistema grafico mac nao tem som, ele possibilita ajustar o volume.

 

 

 

Outro detalhe interesante, rodei aquele programa que vc me indicou, abri o arquivo kernel, ele mostra todo o processo de inicializacao do sistema, uma das linhas aparece (Dec 12 21:19:16 iMac-de-Daniel kernel[0]: Codec #2: Realtek ALC888 (vendor ID: 10ec, device ID: 0888)), entao significa que ele reconheceu o chip realtek acl888. Agora por que nao tem som no mac?

 

Eu sinceramente não sei, isso não tem mistério a VoodooHda funciona(não mt bem) pra quase todos

dê uma conferida nas entradas

Vc está usando audio frontal?

Share this post


Link to post
Share on other sites
Eu sinceramente não sei, isso não tem mistério a VoodooHda funciona(não mt bem) pra quase todos

dê uma conferida nas entradas

Vc está usando audio frontal?

 

Nao, eu ligo na parte de tras do pc (conector verde).

Share this post


Link to post
Share on other sites
Nao, eu ligo na parte de tras do pc (conector verde).

Eu sinceramente não sei

 

dê uma busca pela sua Mobo no fórum, as vezes tem uma kext que funcione pra vc

Share this post


Link to post
Share on other sites
Eu sinceramente não sei

 

dê uma busca pela sua Mobo no fórum, as vezes tem uma kext que funcione pra vc

 

blz, obrigado

 

Quando eu descobri a solucao eu posto no forum.

Share this post


Link to post
Share on other sites
blz

o ideal é vc ir testando algumas versões da VoodooHda, uma funciona com certeza

 

http://www.sendspace.com/file/stsxeg

 

Boa tarde,

 

Finalmente consegui instalar o audio no snow leopard, após varias brigas resolvi fazer uma instalacao nova do snow, apos instalar puxei o combo 10.6.5. Apos instalar o combo rodei o programa [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], escolhi a opcao [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], depois reparei que tem uma opcao Advanced Options, no submenu dele temos o Kexts, Audio, LegacyHDA, ACL888. Escolhi a opcao ACL 888 correspondente a minha placa.

 

Apos a reinicializacao o som funcionou finalmente. :D

 

O mac esta rodando 100%, ele reconheceu também o video e esta operando numa resolução de 1680x1050, reconheceu ate a FireWire(dificilmente irei usar). Ja rodei filmes, musicas e ate agora esta tudo normal.

 

Primeiramente gostaria de agradecer ao fórum Insanelymac e ao usuário MaLd0n pela ajuda e sua rapidez nas respostas.

 

Tenho algumas duvidas, como posso saber se meu sistema esta trabalhando a 64 bits?

Qual antivirus para mac vcs me recomendariam?

Share this post


Link to post
Share on other sites
Tenho algumas duvidas, como posso saber se meu sistema esta trabalhando a 64 bits?

Qual antivirus para mac vcs me recomendariam?

 

roda uname -v no terminal pra saber se está em 32 ou 64

Mac não precisa de Antivírus, o último foi visto a 500 Milhas da costa :D

;)

Vc não está usando o DSDT?

aquele DSDT tem vários fixs "obrigatorios", como IRQs etc

se vc quiser eu removo o HDEF, já que vc conseguiu o áudio

Share this post


Link to post
Share on other sites
roda uname -v no terminal pra saber se está em 32 ou 64

Mac não precisa de Antivírus, o último foi visto a 500 Milhas da costa :D

;)

Vc não está usando o DSDT?

aquele DSDT tem vários fixs "obrigatorios", como IRQs etc

se vc quiser eu removo o HDEF, já que vc conseguiu o áudio

 

Esta trabalhando a 32 bits o sistema.

 

Nao usei o DSDT, se puder remover o Hdef eu agradeço.

 

Outra coisa como instalo esse arquivo DSDT na maquina?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×