Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
clockworks

osx kicks me back to Windows bootloader, no errors

5 posts in this topic

Recommended Posts

I installed 10.4.6 HotISO and followed the chain loading instructions. So when I reboot my machine, the windows boot loader gives me two choices: Windows or OSX. I choose OSX and immediately get shown the Windows boot loader screen again. No errors or anything.

 

I am sure that OSX is installed on a primary partition as well as it has the boot flag. I tried copying the kernel from the install DVD over the kernel that got installed, just to be sure. It didn't help.

 

My machine is a Pentium M Centrino laptop (Dell Inspiron 6000d).

 

Any ideas? Thanks for the help.

Share this post


Link to post
Share on other sites
I installed 10.4.6 HotISO and followed the chain loading instructions. So when I reboot my machine, the windows boot loader gives me two choices: Windows or OSX. I choose OSX and immediately get shown the Windows boot loader screen again. No errors or anything.

 

I am sure that OSX is installed on a primary partition as well as it has the boot flag. I tried copying the kernel from the install DVD over the kernel that got installed, just to be sure. It didn't help.

 

My machine is a Pentium M Centrino laptop (Dell Inspiron 6000d).

 

Any ideas? Thanks for the help.

 

Mine does this too

 

what works for me is i hit enter and then instantly hit F8 Key then the Darwin bootloader shows and u can choose OSX ........... wierd but easy

Share this post


Link to post
Share on other sites
Mine does this too

 

what works for me is i hit enter and then instantly hit F8 Key then the Darwin bootloader shows and u can choose OSX ........... wierd but easy

Awesome, thanks...that fixed the problem.

 

Did you notice when the Darwin bootloader comes up, your Windows (or Linux) partition shows up before the OSX partition? Maybe the Darwin bootloader is set to load the first entry by default..? Mine looks like this:

 

NTFS hd(0, 1)

OSX hd(0, 2)

 

Maybe it just automatically tries to boot the first entry.

Share this post


Link to post
Share on other sites
Awesome, thanks...that fixed the problem.

 

Did you notice when the Darwin bootloader comes up, your Windows (or Linux) partition shows up before the OSX partition? Maybe the Darwin bootloader is set to load the first entry by default..? Mine looks like this:

 

NTFS hd(0, 1)

OSX hd(0, 2)

 

Maybe it just automatically tries to boot the first entry.

not to sure.... it didnt do it till i used 10.4.6 or later for some reason

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×