Jump to content
Sign in to follow this  
Followers 0
MaLd0n

Instalação do Snow Leopard na GA G31M-S2L / Vanilla SpeedStep

53 posts in this topic

Recommended Posts

221661.jpg

 

O que você vai precisar:

 

- CD do HackBoot

-DVD do Snow Leopard

- Chameleon-2.0-RC5

- DSDT Auto-Patcher

- Pasta Extra Extra.zip

 

Procedimentos:

Antes de começar a instalação, vá no bios e dê um Load Optimized Defaults

loadopt.jpg

 

Instalação

 

Dê o boot pelo HackBoot

capturadetela20100606s0.png

 

Remova o CD, insira o DVD do Snow Leopard, aguarde alguns segundos e pressione F5, então selecione o DVD e pressione Enter.

capturadetela20100606s0.png

 

*Se você não consegue chegar na tela de instalação, repita o procedimento digitando “-x” na tela acima.

 

Depois de dar o boot pelo dvd e escolher “usar português do brasil como idioma principal” espere aparecer a tela “Instalar Mac OS X". Vá no menu superior “Utilities --> Disk utility”, selecione o HD que deseja formatar e vá em “particionar(partition)”. Na aba “atual(Volume Scheme)” escolha o número de particões que você deseja, lá embaixo vá em “opções(Options)”, clique e escolha “GUID”, depois selecione “Mac Os Extended (Journaled)(Mac OSX Expandido [Reg. Cronológico])” vá em aplicar e espere.

 

diskutility.jpg

 

guidb.jpg

 

Terminando esse processo encerre o utilitário de disco.

 

Selecione o HD para a instalação e prossiga.

 

Se você receber a mensagem “Mac OS X could not be installed on your computer” no final da instalação como mostrado na foto abaixo...Não se preocupe. :)

 

03500pxslinst7.png

 

Clique em restart.

 

Faça o boot novamente com o HackBoot CD

Chegando na tela do Chameleon, escolha a sua nova instalação do Snow Leopard

*Se você está tendo problemas, faça o boot com "-x"

 

O sistema está rodando, mas não inicializa sem o HackBoot, então temos que instalar o bootloader(Chameleon), as kexts essenciais e o DSDT

 

Pós Instalação

 

1- Instale o Chameleon-2.0-RC5 (na partição do Snow Leopard ou na EFI)

2- Copie a pasta Extra para o seu HD ( / ou na EFI)

capturadetela20100712s0.png

3- Execute o DSDT Auto-Patcher e copie o DSDT que vai ser gerado para a pasta Extra

 

Native Power Management e Restart fix use Chameleon RC5

 

Instalador Chameleon RC5

 

Adicione no boot.plist

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

mald0n20100922s202502.png

 

loveapple2117454552imag.gif

Share this post


Link to post
Share on other sites
Advertisement

Maldon, parabens por mais um tuto brilhante!

Ainda estou a tentar os DSDTs, o audio ate funfou!!! Mais o problema ainda continua com o CMOS reset, nao consigo faze-lo estabilizar. do resto ta blz!!!

 

Valeu por enquanto irmao!

 

Abraços

Share this post


Link to post
Share on other sites

Ola galera vou tantar esses procediemtos mas em um sistema ja instalado so pra corrigir a opçao o resetCMOS e tambem a possibilidade da correçao do meu audio, e so uma pergunta a rede de vcs esta trabalhando bem, se tiver preciso de ajuda pois nao consigo fazer a minha carregar normalmente.

Share this post


Link to post
Share on other sites
Qual o áudio?

 

Pra rede vc pode usar uma kext, se não funcionar nativamente

 

:(

 

em versoes anteriores usava o appleHDA como audio e fincionava bem e a rede usava a kext R1000 mas quando instalo essa kext ela nem carrega.

Share this post


Link to post
Share on other sites
Uma instalaçao simples com o Kext utilities resolve ou tem um procedimento padrao pra ela funcionar..

 

sim

 

yel06.png

Share this post


Link to post
Share on other sites

Veja se você não tem a mesma kext em mais de um lugar, por exemplo:

 

/Extra/Extensions

/System/Library/Extensions

/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns

 

Deixe apenas uma kext para a sua placa.

Share this post


Link to post
Share on other sites
Veja se você não tem a mesma kext em mais de um lugar, por exemplo:

 

/Extra/Extensions

/System/Library/Extensions

/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns

 

Deixe apenas uma kext para a sua placa.

Bem oldnapalm o hardware da minha placa de rede é reconhecido mas ele fica com uma mensagem de IP-auto atribuido e nao consegue conectar ja tentei o modo PPPoE mas tambem sem sucesso ::::/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns nessa pasta ai que vc disse tinha um monte de kext de rede la mas so deletei duas que davam erro no boot mas nao sei se resolve alguma coisa..

Share this post


Link to post
Share on other sites

Olá pessoal!

 

Estou muito interessado em comprar essa placa, mas eu queria saber se a placa de vídeo onboard funciona, não quero gastar dinheiro comprando uma off.

 

Obrigado.

Share this post


Link to post
Share on other sites
Olá pessoal!

 

Estou muito interessado em comprar essa placa, mas eu queria saber se a placa de vídeo onboard funciona, não quero gastar dinheiro comprando uma off.

 

Obrigado.

 

Essa GPU não tem suporte no Os X

 

Um ótimo custo benefício é a NVidia 9500

Share this post


Link to post
Share on other sites

Obrigado pela resposta rápida, mas eu não queria gastar com placa de vídeo off pelo menos agora.

 

Queria que você desse uma olhada nessas duas placas, pelo que eu pesquisei ela tem um grande suporte, até a placa de vídeo on-board.

 

GA-945GCMX-S2 http://br.gigabyte.com/products/product-pa...spx?pid=2521#ov

 

GA-945GCM-S2C http://br.gigabyte.com/products/product-pa...spx?pid=2668#ov

 

O que você acha?

Share this post


Link to post
Share on other sites

Entendi, mas para ver vídeos no YouTube em HD ela conseguiria rodar numa boa? O que eu não quero é desempenho ruim com flash. No meu outro hackintosh com uma FX5500 é triste, fica bem fraco para jogos e principalmete algo em flash.

Share this post


Link to post
Share on other sites
Entendi, mas para ver vídeos no YouTube em HD ela conseguiria rodar numa boa? O que eu não quero é desempenho ruim com flash. No meu outro hackintosh com uma FX5500 é triste, fica bem fraco para jogos e principalmete algo em flash.

 

cara

o desempenho é bem fraco sim

essa NVidia 9500 tá 150 R$

Share this post


Link to post
Share on other sites

Olá MaLd0n, como vai?

 

Bom, final de semana fui na Santa Ifigênia e rodei o dia todo e nada de achar uma Gigabyte, tive que comprar uma Asus a P5G41T-M LX2/BR fabricada aqui no Brasil.

 

Bom ela tem o chipset G41 Express + ICH7, daí no kit comprei o novo Pentium E5500, 2GB RAM DDR3 e HD 500GB SATA Seagate. Agora estou com problemas e espero que você possa me ajudar, eu criei um tópico aqui: http://www.insanelymac.com/forum/index.php?showtopic=241164

 

Dê uma olhada e me responde se puder, já tentei várias distros, configurações na BIOS e nada. Já vi umas pessoas terem sucesso com essa placa, mas eu não consigo.

 

Obrigado.

Share this post


Link to post
Share on other sites
Olá MaLd0n, como vai?

 

Bom, final de semana fui na Santa Ifigênia e rodei o dia todo e nada de achar uma Gigabyte, tive que comprar uma Asus a P5G41T-M LX2/BR fabricada aqui no Brasil.

 

Bom ela tem o chipset G41 Express + ICH7, daí no kit comprei o novo Pentium E5500, 2GB RAM DDR3 e HD 500GB SATA Seagate. Agora estou com problemas e espero que você possa me ajudar, eu criei um tópico aqui: http://www.insanelymac.com/forum/index.php?showtopic=241164

 

Dê uma olhada e me responde se puder, já tentei várias distros, configurações na BIOS e nada. Já vi umas pessoas terem sucesso com essa placa, mas eu não consigo.

 

Obrigado.

 

Use um cd de boot

pode ser o [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], HackBoot, Nawcon

use o -x -v na instalação

Share this post


Link to post
Share on other sites
Use um cd de boot

pode ser o [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], HackBoot, Nawcon

use o -x -v na instalação

 

Eu já fiz isso, quando não dá esse erro dá outro mas sempre relacionado a ACPI "Unable to find ACPI driver" (Bem parecido com isso).

Share this post


Link to post
Share on other sites
Eu já fiz isso, quando não dá esse erro dá outro mas sempre relacionado a ACPI "Unable to find ACPI driver" (Bem parecido com isso).

 

Vc está esperando carregar o DVD e só depois apertar F5?

 

Teste o DVD do Snow tb

Share this post


Link to post
Share on other sites
Vc está esperando carregar o DVD e só depois apertar F5?

 

Teste o DVD do Snow tb

 

Sim, eu espero o DVD carregar daí eu aperto F5, o nome do disco aparece e o resto é isso. Eu estou tentando mexer com o DSDT.aml mas quando fui compilar depois de remover os alias ele deu vários erros, daí fiquei nervoso. Eu percebo que na tela do empire efi ou de qualquer outro bootloader ele dá um erro relacionado a ACPI e DSDT.aml juntos. Acho que eu editando o arquivo pode dar certo, mas não consigo.

 

Me arrependi de pegar essa placa-mãe, ter que ficar usando Win me dá mau humor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×