Jump to content

iphone won't be recognised after restart!

2 posts in this topic

Recommended Posts



I recently successfully installed iATKOS S3 (10.6.3) on my desktop system, the specs for those interested are as follows:

- GA-X48-DQ6 motherboard

- Core 2 Duo 3.16GHz

- 8800 GTS 640MB


Everything worked out of the box. Good job on iATKOS team. Anyway, about my problem..


I used Migration Assistant to transfer my settings and applications from my Mac Mini to the new desktop, all went smoothly. However, when I tried to sync my iphone with iTunes (OS4), the device was not recognized in the left iTunes panel. I re-installed iTunes 9.2, which allowed me to successfully sync.. I was happy, but then I restarted the system, tried to sync, and nothing! Anyway, it seems that after every restart, iTunes won't sync with the iPhone. And the problem also exists in XCode, the Organizer cannot "see" the iPhone.


I followed several steps I found on the internet, including deleting DeviceLink.framework, AppleMobileDevice.kext, re-install iTunes, start iPhone in DFU mode, nothing could fix my problem. When I restarted the system, iTunes would not sync with the device. Only an iTunes re-install can fix it, which of course is not what I want, I can't re-install iTunes everytime I start my computer.


Does anyone have ideas / solutions? I think I have tried everything..

Oh by the way, I am running 10.6.4 now, I successfully updated from iATKOS base system, I don't know if that helps.


Thanks a bunch


Okay, it is fixed. For those interested, if you have the iPhone OS 4 SDK, there is an issue that won't let you sync your device with iTunes or XCode Organizer.


Open Software Update, Apple released an update that fixes this issue, it's called "iPhone SDK Compatibility Upgrade".

Installed, restarted, works ;)

Link to comment
Share on other sites


  • Create New...