Jump to content

Intel D865 PERL

Jay Cee

8 posts in this topic

Recommended Posts

Hi guys,


Greetings from Brazil! I've been trying to get OS X installed on my PC for a bit over a year now, but no luck so far. My PC configuration, supposedly all compatilble, is as follows:


-> Intel D865 PERL mobo (with onboard soundmax)

-> Pentium 4 2.66 GHz (instructions MMX, SSE and SSE2)

-> 4 GBytes of RAM

-> GeForce4 MX 440 graphics board 128 MB with AGP 8X

-> Samsung 500 GBytes SATA HD


-> USB Optical Mouse

-> PS/2 Keyboard

-> Network D-Link DFE-530TX PCI


Since I have already tried a zillion thing and it still doesn't work, I'm obviously doing something very wrong, so I just have a few basic questions:


1) What is the best OSX86 package for my configuration?

2) What are the best BIOS settings for the D865 PERL mobo?

3) Anybody out there with similar configuration who actually got it working?


Thank you guys for reading this long post. I'd really appreciate whatever help I can get. Take care y'all.


Best regards,


Jay Cee :(

Link to comment
Share on other sites

Try JaS 10.5.4 Client/Server if you can find it, it's easy to install on a i865 based board.


As a minimum you'll need to pick the following under 'Customize':


Chameleon bootloader

Stage XNU 9.4.0 kernel (precursor to the Voodoo Kernel)

Disabler.kext or nullAppleIntelCPUPowerManagement.kext

DSMOS.kext or AppleDecrypt.kext (both do the same thing)


It's a bad idea to mix USB keyboard and PS2 mouse and vice versa. You should preferably have all USB input devices.


i865 is usually paired with ICH5. In IDE (PATA) mode you'll need AppleIntelPIIATA.kext.


I recommend installing OS X on its own drive. Run Apple Disk Utility before starting the installer, partition and format the drive as GUID, HFS+ Journaled, non-case sensitive.


ICH5 should have a couple of different modes to set in the BIOS, "compatible", "enhanced" and something else. If you have trouble booting, experiment with these. Also you might have to switch your drive order around. If you're using IDE (PATA) drives, make sure you're using 80 conductor IDE cables and if you're having problems try cabling and jumpering each IDE (PATA) device as master and use one IDE channel for each.


Enable ACPI 2.0 and APIC in the BIOS, and enable all advanced CPU features except CPUID limit. Turn off unnecessary hardware such as serial- and parrallel ports, floppy drive etc. Experiment with turning Hyperthreading off (assuming your CPU supports it) if you can't boot the install DVD.


If your motherboard as standby jumpers for the USB ports, make sure all of them are set to +5V standby and that your power supply can handle it. Refer to your motherboard manual if you're unsure about the jumpers.


If you can't boot the DVD at all no matter what you do, try a CMOS reset (refer to your motherboard manual). Unplug your PSU and keep the CMOS reset jumper closed for 10 minutes. Remember to set all the BIOS settings back as they were.


MX series Geforce 4 cards are not supported by the nvidia drivers that come with OS X. You can get basic VESA framebuffer graphics going with no hardware acceleration, which is not a lot of fun on OS X. Many apps depend on HW acceleration and won't run at all without it.


As you can see if you visit this thread: http://www.projectosx.com/forum/index.php?showtopic=4 you'll need as a minimum a 6xxx series card to get full acceleration up until 10.5.8 with unmodified drivers.


There's no AGP acceleration - AGP cards will work at 33MHz PCI Bus speeds. This is fast enough for everyday use but for 3D games you'll have to run in 640x480 to get playable framerates, no matter how awesome your AGP card is. There's been some work done on an AGP driver but it does not work with the 865 chipset.

Link to comment
Share on other sites

Hi Gringo Vermelho,


Wow! Thank you very much for all the valuable info. I had already tried the exact JaS distro you suggested, but it simply wouldn't work. However, after I made the BIOS changes you suggested, I tried iDeneb 10.5.5 just for the heck of it. I did a default install and I didn't change any options. It finished the installation successfully, but it failed to restart the system properly. Now, hoping you won't mind me picking your brain again, what options should I select during the iDeneb install for my hardware configuration? Once again, thanks a million! I appreciate all your attention time and help.


Best regards,


Jay Cee :)

Link to comment
Share on other sites

I have never installed ideneb so I can't say anything specific.


Eject the DVD and boot from your hard drive with -v (mash F8 repeatedly after BIOS POST to get to the Chameleon boot prompt) to see error messages and other important stuff. Attach a photo (use the full editor to attach files) of what it looks like when it stops booting and maybe I can help.


The good news is, if you can complete the installation process, it means you can use your ideneb DVD to make a working install, so if you're impatient and don't want to wait for me to look at your verbose boot photo, keep trying. Try selecting just the minimum, don't pick graphics/network/sound or anything, just kernel, bootloader, disabler and decrypter (DSMOS or AppleDecrypt).


For the record, I'm serious about not mixing USB and PS2. Get a USB keyboard as soon as you can.

Link to comment
Share on other sites

You're right. My graphics board and PS/2 keyboard are most likely messing up. I'm buying new ones on monday.


Anyway, I did as you suggested in the previous post. Once again, installation successful. At system restart, I rebooted using -v -x and got the following error messages:


waiting for boot device

still waiting for boot device

still waiting for boot device

still waiting for boot device


It looks as though it would wait forever. What do you think?

Link to comment
Share on other sites

It's "root device", and yes it will continue like that for all eternity if you leave it.


It means OS X can't talk to your SATA controller (you use all SATA drives, right?).


You need to install a driver for it - it's on the DVD you're using, otherwise you would not have been able to install at all.


Look for something with Intel ICH in the name, should be under 'chipset drivers'.

Link to comment
Share on other sites

Hi Gringo Vermelho,


Success at last! Your suggestion about the SATA option fixed the issue. The installation finished successfully, as before, and now the system restarted without a glitch! Thank you for all your expertise.


My video still kind of sucks, good resolution but no acceleration. I`m getting a GeForce 9600 board soon anyway.


Got my sound card and network adapter also up and running! I`m actually replaying to this post on my Hackintosh!


Once again thanks for everything. You`re the best!


Um grande abrasso,



Jay Cee ;)

Link to comment
Share on other sites


  • Create New...