Jump to content

Realtek 8196 Ethernet was working now it's not


5 posts in this topic

Recommended Posts

Hope somebody can point me in the right direction to get this working again.


I have a Gigabyte GA-EP45-UD3L motherboard that was running a vanilla Snow Leopard install fine for over a month now. I actually installed it on the disk using a genuine Apple MacBook, installed chameleon RC4 then put the disk in the hackintosh and got everything working. Ethernet worked right from the start and I didn't have to do anything AFAIK. The Ethernet is hooked up to a Buffalo router running as a bridge to my main router. All of this was working fine until...


Today, I opened it up to make some additions:

- added one more HD for total of 4

- installed PCI-E x1 eSATA card based on SiliconImage 3132 chipset

- installed Realtek 8192S chipset WiFI N USB adapter from monoprice (selected because a couple of user reviews said it worked fine on Snow Leopard)


Software-wise, I installed:

- SiliconImage3132.kext for the eSata card


When I first booted this up after the hardware and driver installs, the drive connected to eSATA showed up right away so I knew the Silicon Image board was working fine. I opened Safari and got no internet connection. Network prefpane showed no Ethernet cable connected (although it was plugged in). But after a few replugs of the cable (no effect) and a reboot of my router/bridge, suddenly an IP address showed up and everything was working fine.


I then proceeded to try to get the USB WiFi device working (the idea was to eliminate the need for the router/bridge and connect directly to my main router over WiFi). I ran the installer for the drivers that came with the USB WiFi and it installed RTL8192SUI.kext in System/Library/Extensions and a GUI in /Applications. After rebooting, the USB WiFi still wasn't working, and my wired Ethernet no longer worked.


It now consistently detects a cable but DHCP fails and it goes to a self-assigned IP address. I tried switching cables, rebooting router/bridge and testing the same connections on my MacBook (works fine). I ran the uninstall on the Realtek drivers with no change. I also removed the SiliconImage eSATA drivers with no change. I removed the (en2) interface from Network prefpane, removed the IONetworkingFamily plist and rebooted to let it rebuild and then re-added (en2) but still nothing.


My Firewall is off. System Profiler still shows the Ethernet Controller kext loaded from /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleRTL8196Ethernet.kext


It seems like I should be back to my original config, but I'm out of ideas...any suggestions on how I can get this back working?



Link to comment
Share on other sites

ok, i'm pretty sure at this point that it isn't a kext problem, but higher up in the networking stack, because:


- the Ethernet status changes instantly if I unplug the ethernet cable and when I replug it, it changes again, going through not plugged in, to status cannot be determined and finally self-assigned IP.


- the HackPro's MAC address shows up in my router's DHCP list. I went into my router control panel while the ethernet to the hackintosh was unplugged and saw that it actually did have an IP address assigned for that MAC address. I deleted that lease so the HackPro wasn't in the list any more. I plugged in the ethernet cable again and it went through the process described above and ended up with a self assigned IP. I refreshed my router's DHCP list and the HackPro's MAC address is back in the list on the router!


- I noticed that the HackPro shows up in my Macbook's Finder windows under SHARED as "MacPro-MACADDRESS". This same item shows up on the HackPro's own SHARED list. If you click on it and try to share screen or connect file sharing, nothing happens.


So it seems like the problem does not lie with kexts or drivers but something in the networking stack is messing up the handling of the DHCP assignment.


It's a different ballgame now...any suggestions now?



Link to comment
Share on other sites

  • 7 months later...
ok, i'm pretty sure at this point that it isn't a kext problem, but higher up in the networking stack, because:



Did you ever get this fixed? six months ago....


I've got a similar problem: GA P55A-UD3 with RTL8111E ethernet. Using Lnx2's kext/driver I had it working OK. I use an Apple Magic Mouse via an el cheapo usb plugin. Then I switched on AFP, Apple File Sharing over TCP. Could not get it to work, in or out, to or from another real Mac I've got. At this point I saw the internet was gone. Network Utility showed that the IPnr from my ISP had been assigned to the Blutooth DUN. So I pulled the dongle, flushed all Blutooth and internet settings and caches, rebooted, still no go.


I'm using PPPoE, it connects to my ISP. tcpdump shows normal negotiation and packet exchange, and bad guys probing my ports wacko.gif I can open a Terminal window and ping or traceroute right across the planet, but there is no connection between this transport layer and the application layer on the stack. Mail.app just sits there dumb, Safari & Firefox quick as a wink say "You are not connected to the Internet".


I have a spare PCI card here, RTL8169, plugged that in, AppleRTL8169 loaded automatically, but still same story. There's nothing wrong with the chips, both nics work 100% when I reboot into my alternative Ubuntu 10.04 sad.gif

Link to comment
Share on other sites

FIXED (for me) :blink: Bonjour, aka. mDNSResponder, Apple's Magic Genie that replaces all the functions of AppleTalk and resolv.conf and who knows what else. Safari and similar high level apps assume that if mDNS is not available there is no network.

How to tell if mDNSResponder is working? Utilities/Activity Monitor, or in the Terminal, top, or ps -awx

How to tell if it tried to start and failed? tail /var/log/system.log or tail /var/log/kernel.log

How to tell what is keeping it off? /var/db/launchd.db/com.apple.launchd/overrides.plist

How to turn it on and keep it on? sudo launchctl -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist.


I dunno what turned it off, and now I don't care wink_anim.gif

Link to comment
Share on other sites

  • 4 months later...

Ok Im in LION

I have a usb WIFI adapter with the same chipset and runs the same kext 8192S


I'm also having intermittent issues and complete dead connection at times that can only be resolved with a reboot.


Weird thing is........ when i turn on my ethernet connection suddenly the wifi works and assigns me an IP THROUGH MY ETHERNET :)


any advice??????????


also to *hiroo your're using the card in 32bit mode right? because the kext is 32 bit only last time i checked....

Link to comment
Share on other sites


  • Create New...